7 Replies Latest reply: Sep 9, 2013 12:38 PM by ajm_from_WA
Omniver Level 1 Level 1 (10 points)

I've had a constant issue where Network Users can't use Messages or FaceTime.  The apps load, but just don't work (messages don't get sent or received, FaceTime connections abort just after starting). 

 

This issue always occurs when the user is logged in to a client and the home directory is mounted from the file server (AFS)

 

The apps work fine if the user is logged in locally to the server or using Portable Home Directories.

 

I thought this was some misconfiguration on my network, but I just did a fully clean install on two brand-new systems, one as a client, one as a server (OD/FileSharing/DNS) and the probem is fully reproducable.  I don't see anyone else mentioning this not working.

 

Is this working in your environments?


OS X Mountain Lion
  • awaldraff Level 1 Level 1 (0 points)

    It does work for me. However, I have an issue whereby after a PHD sync, the system wil require me to login again to both, messages and facetime.

     

    I know the problem lies in the ~/Preferences folder, because I tried syncing the PHD ignoring ~/Preferences and it worked flawlessly..

     

    I just haven't been able to isolate which files get out of whack after the synchronization so I can ignore them..

  • awaldraff Level 1 Level 1 (0 points)

    I meant to say the ~/Library folder not the ~/Preferences folder

  • thomas45344 Level 1 Level 1 (0 points)

    awaldraff,

     

    did you figure out which files to exclude to prevent Facetime/iMessage from password prompting?

     

    So far I've tried to exclude several files starting with "com.apple.FaceTime, com.apple.imservice or com.apple.imessage" in the User's Library folder. Whereas this seems to prevent imessage/facetime to ask for login password for a couple of hours, the issue re-appears at next day. Without exhaustive testing I'd assume that this happens whenever the same user logs on to different client computers.

     

    I'm not convinced that one can solve this issue by excluding files from sync. It looks like your appleID gets tethered to User and device at Facetime/iMessage login. Whenever there is a mismatch in device name and user profile iMessage/Facetime ask for password prompt once again.

     

    Can anyone confirm this?

     

    Regards,

    Thomas

  • awaldraff Level 1 Level 1 (0 points)

    unfortunately not..  in fact my situation is now worse. In my trials I probably messed something up, and now on my iMac, Messages needs to be closed and restarted everytime.

  • ajm_from_WA Level 1 Level 1 (10 points)

    I do have trouble with messages.  don't use facetime.

     

    I have 8 users who share 6 imacs.  All are using network user accounts, home folders are on the server.  not using portable home directories (that was a complete disaster).

     

    Messages often times asks the user to enter their password again.  It seems like it happens after someone different is using a shared computer.  IE if User 1 has been using iMac 1, and then the next day User 2 uses iMac 1, messages will ask User 2 for their messages password.

     

    the real problem though, is that entering the password doesn't work.  It usually acts as if messages is being setup for the first time again, and the only way that we can get it working is to skip all the setup prompts (if you try to follow them, messages just crashes), and then goto messages preferences and enter it manually.

     

    I've been suspicous that it has something to do with trying to tether user IDs to the computers, but i can't prove it, and don't know why its a problem.  Notably, it doesn't seem to be a problem if you use a local user account on the computer. 

     

    weird.

  • jb86 Level 1 Level 1 (0 points)

    Did you make any headway on this?  I'm having the same issue, clients with portable home directories work fine, but not network users.

  • ajm_from_WA Level 1 Level 1 (10 points)

    Gave up on using server months ago.  We are slowly re-exploring it again now to see if we can get it working reliably