4 Replies Latest reply: Dec 22, 2012 4:24 AM by iamp
iamp Level 1 Level 1 (0 points)

According to "do not disturb" usability, Can I mute notifications from text message and emails as well?

iPhone 4S, iOS 6.0.1
  • gail from maine Level 6 Level 6 (17,475 points)

    Hi iamp,


    Do you want to disable it for the two items, or set "Do Not Disturb" - two different functions....



  • sberman Level 7 Level 7 (28,115 points)

    This excerpt from the iPhone User Manual says if the iPhone is locked and Do Not Disturb is on, you will not receive any notifications.



    1. Do Not Disturb and Notifications

      Push notifications appear in Notification Center and alert you to new information, even when the associated app isn’t running. Notifications vary by app, but may include text or sound alerts, and a numbered badge on the app icon on the Home screen.

      Turn off all notifications: Go to Settings and turn on Do Not Disturb. When it’s turned on and iPhone is locked, all notifications and calls are silenced, but alarms will still sound. You can set the following options in Settings > Notifications > Do Not Disturb:

      • Automatically turn on Do Not Disturb: Set the starting and ending hours for when you don’t want to be disturbed. iPhone turns on Do Not Disturb during these hours each day.
      • Allow some phone calls during Do Not Disturb: When Do Not Disturb is on, calls are silently sent to voice mail. To allow some callers to ring through, tap Allow Calls From. You can allow calls from your Favorites list or other Contacts groups you define. For information about Favorites, see Chapter 25, Contacts, on page 100.
      • Allow persistant callers to ring through: Turn on Repeated Calls. If the same caller (based on their Caller ID) calls you twice within three minutes, iPhone will ring.


  • iamp Level 1 Level 1 (0 points)

    Thanks to gail, I already turn on the Do not disturb function but I still got email message alert sound.


    I go to setting> notifications> Do not disturb.

    Set the schedule to current time

    Try calling > no sound - correct

    Try text message > no sound - correct

    Try send email > have sound - why?


    I think, do not disturb function should mute all sounds, shouldn't it?

  • iamp Level 1 Level 1 (0 points)

    Thank you, sberman.

    It's very useful. I got it already. The function will turn off all sound when "home screen is lock".


    My screen should have been unlocked.

    Thanks to you again for the suggestions in detail.