4 Replies Latest reply: Dec 22, 2012 6:01 PM by Brooklyn Lion
Brooklyn Lion Level 1 Level 1 (0 points)

Whenever I try to scan anything with CanoScan LiDE 700F scanner my computer gives the message "scanner reported an error. An error ocurred while communicating with the scanner." I have to unplug and plug back the USB port and only hten it opens up.  When I try to open the scanner with System Preferences, scanner opens up, but as soon as I hit "scan" the same error message pops up.  I uploaded the latest driver from Canon website, but the problem persists.  I also deleted and re-installed the sanner in system preferences, but it didn't help.

It used to work fine when I initially installed it (on Leopard), but then suddenly this problem arose.


iMac, OS X Mountain Lion (10.8.2)
  • 1. Re: CanoScan LiDE 700F Scanner not opening up
    PAHU Level 6 Level 6 (14,510 points)

    This same error message was first noticed on 10.6. It would only occur after waking the Mac from sleep. Prior to the sleep state you could scan using Image Capture without error. But if the Mac entered a sleep state with the scanner connected, after waking it and then trying to scan, the error message would appear. And as you have found, the quick solution is to unplug the USB cable and then reconnect it.

     

    This problem only occurs with Canon scanners that use USB power. The models that have their own power supply, or the All In One devices with scanner, do not suffer the same fate. Apple Engineering is aware of this and have told me that it is up to Canon to fix.

     

    Note that the same problem does not occur when using Canon's MP Navigator application. This application uses the full TWAIN-based scanner driver, whereas Image Capture and Preview use the ICA driver, and works fine after waking the Mac from a sleep state.

  • 2. Re: CanoScan LiDE 700F Scanner not opening up
    Brooklyn Lion Level 1 Level 1 (0 points)

    Thanks!  I guess the problem will not be fixed any time soon unless enough people contact Canon.

  • 3. Re: CanoScan LiDE 700F Scanner not opening up
    PAHU Level 6 Level 6 (14,510 points)

    Brooklyn Lion wrote:

     

    I guess the problem will not be fixed any time soon unless enough people contact Canon.

    Even then I personally doubt that they would fix it. They would tell you it is an Apple problem and that their application (MP Navigator) works fine. And given that it does not occur with 10.5, it does appear that Apple changed something in the OS to cause this.

  • 4. Re: CanoScan LiDE 700F Scanner not opening up
    Brooklyn Lion Level 1 Level 1 (0 points)

    Thanks for mentioning MP Navigator!!  This was the application I tried to get to and couldn't remember the name of!  Actually, it makes scanning much simpler and faster.