Skip navigation

how can I use my CanoScan LiDE 35 on Mac OS 10.8.2

8681 Views 30 Replies Latest reply: Mar 31, 2014 2:15 PM by RolfdeKoning RSS
1 2 3 Previous Next
NobbyKnees Calculating status...
Currently Being Moderated
Dec 22, 2012 6:21 PM

I recently moved upto OS 10.8.2 and find that my trusted CanoScan Lide35 can no longer give me the service it has being giving me all these years.  On checking the Canon site, I'm informed that there are 'no drivers' for this OS.  Does this mean I shall have to replace my scaner (as I have concluded) or.... has some genius found a way round it? NK

iMac (24-inch Early 2008), OS X Mountain Lion (10.8.2)
  • John Galt Level 7 Level 7 (33,105 points)

    NobbyKnees wrote:

     

    ... On checking the Canon site, I'm informed that there are 'no drivers' for this OS.  Does this mean I shall have to replace my scaner

     

    It seems that way:

     

    Screen Shot 2012-12-22 at 9.26.23 PM.png

     

    As of Lion all scanning functions are incorporated natively in OS X.

     

    Try the following:

     

    • Use Preview: File > Import from scanner
    • Use Image Capture

     

    Preview and Image Capture are both in your Applications folder.

     

    If nether method works, the CanoScan is using a communications method no longer supported. If Canon is not interested in updating its drivers, you might be out of luck.

  • John Galt Level 7 Level 7 (33,105 points)

    It is going to be a personal decision; if you have extensive knowledge of imaging or scanning your criteria are likely to be different than mine.

     

    There are many scanners on the market, including Canon if you happen to like them. A good place to start would be Apple's website but there is not much of a selection from which to choose.

     

    They seem to be overpriced too. There are many "all in one" devices that also print and copy, and since they are less of a niche product their prices tend to be much more competitive than dedicated scanners.

     

    These days I like Brother products. They are well supported and have a better warranty than most, and they have several "all-in-one" models for less than $100.

     

    For recommendations, research their user reviews (Amazon for example) and disregard all that do not specifically mention the Mac or OS X. Regard any that do not have the ring of truth with a healthy degree of skepticism; same for reviews written by those with questionable literacy skills. Augment this research by going to the manufacturer's website to confirm what you learn.

     

    Then, find the best price and buy it.

    MacBooks  iMacs  iPods  AirPorts, OS X Mountain Lion,  27 years Apple!
  • Mike Sombrio Level 6 Level 6 (9,100 points)

    You CAN continue to use your Cannon scanner, download VueScan http://www.hamrick.com/

    They have a free trial version that will show you that your scanner will work in ML. Then you'll have to purchase the full version. I have it, I have a Cannon LiDE 35 and I use it under Mountian Lion.

  • John Galt Level 7 Level 7 (33,105 points)

    Good find Mike!

  • Mike Sombrio Level 6 Level 6 (9,100 points)
    Currently Being Moderated
    Dec 22, 2012 8:09 PM (in response to John Galt)

    I was upset when I upgraded then found VueScan, I really like my Cannon Scanner will hate to have to replace it someday.

  • D.R.C. Level 1 Level 1 (145 points)

    @Mike,

    I'm in the same boat as the OP, wanting to use my old LIDE 35 on Mountain Lion. I followed the link you posted for VueScan. According to Hamrick's website, "you need to install a Canon scanner driver to use the LIDE 35 scanner on Mac OS X".

    Further, it says that "this scanner is supported on Mac OS X Lion and later if you first install the Canon scanner drivers".

    http://www.hamrick.com/vuescan/canon_lide_35.html

     

    I went to the Canon website, and found the same thing that John Galt reported above: there are no LIDE 35 drivers available for OSX 10.8.

     

    Mike - can you indicate where you obtained the Canon driver for Mountain Lion.  If you didn't install a driver, how did you get the LIDE 35 working on ML?  Perhaps the information on hamrick's website is incorrect.

     

    Thanks.

  • D.R.C. Level 1 Level 1 (145 points)
    Currently Being Moderated
    Feb 5, 2013 7:06 PM (in response to D.R.C.)

    @Mike,

    Some more info on this.  I downloaded the trial version of VueScan.  It doesn't see the Canon LIDE 35.  Apparently, a Canon driver is required, as per the information published at hamrick.com. Can you detail the steps you took to get your LIDE 35 working on ML?

     

    I ran the OSX System Profiler and checked the USB bus.  It reports that the LIDE 35 is connected, but indicates it "has not been configured". That's consistent with there being no driver loaded.

     

    Dave

  • Mike Sombrio Level 6 Level 6 (9,100 points)
    Currently Being Moderated
    Feb 6, 2013 5:09 AM (in response to D.R.C.)

    I don't recall doing anything involving Canon drivers. I'm not on my iMac right now but when I am I'll check it out.

  • D.R.C. Level 1 Level 1 (145 points)

    @Mike,

    Thanks for looking into this for me.

    Did your iMac come from the factory with Mountain Lion installed, or was it upgraded from a previous Snow Leopard installation (or earlier)?  I'm wondering if perhaps the iMac has a old Canon driver on it from Snow Leopard, that is still being used by ML.

     

    My MacBook Air came from Apple with 10.7, subsequently upgraded to 10.8. It's never had any Canon software on it.

     

    I'll stay tuned. I've also e-mailed hamrick.com for their input.

     

    Dave

  • Mike Sombrio Level 6 Level 6 (9,100 points)
    Currently Being Moderated
    Feb 6, 2013 7:53 AM (in response to D.R.C.)

    I upgraded from Snow Leopard, that very well could be why it works. I will still. Heck it out for you though.

  • D.R.C. Level 1 Level 1 (145 points)

    That's good news, in a way. In theory, I should then be able to get the SL driver from Canon website and shoehorn it into Mountain Lion.  But it's not clear how to move from theory to practice!

  • Mike Sombrio Level 6 Level 6 (9,100 points)
    Currently Being Moderated
    Feb 6, 2013 9:58 AM (in response to D.R.C.)

    Well now bad news. My scanner doesn't work anymore. Just like yours it shows connected but not configured. I haven't used it since I posted that it worked back in December, but I know it worked. Now it doesn't. I don't know if something updated that made it unavailable or what. The plug in I was using is ScanGear CS 7.2.5.2X for Mac OS X, but now it flat out refuses to work. I'm trying to figure it out, but not having much luck either.

    I was able to download and run CanoScan Tool Box 4.9 but it says it can't find a driver to open.

  • D.R.C. Level 1 Level 1 (145 points)

    @Mike,

    Sorry to have exported my bad karma onto your system:-(

     

    I've found this thread:

    https://discussions.apple.com/thread/3192066

     

    It's about getting a LIDE 60 working on Lion, using the SL driver. About a third of the way down is a long recipe posted by "7p".  Not exactly the same configuration, but maybe it will help.  I have not yet tried it - I'm going to clone my hard drive with SuperDuper before I attempt it (that's if I don't get a simpler solution back from Ed Hamrick). 

     

    Will update this thread if I have any luck.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.