8 Replies Latest reply: Jul 31, 2013 2:39 PM by spuDaisy
Steven Springer Level 1 Level 1 (5 points)

Has this function disappeared from iTunes 11, or is it just hiding?  I find it incredibly useful for live albums and if it's gone it's really a big loss.  Thanks for any and all help.


iMac, OS X Mountain Lion (10.8.2)
  • the fiend Level 5 Level 5 (7,860 points)

    It's hiding!

     

    When the CD is in the drive, awaiting importing, look on the right hand side, under Options. Note that the Join CD Tracks only appears once you have selected the tracks; see the two screenshots below. The first one, without two adjacent tracks selected:

    Capture68.PNG

     

     

    and this one, when two or more adjacent tracks are selected:

     

    Capture69.PNG

     

    Hey presto!

  • Steven Springer Level 1 Level 1 (5 points)

    Thanks!

  • the fiend Level 5 Level 5 (7,860 points)

     

  • Chalcis Level 1 Level 1 (0 points)

    I have the same problem that the original poster had.  I have done all of the suggested steps in this dance and I am still unable to "join CD tracks.'  Can you find anything else in that bag of tricks?

  • the fiend Level 5 Level 5 (7,860 points)
    • You can only join tracks on CD tracks, not imported MP3s or with online purchases.
    • You can only use join CD tracks before starting the import the CD procedure.
    • You must select two or more adjacent tracks before the Join CD Tracks option is displayed. This means tracks 1&2, 4&5 or even 1,2,3,4,5 & 6. You cannot join tracks 1&4, 3&1 or similar.

     

    So, at which point do you get stuck?;

    1. Are you trying to join tracks on a CD?
    2. When you have the CD in your drive, you select two or more adjacent tracks, and look on Options, is join CD tracks showing up?
    3. Click on Join CD tracks. Do the two songs titles combine?
  • stacy223 Level 1 Level 1 (0 points)

    I am having the same problem. I have put the CD in, selected the tracks by holding down the shift key (have also selected all from drop down menu), then I open up the options at the top right hand side of the screen and my only options continue to be Get Info or Send Info. I am using a Dell Latitude laptop and have no problems until this update. I hope you can help me. I feel like I must be overlooking something very simple here. oh, I have also checked the track numbers and they are numbered from top to bottom 1-14 and are all checked.

    Thanks in advance for any help you can give me.

  • the fiend Level 5 Level 5 (7,860 points)

    Stacy,

     

    That all sounds as though it's correct. The only three four things I can think of at this time (assuming you've followed the points I've made in both my previous posts) are:

    1. The track numbers you see are the iTunes list numbers in the left hand column, aren't they? They're not numbers in the track titles are they?
    2. As you will see in my two screenshots below, if the numbered column is in reverse order, the Join CD Tracks isn't visible. So even though you have that column in correct "front" order, try a reversal to see if it makes any difference. (I don't expect it to!)

     

    Note the difference:

    Capture228.PNG

     

     

    Capture229.PNG

     

    Any luck? If not;

       

         3. Try selecting just the first two tracks. Does the Join CD Tracks appear? If it does, try selecting the first three songs and check to see if the Join CD Tracks still appears. Do this until you find the song that's preventing you from joining all the tracks.

         4. Perhaps the combined track titles make the filename too long. When tracks are joined, they acquire the filename of all the tracks, separated (I believe) by an underscore. If you think this might be the problem, try shortening the track names before joining them. Find the first track to tip this over the balance, and then shorten both its title and the song prior to that one. If that works and you can then join those songs, that's the fix. Try it only as a last resort.

  • spuDaisy Level 1 Level 1 (0 points)

    make sure you are sorting your tracks by the check mark not by artist name or album. I accidently sorted my tracks by a different column and that greyed out the join cd tracks option.