1 Reply Latest reply: Dec 23, 2012 9:30 AM by lllaass
Georgoula Level 1 Level 1

I did whatever it says step by step but again it not Sync the games .


iPod touch, iOS 4.2
  • lllaass Level 10 Level 10

    Are the apps/games compatible with your model iPod and iOS. Yu say you have iOS 4.2 which implies a 2G iPod since a 2G can only go as high as iOS 4.2.1. Many apps now requires a higher iOS. The Requirements section of the App description lists the requirements for the app.