Previous 1 2 Next 26 Replies Latest reply: Aug 7, 2014 8:01 AM by frankhebo
WaterBottle-_- Level 1 Level 1 (0 points)

I just purchased a Electra 3G SSD from OWC and installed it into my 2009 Macbook Pro 2.26Ghz 4GB of ram. However, everytime I launch iPhoto it gets the beachball "stall" icon for about 20 full seconds. Does anyone know what the deal is. I am using a fresh Install of Mountain Lion (about a week in use) and iPhoto 09 (with all the latest firmware updates from Apple). It is very frustrating and I am hoping someone on here who is very experienced has a solution. 

I did install Snow Leopard off of a CD and then upgraded it with Mountian Lion from the app store if that makes a difference.

 

 

 

Thanks so much to anyone who helps,

I will be eagarly waiting for a response.


MacBook Pro, OS X Mountain Lion (10.8.2)
  • LarryHN Level 9 Level 9 (71,015 points)

    turn internet off and see if that affects the start up speed

     

    LN

  • WaterBottle-_- Level 1 Level 1 (0 points)

    You're right, it stopped after I unplugged the ethernet cord from the computer!

     

    However, I do need internet. Is there any known fix that you are aware of so that It wont stall even when I have my ethernet cord plugged in (which is about 100% of the time)? I dont use wireless or bloothooth on my MBP, and have both turned off. Appreciate it!

    Thanks!

  • LarryHN Level 9 Level 9 (71,015 points)

    That indicates that it is looking for something - probably syncing to facebook or flickr - make all web services manual sync instead of automatic - and turn off any sharing options

     

     

    LN

  • WaterBottle-_- Level 1 Level 1 (0 points)

    Well, I dont have any of those services enabled. Im not sure if "sharing" is on, but when I look at preferences under the sharing tab the only one that is checked is the "Look for shared photos" and I treid disabling that and restarting but it still stalled. Flickr, Facebook, Moblile me, Mail icons are all greyout at the botton and unclickable. I have never set them up on this new fresh Install of Mountain Lion? Am I disabling the "sharing" correctly?

     

    Thanks.

  • Old Toad Level 10 Level 10 (130,305 points)

    Make a temporary, backup copy (if you don't already have a backup of the library) and try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/com.apple.iPhoto folder (Snow Leopard and Earlier).

    home.PNG

    or with Mt. Lion from the User/Library/Containers/com.apple.iPhoto/
    Data/Library/Caches/com.apple.iPhoto
    folder

     

    iP11mtlioncache.png

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

     

    If you have problems locating the cache file don't worry about it.  The key file to delete and rebuild is the preference file.  Once you relaunch iPhoto reset the iPhoto prefs to what you want.


     

    OT

  • WaterBottle-_- Level 1 Level 1 (0 points)

    Thanks Toad, however, I dont have that com.apple.iphoto.plist file. The closest I could find in the Preferences folder was a iLife09.playlist. Option number 2 wont work as im using Mountain Lion, not Snow Leopard or earlier. When I tried the Mountain Lion route you provided, I couldnt find the Containers folder? Maybe this is becuase I am using iLife 09 on Mountain Lion? I find it odd that when I dont have the ethernet cable plugged in, iPhoto doesnt stall, it only happends when I am connected to the internet. I've also tried the command and option method various time to no avail.

     

     

    When I launch iPhoto 09, the beachball starts spinning, however if I unplug the ethernet cord it automatically stops, and I can use iPhoto normally.


    If I dont unplug the cord, it stalls for about 20 seconds before it allows me to use the applicaton.

     

    Any suggestions? Thanks.

  • Old Toad Level 10 Level 10 (130,305 points)

    Make sure you're looking in the correct Library folder.  In Mt. Lion it will be invisible so follow the instructions to make it visible and then go to your Home/Library/Preferences folder for the preference file.

  • WaterBottle-_- Level 1 Level 1 (0 points)

    Screen Shot 2012-12-27 at 2.24.49 PM.png

    Those are all of the contents in my folder.

    To get there I clicked my Hard Drive desktop icon, then Library, then I found the References folder. Those are all of the contents that are inside.

  • Old Toad Level 10 Level 10 (130,305 points)

    Here's the library you want to look in:

    HomePrefFolder.PNG

     

    The house icon is your home folder and will be named with your short account name.  If you've run iPhoto even once you will have a file titled com.apple.iPhoto.plist. 

     

    You can download and use  Find Any File   to search for com.apple.iPhoto.plist.  FAF can search areas that Spotlight can't, like invisible folders.

  • WaterBottle-_- Level 1 Level 1 (0 points)

    You.Sir.Are.Awesome. That seemed to work, after I finally found that iPhoto.plist file using that "FIND ANY FILE APP! The reason I coudn't find it without that app is becuase I didnt have a "Preferences" Folder when I clicked the home icon. Since you seem to be tech savvy, do you have an idea as to why that is. In fact, this is what I have listed under the home folder. Toad Pic.png

    (Desktop, Documents, Downloads, Movies, Music, Pictures, Public, Send Regristaration, and Sites) No Preferences folder under there. The Pref folder I was looking in was the one under Library/Preferences (see below) and that iPhoto.plist wasnt here?!

    Toad 2.png

     

    Even more interesting is that that "Find Any File" app says its here:

     

    Toad Final.png

     

    Any idea as to why this is the case? By the way, dont worry,I will give you best answer for solving my inital and primary issue. I am just wondering if you know why this is the case with the preferences folder since you seem to be experienced with Mac OS. Thanks!

  • Terence Devlin Level 10 Level 10 (135,020 points)

    The User Library is hidden by design in 10.7 and later.

     

    On 10.7 or later: Hold the option (or alt) key while clicking on the Go menu in Finder to access the User Library

  • WaterBottle-_- Level 1 Level 1 (0 points)

    Thanks Toad.

     

    Blehh, I just started up iPhoto and it gave me the wheel, so its back. However, it was gone for a while since I deleted it.

     

    I guess Im just going to have to deal with it. Now I know if it gets really bad, I could keep deleting the iPhoto.plist file..

     

    Thanks again!

  • Old Toad Level 10 Level 10 (130,305 points)

    Try rebuilding the library's database flie as follows:

    make a temporary, backup copy of the library if you don't already have one (Control-click on the library and select Duplicate from the contextual menu) and try the following:

     

    1 - launch iPhoto with the Command+Option keys held down and rebuild the library.

     

    iP93rebuild.PNG


    2 - Since only one option can be run at a time start with #1 followed by #3 and then #4 (do all of those).

  • WaterBottle-_- Level 1 Level 1 (0 points)

    I tried that, but it also didnt work. Now even if I delete the iphoto.plist file in the preferenes folder, the wheel still spins. Its odd that this only happens when im connected to the internet. I feel like it has something to do with communicating/connecting to the Apple Servers. It is the older version (iPhoto 09) and that message keeps popping up (upgrade to the new version message) but I dont need nor want to. I did click the "do not show this message again" but I still feel like it does something like this in the background where it tries to communicate with Apples Servers and that causes the stall possibly? A little side note, I dont have any services enabled like Facebook, Flickr, etc. Nor did I enable GPS photo tracking as I thought these could possibly cause a stall.

     

    I just dont know.

     

    But thanks for all the help Toad, I appreciate it.

Previous 1 2 Next