1 Reply Latest reply: Mar 3, 2013 12:59 PM by koolbl
Xenolab Level 1 (0 points)

Season's Greetings Everyone,


I've read on another post that OS X Lion supports the Emagic AMT8 and Unitor MIDI interfaces, and the driver can be installed by connecting the unit, turning it on and then doing a software update to get the driver. Can anybody confirm that Mountain Lion offers the same support?


I've got a lot of legacy MIDI gear including a pair of Emagic AMT8 MIDI interfaces which are believe are USB 1.1 spec. I was planning on buying one of the new Mac Minis which have only USB 3.0 ports, and I've read that USB 3.0 is compatible with USB 2.0 device, but it seems that 3.0 is not compatilble with 1.1. Some comments have said the 1.1 devices will work if plugged into a 3.0 port, but my gut is telling me that might only be "simple" devices like a mouse or keyboard. Has anybody successfully used an AMT8 or Unitor 8 with a new Mac Mini or iMac with USB 3.0?


Thank you - and I hope Santa brings you all the Apple hardware and software you desire.

Logic Studio, OS X Mountain Lion (10.8)
  • koolbl Level 1 (0 points)

    I just purchased a Mac Mini also and... just purchased the Emagic AMT8 myself. I've never used the AMT8 before and with the new Mac Mini and the latest OS, along with a new audio interface and a host of new software, etc., I've got 100 questions to hope and have answered.


    I'm trying to find out myself if the AMT8 will be compatible with the Mac Mini's 3.0 USB. I thought I heard that it will work with Logic Pro. I myself am currently experimenting with Studio One Artist. My 2nd consideration is Cubase. Logic Pro is at the bottom of my list so I'm hoping if it does work at all with the Mac Mini it will even work with more than just one program.


    Anyone out there with any such advice would be appreciated!