Previous 1 2 Next 19 Replies Latest reply: Mar 19, 2015 10:24 AM by Lemonly Go to original post
  • Donut5 Level 1 (0 points)

    Worked for me too! I had also reset network settings, then realised I had disabled set time automatically and location settings - reset and all fine now, thanks!

  • Zaddion Level 1 (0 points)

    None of the solutions seemed to have worked for me. iOS 6.1.6 iPod touch 4th gen

  • Cam-Fox22 Level 1 (5 points)

    I spoke to a senior advisor this afternoon and I was told it's a known issue and they are currently working on it. He told me it could take up to a couple of weeks to resolve. We will all have to sit tight and wait I'm afraid

  • Paul Matsuda Level 1 (95 points)

    in Settings/iCloud click on your name and if it asks for your password enter it. Then go back to iMessage or FaceTime and try to login.

  • Lemonly Level 1 (10 points)

    I have an old iPod Touch with old software that can no longer be updated:

    iOS version 6.1.6

     

    I've been searching for a solution to my iMessage login problem for months and tried everything from those frustrating links and all the tips from other users.

     

    Here is what finally worked:

     

    1) Settings > Privacy > Location Services > On

    2) Settings > General > Date & Time > Set Automatically > On

    3) Reboot device until Apple logo appears

    4) Settings > Messages > Sign In

Previous 1 2 Next