9 Replies Latest reply: Dec 25, 2012 1:21 PM by Linc Davis
Eldor Level 1 (0 points)

My new MacBook Air connects to my local network and the Internet just fine via WiFi but after about 5 minutes (if I'm watching a video, or 50mb if I'm downloading something) it drops the connection.  The only way I've found to get it working again is to turn off WiFi and then turn it back on again.  I don't know where to turn to get help on this...


Other WiFi connections to the Internet work perfectly, without any stability issues at all.  What doesn't work properly is my new MB Air, or any iOS gadgets running iOS 6.x.  (I've returned two iPad Mini's because of this problem, thinking that it was a hardware problem with the Mini's and an iPod Touch which was working perfectly with iOS 5.x has also started dropping the connection since I upgraded it to iOS 6.0.1.)


Multiple iPad's (original and iPad2, iPhones (4S's), and iPod Touch work perfectly on the network, as do several PC computers connected via WiFi.  I have the same problem at my home and office networks (same configurations) and also had it during a two-night hotel stay when I was trying to use the iPad Mini.  It would connect fine, but drop the connection every few minutes.


I'm sure the problem is something in my WiFi routers, (doesn't explain the hotel problem) but don't understand why earlier iOS gadgets work perfectly and newer iOS 6.x or my MB Air do not.


I'm running a Cisco WAP4410N WiFi router, connected by wire to a "switch".  Then between the switch and my cable modem, I've got a hardware firewall (Cisco RV220W) with its own WiFi turned off.  I don't have a DHCP server, but use Static IP addresses.


If I connect the MB Air directly to my network via Ethernet cable, it works perfectly (suggesting to me that the problem is only in the WiFi part of my network configuration and not related to my Cisco firewall).  Also, for testing purposes, if I bypass my entire network configuration and use an Airport Extreme router connected directly to my cable modem, WiFi connections through it to the Internet work perfectly without any drops.


Where/how could I get help solving this?  Thank you.

  • Linc Davis Level 10 (192,325 points)

    Pretty much everything you can do yourself to solve the problem is contained in this article:


    Troubleshooting Wi-Fi issues

  • Eldor Level 1 (0 points)

    I've already gone through that article, Linc.  But thanks anyway.


    One of the first things it says is that, "Usually, if other computers or devices (such as the Apple TV or iPhone) are able to get on the Internet without issues, then your Wi-Fi router is probably fine."


    In spite of the fact that three iPads, two iPhones and an iPod Touch (not to mention several PC computers with WiFi) work perfectly, I've gone through the entire trouble-shooting steps.  No luck.


    Leaving aside the brand new MacBook Air for the moment, what could possibly have changed in iOS 6.x over 5.x to cause WiFi instability issues on the same networks?  Whatever it is, also affects the brand new MB Air as well.

  • Linc Davis Level 10 (192,325 points)

    Have you tried changing the channel on your router? Are you on the 5 GHz band?

  • Eldor Level 1 (0 points)

    No, I'm not running 5 GHz.  And I have tried changing the channel on my router, although I didn't think it would make a difference as it's not an interferrence issue... (as far as I can determine) because from the same location with the same gadgets running, iOS 5.x devices work perfectly and 6.x devices don't.  Including the new MB Air.  And at my home network there are no other WiFi devices anywhere (heck, I can barely even see my neighbors homes from here!).


    I repeat, simply changing from iOS 5.x on my Touch to 6.0.1 caused the WiFi connection to become regularly disconnected.  iPad Mini's (two of them of course with iOS 6.x) had the same problem.  Now the new MB Air also has the problem.  Older iOS devices with iOS 5.x work PERFECTLY.  Every setting has been set, reset, checked, etc.  Obviously some setting in my WiFi router isn't compatible with newer iOS 6.x devices or the new MB Air, and I have no idea what it could be.


    I'm real frustrated, and have no idea where to look for help.  As near as I can figure out, those newer Apple devices don't like WiFi networks with fixed IP (no DHCP server) addresses.


    What setting(s) could possibly allow for initial connection but then drop the connection 5 minutes or 50mb later?  Only way to get it reconnected then is to turn off WiFi and turn it back on again.  That was the only way I was able to download software to my new MB Air.  Keep watching the d/l progress, and when it stalls and before it can abort, turn off the WiFi and turn it back on, resume the d/l.  Frustrating!


    Thank you for trying to help.

  • Linc Davis Level 10 (192,325 points)

    I'm not running 5 GHz.


    Try it.

  • Eldor Level 1 (0 points)

    My WiFi routers don't support it.


    Besides, why should my new MB Air NOT work on my network when several iPads and iPhones, etc. DO?  They're not running 5 GHz either.

  • Linc Davis Level 10 (192,325 points)

    You seem to be asking me to debug your whole network. I can't do that. Nor do I know of any secret button you can push to fix it. You're using obsolete equipment. The sensible course of action, in my opinion, is to replace it.

  • Eldor Level 1 (0 points)

    What makes you think I'm asking YOU to do anything???  I'm asking for help from the community, and if you don't feel like trying to help, don't be a p____k about it.  Just don't help.


    Obviously I don't know anywhere near enough to solve this on my own, and I was hoping to at least get some pointers here about where to look for help.  My WiFi routers are less than a year old, still current models from Cisco, and they work perfectly with my other (including Apple) WiFi products.  Something's changed with the newest MacBook Air and iOS 6.x devices which has obviously turned up some kind of error/mis-configuration in my WiFi routers, and as far as I can see, if the same Apple devices running iOS 5.x work perfectly here, upgrading them to iOS 6.x should still allow them to work.  My own network is one thing, but geez, if you travel you end up in hotels where you run into the same problems... you can't go around telling them all that their equipement is obsolete.  Especially if iOS 5.x gadgets work perfectly and iOS 6.x don't.


    I hope someone else might be able to give at least a little guidance here.


    Happy Holidays to you.

  • Linc Davis Level 10 (192,325 points)

    Just don't help.


    Don't worry. I won't make that mistake with you again.