1 Reply Latest reply: Dec 25, 2012 1:36 PM by randers4
tinafromthe woodlands Level 1 (0 points)

My i phone 4s calendars have not been automatically syncing to my i cloud calendars.  I have noticed my phone apple ID is the primary one and my i cloud is using the secondary apple id.  I am able to log into i cloud using both IDs.  I believe the problem is the ID s are not the same on each.  I believe if I change my i cloud ID to the primary ID it will fix the issue but I can't figure out how to change it.


iPhone 4, iOS 5
  • randers4 Level 9 (62,715 points)

    To do this you will have to go to Settings>Mail,Contacts,Calendars and delete the secondary account (this only deletes it from your phone, not from iCloud).  Then go to Settings>iCloud and tap Delete Account to delete the primary account.  Next sign into your former secondary account ID in Settings>iCloud, making it the primary account.  If you wish, you can then go to Settings>Mail,Contacts,Calendars>Add Account>iCloud and add the former primary account as your secondary account.