Previous 1 2 3 4 5 Next 66 Replies Latest reply: Jul 12, 2014 4:31 AM by enrico.cataldi Go to original post Branched to a new discussion.
  • Old Toad Level 10 (135,487 points)

    I don't think we've suggested this yet: 


    1 - delete the iPhoto preference file,, that resides in your

         User/Home/Library/ Preferences folder.


    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/ folder (Snow Leopard and Earlier).


    or with Mt. Lion from the User/Library/Containers/



    3 - launch iPhoto and try again.


    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.


    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

  • cfrombarrhead Level 1 (0 points)

    Thanks I tried it and it worked until iphoto closed and reopened then back to problem.

    I could not find the cache file and when I tried using terminal, never having used it before, I copyed the chflags nohidden ~/Library and nothing happened except message no such folder.

    What have I done wrong?

  • Terence Devlin Level 10 (137,945 points)

    In the finder hold down the alt key and click on the Go menu to access the User Library.

  • cfrombarrhead Level 1 (0 points)

    Thank you very much

  • cfrombarrhead Level 1 (0 points)

    I have deleted from the prefs folder and cache.db from the cach folder.

    emptyed trash, restarted the computer and opened iphoto.

    Again on first opening the edited photo it opens at correct size ie not magnified, but on closing iphoto and reopening the problem returns.

    I did notice that in the prefs folder next to is a file called, should this be removed too?

  • mfog Level 1 (0 points)

    I have the same problem. It's with editing photos with external editor. I've set up iPhoto '11 (version 9.4.2) with Photoshop Elements 10 (version 10.0) as external editor. I'm on an iMac running OS X Mountain Lion (10.8.2).


    First I'll explain the problem, as I see it. Second I'll report what I've learn from my investions on the problem. But before this let's estabilish the basics:


    When editing an original photo (that is a photo that is untouch/unchanged since the import into iPhoto) iPhoto will make a copy of this particular photo within the iPhoto library. The original photo is still in the library – in a folder called "Masters". The edited version of the photo – the version of the photo that one sees in iPhoto – is in a folder called "Previews".


    The problem: Editing a photo with an external editor seems to be fine. Coming back to iPhoto both the thumbnail and the photo it self is updated as expected (now showing the edited version).


    But as others have reported, in a following session of iPhoto (hereby I mean after iPhoto has been quit and then once again started/executed) I experience two problems; 1) the size in pixels stated by iPhoto in the Info Panel is incorrect, and 2) the display of the photo (double click on a thumbnail brings you to the display) is only showing a portion of the photo. The portion is a "zoomed in" of the lower left corner of the photo. I know that others have reported that they see a "zoomed in" portion of the upper left corner of the photo.


    If a photo has been edited with an external editor it is no longer possible to edit within iPhoto. A message is given that this particular has been edited outside iPhoto or with prior versions of iPhoto.


    What I've learned: The incorrect size/dimension of the same edited photo (problem #1) is different from each iPhoto session (see above what I mean by session). The size of the iPhoto window when starting a new iPhoto session – that is, the size of the iPhoto window when quitting the preceding session – is thus somehow defining the incorrect size/dimension stated for the edited photo. I've found a correlation between the incorrect size and the "zoomed in" portion displayed: The size/dimension of the "zoomed in" portion (problem #2) is equivalent to the incorrect size/dimension stated for the photo!


    In the same session the problem #2 is only seen if the iPhoto window is in full screen mode or is maximized.


    Others have suggested that it should be a problem with Photoshop (Elements). This is not the case. I've tried editing with a different external editor (Pixelmator) and still experience both problems. I've even substituted an edited version of the photo (in the "Preview" folder) with the original version (a dublicate from the "Masters" folder) and still see the problem. Actually iPhoto still gave the message that the photo had been edited outside (with an external editor). I therefore believe that iPhoto somehow keeps control of "originals" and "edited" versions in the database/xml-file – no matter the actual file.


    In conclusion it seems to be a problem with photos that has been edited in an external editor (or that iPhoto believes has been edited in an external editor). This will (in a following session) trigger the problem #1. And if the iPhoto windows is maximized or in full screen mode one will also experience problem #2.

  • Old Toad Level 10 (135,487 points)

    I was finally able to reproduce the problem with PSE 10. This problem doesn't exist when using Photoshop CS3.  


    Noticed another issue.  When trying to subsequently edit the photo with iPhoto I get this message:



    This happens with CS3 as well as PSE 10.   I'll report it to Apple via as well as everyone who is experiencing this issue.


    UPDATE:  I did find that the image dislpayed properly when iPhoto is put into full screen mode.

  • Old Toad Level 10 (135,487 points)

    Here's some more quirks that I've found.  If I reduce the iPhoto window until this edge:


    i.e. the background to the right of the image disappears to this:


    the image displays fully in the window.


    Also if the image is deselected in the photo tray at the bottom of the window:


    and then reselected it will display correctly.  Some really strange behavior.  The same goes with the full screen mode.

  • tricker13 Level 1 (0 points)

    I have the same problems with CS4 11.0.2 and iPhoto 9.4.2. Furthermore, when trying to email the photos using Mail, the photo is the zoomed version on the lower left corner...rendering email edited photos in Photoshop useless at this point.


    Looking forward to an Apple fix.

  • apogos Level 1 (5 points)

    I have exactly the same problem. Externally edited photos zoomed in automamtically in iPhoto.


    Lion 10.7.5, iPhoto 9.4.2 (710.42), Photoshop CS5.

  • sojourner42 Level 1 (0 points)

    It occurred to me that this problem did not occur in a previous version in which an image was duplicated and displayed in the grid view when tapped for external editing. I'm guessing Apple messed up when they tried to fix that. Not sure that helps any of us, but maybe someone will get an idea.

  • sojourner42 Level 1 (0 points)

    Does anyone know if Aperature has the same problems? I'm about ready to chuck iPhoto.

  • apogos Level 1 (5 points)

    Aperture doesn't have this problem because it makes a duplicate of a photo you wish to edit in external editor and puts it in the library, and then opens it in external editor. So after editing and saving in photoshop you will have both photos in you library: unedited and edited one.

  • apogos Level 1 (5 points)

    When you edit your photo either in iPhoto or in external editor, it saves new version in Previews subfolder of your iPhoto library. Strange thing is though, it scales down photos if you edit them in iPhoto.


    So my camera produces 4000x3000 images, around 5 mb each. After editing with Photoshop they retain same resolution. After editing in iPhoto though, they become 2984x2238 (25% less) and around 2 mb in size (60% less). Shouldn't software at least give a little warning about this?

  • Old Toad Level 10 (135,487 points)

    What sort of edits are you performing with iPhoto?  How are you determining the pixel dimensions of the photos you've edited with iPhoto that show a smaller dimension?


    Actually, when I edit a photo in iPhoto the file size is getting larger (as seen in the Info window in iPhoto) which is strange.


    Try this:  launch iPhoto with the Option key held down and create a new, test library.  Import some photos and check to see if the same problem persists.