1 2 Previous Next 17 Replies Latest reply: Dec 6, 2013 5:53 PM by Paris_01
ginger_debra Level 1 Level 1 (0 points)

Normally I just plug in my phone or camera, go to iPhoto, and hit import, but as of today it won't work. Earlier today I plugged in my iPhone 4, and it wouldn't let me import my photos. Thinking it was just my phone being slow I unplugged it and went on with my day. And now tonight (after being at a family party) I plugged my camera into my computer, but it won't let me import those photos either! I've never had this problem before and am wondering if anybody has any ideas as to what's wrong? Thanks!


iPhoto '11, Mac OS X (10.6.8)
  • 1. Re: I can't import my pictures into iPhoto?
    Terence Devlin Level 10 Level 10 (123,865 points)

    Any error messages?

  • 2. Re: I can't import my pictures into iPhoto?
    hamed.tehrani Level 1 Level 1 (0 points)

    I have the same problem.

    No error message. iPhoto does not recognise my iPhone and all 4 other iDevices.

    When I connect my camera, Picture Capture will launch automatically but iPhoto not.

  • 3. Re: I can't import my pictures into iPhoto?
    Terence Devlin Level 10 Level 10 (123,865 points)

    When I connect my camera, Picture Capture will launch automatically but iPhoto not.

     

    What is set to launch in the iPhoto Preferences?

  • 4. Re: I can't import my pictures into iPhoto?
    hamed.tehrani Level 1 Level 1 (0 points)

    I have set iPhoto to be launched when iPhone is connected. But when I connect my to my iMac, iPhoto won't launch and when I open it manually I can not see my iPhone in it. It is happened since 2 weeks ago.

     

    On the other hand when I insert a sd card of my canon camera, iPhoto will launch as expected and I can see the sd card and an IMPORT button appears then I can import my pix to iPhoto.

     

    I have also tried to create a new photo library but it did not work.

    I have also tried to rebuild my iPhoto library but it did not work.

  • 5. Re: I can't import my pictures into iPhoto?
    Terence Devlin Level 10 Level 10 (123,865 points)

    Create a new account (systempreferences -> accounts or Users & Groups on 10.7 and 10.8), make a new Library in that account, import some shots  and see if the problem is repeated there.

  • 6. Re: I can't import my pictures into iPhoto?
    hamed.tehrani Level 1 Level 1 (0 points)

    Thanks Terence for your time.

     

     

    I did it but problem is still there. I have also tried it with other accounts on my Mac. it did not work.

  • 7. Re: I can't import my pictures into iPhoto?
    Terence Devlin Level 10 Level 10 (123,865 points)

    To re-install iPhoto

     

    1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)

     

    2a: On 10.5:  Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.

     

    2b: On 10.6: Those receipts may be found as follows:  In the Finder use the Go menu and select Go To Folder. In the resulting window type

     

    /var/db/receipts/

     

    2c: on 10.7 they're at

     

    /private/var/db/receipts

     

    A Finder Window will open at that location and you can remove the iPhoto pkg files.

     

    3. Re-install.

     

    If you purchased an iLife Disk, then iPhoto is on it.

     

    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.

     

    If you purchased it on the App Store or have a Recent Mac you can find it in your Purchases List.

  • 8. Re: I can't import my pictures into iPhoto?
    hamed.tehrani Level 1 Level 1 (0 points)

    I do appreciate your help and advise Terence

     

    I have already done it twice! No success.

    I have also restored my iPhone to factory settings. No success.

  • 9. Re: I can't import my pictures into iPhoto?
    Momnipotence Level 1 Level 1 (0 points)

    I can't either.  It shows that my phone is connected, but when I try to upload images I get an error message saying that the following files are corrupt - and it lists all of the ones I'm trying to upload.  On my other computer I just went through losing my entire iPhoto library and having to start all over, I've spent many many hours with iPhoto for my business on this laptop, I really don't want to have to start from scratch on this one as well, and it looks ilke that wouldn't matter anyway.

     

    So what do we do?

  • 10. Re: I can't import my pictures into iPhoto?
    Terence Devlin Level 10 Level 10 (123,865 points)

    As a Test:

     

     

    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'

     

     

    Import a few pics into this new, blank library. Is the Problem repeated there?

  • 11. Re: I can't import my pictures into iPhoto?
    Dr. Jones 8 Level 1 Level 1 (0 points)

    I just had the same problem. My labtop was connected to an external hard drive and when I disconnected from the hardrive it started to work and import the photos. I don't know if this helps you but it worked for me.

  • 12. Re: I can't import my pictures into iPhoto?
    boots16 Level 1 Level 1 (0 points)

    I've had this issue for several weeks, too ... I did at Terence suggested (hold the Alt key while opening iPhoto) ... it avails the option to open a different library, or create another one.

     

    now ... I'm trying to merge the libraries

     

    I don't know why this happened ... but like the OP said ... I'd get the error message on every photo which iPhoto attempted to load from the iPhono5.

     

    Related ... I may have lost my original library by download some pix from another iPhone (not synced, just got the pix) ... ????  maybe a seperate thread?

  • 13. Re: I can't import my pictures into iPhoto?
    marshmist2 Level 1 Level 1 (0 points)

    I am having trouble importing photos from my iphone 4S to my PC.  Error message says:  The specified module could not be found.

     

    Any ideas on how to fix this?  I have been on the phone with support and nobody can solve this mystery so far.  I am having trouble with my phone and need to try a restore but I can't until my photos are saves.  My husbands phone gets the same error message.  This problem started occuring after the last software update for the phone.  Itunes recognizes my phone but the PC itself will not import my photos.  I would be grateful if you could help.

  • 14. Re: I can't import my pictures into iPhoto?
    Terence Devlin Level 10 Level 10 (123,865 points)

    from my iphone 4S to my PC

     

    This a WIndows machine? I'd ask on the iPhone forum. This forum is for iPhoto for Macs, and whatever little I know about iPhoto for Macs is encyclopedic comepared to my knownedge of Windows. My ignorance of Windows is legendary...

1 2 Previous Next