Previous 1 2 3 Next 62 Replies Latest reply: Nov 26, 2013 1:57 AM by iSeekAnswers Branched to a new discussion.
JuanLluch Level 1 Level 1 (0 points)

Whatsapp is working on iphone 3G with IOS 4.2.1 until it requires and update and then no longer works because the application in Apple Store needs IOS 4.3 or higher. Incredible! If the update can not work why it require this update? Now I can not use Whatsapp. These are the things that tells apart good sofware developers from bad ones. Please any help?


iPhone 3G, iOS 4.2
  • KiltedTim Level 8 Level 8 (46,445 points)

    Get the old version out of the trash on your computer, put it back in your iTunes library, and re-sync it to the phone.

     

    Then don't update it again until you buy a new phone.

  • JuanLluch Level 1 Level 1 (0 points)

    Thanks Tim,

    But how can I get the old version and put it in the itunes?

  • mia_lene Level 1 Level 1 (0 points)

    Hello Tim,

     

    By doing that, you need to re-enter your phone number when configuring whatsapp and receive an activation number from whatsapp.. however, you never receive the confirmation 3 digit number since whatsapp reminds you that you're using an old iOs.. any idea ?

  • KiltedTim Level 8 Level 8 (46,445 points)

    mia_lene: That's an issue you'll have to take up with the developer.

  • KiltedTim Level 8 Level 8 (46,445 points)

    JuanLluch wrote:

     

    Thanks Tim,

    But how can I get the old version and put it in the itunes?

    When did you update the app in iTunes? Did you look in the recycle bin on your computer to see if the old one is there?

  • misterkoog Level 1 Level 1 (0 points)

    I have the exact same problem. I have an iPhone 3G with iOS 2.4.1. As of yesterday (12.26.12) Whatsapp asks me to verify my phone number. After I enter it, it asks for a 3 digit number that has supposedly been sent as an sms but I never get that. If I press either of the options 'Resend Code' or 'Call Me' I get a message that says my version of the app is too old and that I need to download the latest version from the App Store. But when I try to upgrade to the new version, it says the app requires iOS 4.3. The app worked perfectly fine and I have not actively upgraded it because I had already tried to do so but got the same message about iOS 4.3.  But then this phone number verification message popped up and now there seems to be no way out of this loop.

  • Narendra Mongiya Level 1 Level 1 (0 points)

    I am also facing the same issue.I have an iPhone 3G with iOS 2.4.1. As of today(1.1.13) Whatsapp asks me to verify my phone number. After I enter it, it asks for a 3 digit number that has supposedly been sent as an sms but I never get that. If I press either of the options 'Resend Code' or 'Call Me' I get a message that says my version of the app is too old and that I need to download the latest version from the App Store. But when I try to upgrade to the new version, it says the app requires iOS 4.3. The app worked perfectly fine and I have not actively upgraded it because I had already tried to do so but got the same message about iOS 4.3.  But then this phone number verification message popped up and now there seems to be no way out of this loop.

  • jeebee Level 1 Level 1 (0 points)

    I am also in the same boat.

     

    I was not given the option to update, I logged into whatsapp and it asked me to verify my iphone. I entered my number and before I was supposed to received the 3 didgit verification code, I got an error message saying my version is too old. RUDE.

     

    Best thing to do is everyone email whatsapps support and bombard them with abuse. It's the only thing I can think of. It's the programmers responsibility to provide the app on various iphone versions. Especially to those, like myself who bought the app before it was made available for free. Cheeky f****ers!

     

    support@whatsapp.com

  • kentch84 Level 1 Level 1 (0 points)

    Reply from Whatsapp Developer,

     

    Hi,


    Thanks for your message.


    In order to connect to WhatsApp, or activate your number, you will need the latest version of WhatsApp Messenger - v2.8.7 - available from the App Store on your iPhone. Please note that iPod and iPad are not supported devices.


    The latest version of WhatsApp for iPhone requires iOS 4.3 or later. Regretfully, Apple does not allow new app updates to be compatible with both iOS 6 and older versions of iOS, effectively ending support for the iPhone 3G. Because of Apple's decision to stop supporting these devices, we can no longer provide new app updates for iPhone 3G users.


    If you have an iPhone 3GS or newer device, please update to the latest version of iOS. Instructions for updating can be found at this Apple Support page: http://support.apple.com/kb/HT4972


    WhatsApp is also supported on Android, Windows Phone, BlackBerry, and select Nokia devices. Find out more at http://www.whatsapp.com/

     

    So your guys need to blame Apple, LOL.....

  • Allan Eckert Level 8 Level 8 (47,850 points)

    That is if we trust the yahoos from Whatsapp which I personally don't. To me it sounds like they lie like a carpet.

     

    Allan

  • jeebee Level 1 Level 1 (0 points)

    Apple has stopped providing updates for 3G for a while now, it's nothing new - why the sudden decision to stop providing a version for older iPhones? Regardless, I stick to my main comment that it is the software programmers responsibility to provide support and compatible versions for all users. Flood Whatsapp with emails!

  • hakz4s Level 1 Level 1 (0 points)

    I am getting the same problem in my iphone with 4.2.1 firmware since today morning..why is that suddenly ? if they want to stop that 4.2. versions of iOS let them stop for the newly producing iphone3. but for the old customers who are already having it they can continue the services right? this is totally disgusting. My humble request please take up some action to resolve this.

  • hakz4s Level 1 Level 1 (0 points)

    I am getting the same problem in my iphone with 4.2.1 firmware since today morning..why is that suddenly ? if they want to stop that 4.2. versions of iOS let them stop for the newly producing iphone3. but for the old customers who are already having it they can continue the services right? this is totally disgusting. My humble request please take up some action to resolve this.

  • Affendy Level 1 Level 1 (0 points)

    Happy new Year gift from WhatsApp ! I paid for it. If they stopped us from using it, refund those who purchased it !
    I can use VIBER  for free and it's working.

Previous 1 2 3 Next