11 Replies Latest reply: Feb 25, 2013 1:19 AM by Perapoika
Krimsha Level 1 (0 points)

I just got a new iPod nano (7th gen) and I'm trying to sync it with my iTunes. It gets to certain songs and just.... stops. It looks like it's still syncing but it'll stay on that one song for hours and not move forward. It's not my iPod, since this happened with my 6th gen last night.

iPod nano, Windows 7
  • CTLance Level 1 (0 points)

    Happens to me too. iTunes just does not advance past a certain item while syncing, the progress bar just stops, and apparently no more songs are transferred.


    Left it on over night, but the progess bar remained stuck. iTunes remains as responsive as iTunes under Windows can be. Clicking the x in the info pane appears to properly stop the sync.


    First time iTunes got stuck at song 2/141 in Step 2/3.


    I tweaked the bitrate setting on the sync panel to force a re-sync of most of my songs, and it got stuck on song 2/1858 - but that's another song entirely, not the same as the one from before.


    Restoring the iPod to factory defaults did not help. Got stuck on song 2/... again.


    This bug appears to be unaffected by the "Enable Disk Use" option, as it occurs regardless.


    It appears that item number one seems to sync just fine, iTunes just never manages to get item number two to transfer. I have played around with the settings, apparently the files itself are of no consequence, but rather its position in the transfer queue.


    Ticking/unticking the "offending" songs did not help, sync always appears to get stuck on song number 2 in the queue.


    iPod: 6th Generation nano 16GB

    OS: Win7 Home Pro 64Bit, 16GB RAM, >>10GB free space on all drives.

    Data to sync: Mix between MP3 imports, ALAC CDrips and iTunes purchases

    iTunes sync settings: sync only ticked songs, Convert higher bit rate songs to 192kbps AAC

  • CTLance Level 1 (0 points)

    Self-reply: Got it so work by basically changing one option, then "apply"-ing it while the sync was in progress already - which restarts the sync. Did that a bunch of times, and, knock on wood, currently syncing song 74 out of roughly 2000.


    Switching to the old view (Ctrl-B->View->Status/Sidebar) and/or emptying my trash (only some old ipa files and a handful of mp3s from a library cleanup, <500MB in all) might have done it, too, but I seriously doubt it. Then again, some software bugs are crazy like that.


    Hope the bug doesn't rear its head once more. I'm not too keen on fiddling with this again.

  • baileyb7 Level 1 (0 points)

    I am having the same problem where it gets stuck on syncing the second song.  Deleting that song didn't help.  What option are you changing?  Why did you have to do it multiple times - did it keep getting stuck on song 2 until you changed the option and Apply?  Thanks.

  • CTLance Level 1 (0 points)

    First off, a Happy New Year to anyone reading this.

    Second, I apologise for any weirdness, I am severely lacking sleep and am hopped up on a delicious all-you-can-eat brunch with accompanying reception, so my English might be lacking... more than usual.




    I just tinkered with the options on the first page, i.e. the "enable Disk Use" and "reencode to ____kbps" drop down menu amongst others - but mainly those two.


    It was stuck on the second item and I admit to getting frustrated looking at the sync bar being stuck and the text staying at the second song, so I changed one of those settings on the above-mentioned page and hit apply. Syncing restarted and got stuck again, so I repeated the same action again. And again and again. After a couple of tries I didn't even wait for it to get stuck. Rage!


    By this time I had been battling this stupid bug for quite a while, and I was in a hurry and had kind of depended on my iPod for a long ride, so some NSFW shouts and angry gestures (no physical abuse!) might have been involved too, although I doubt that fixed it. You never know though. ;)


    Anyway, after mashing apply for a bit I opened my email client (full screen, thus obscuring the iTunes window). When I came back to iTunes the bar had finally moved and it was syncing.


    Now you might think this was just snake oil, and honestly, I'm not too sure either. I just know that I had genuinely encountered a bug, and that doing the above had finally fixed it.


    History of my shenanigans: First time it got stuck I aborted sync after a while (two hours maybe?). I tried again, then on the second try decided to leave my PC on overnight in the vain hope it'd fix itself. Over the course of the following day I repeatedly attempted to reconnect the iPod and sync it only to have it get stuck again. First without changing any settings or files, later starting to experiment, always properly aborting sync after half an hour to an hour. I rebooted my PC and restarted iTunes several times while doing so. No dice, always got stuck.

  • 98gator Level 1 (0 points)

    Same issue... 160gb classic.  Sync's to song 2 (regardless of the song) and won't move past.  I have my library in Apple Lossless and have select to convert to 192 or 256 and it doesn't help.  I can't sync my ipod at this time.

  • hsmith543 Level 1 (10 points)

    Try this: Sync the first song only. Then sync the second one. Then sync the rest of the album.

  • Perapoika Level 1 (85 points)

    As per 98gator's post ...


    Exact same issue with me - 160GB classic - 27111 songs in my library of which 22393 are ALAC.  Syncing now gets stuck at song #2 when converting to lower bitrate.  Noticed the problem first when I arrived back home after three weeks holiday ...


    It works if I allow syncing of the lossless files with no down conversion, however only a small subset of songs obviously - so individual playlists.


    Seems to be a fault in the new iTunes - never had this issue in all the years I've been downconverting to fit on my original 160GB classic.

  • Aukina Level 1 (0 points)

    identical issue. reeeally looking forward to this being resolved...

  • Perapoika Level 1 (85 points)

    The workaround that works for my Classic is to only synch playlists, i.e. a subset of the full library.  iTunes then behaves and syncs (either in original ALAC format, or downconverted to 128kbps).


    However if I then go and select 'Entire music library' (now 27178 songs), it hangs on song #2 again.  And I have to force-quit (and send a report to Apple).  I also tried just synching a playlist of my entire library (rather than the 'entire music library' option) and it's the same issue.

  • Perapoika Level 1 (85 points)

    Could it be ... fixed?


    Installed latest iTunes 11.0.2 and gave it a try.  Nope, same problem -> force quit iTunes.


    However after restarting iTunes ... it's now synching 27143 songs @ 128kbps ... up to song 300.


    So looks like they've fixed the issue finally.

  • Perapoika Level 1 (85 points)

    Over 13 hours later and almost done ... song #25664 of 27143 ... phew