12 Replies Latest reply: Jan 11, 2013 8:11 PM by WSKit
kiapkiap Level 1 Level 1 (0 points)

I bought the Canon ImageClass MF 3010 a couple of days back, and I don't know why but "Add Printer" doesn't detect it.

 

When I go to "More Info" under the Apple symbol, the printer is not there either. I realise that it's not on Apple's list of supported printers, but I've seen reviews from Mac users using it. (Am trying to find out what OS they are using at the moment.)

 

I've tried:

  • changing the cables
  • using different ports
  • downloading the new drivers from Canon's website (deleting, re-installing, restarting - the works)
  • spoke to Apple about it - this is not a supported printer, but they sent me to Macpedia to try this download (didn't work)

 

So, my (uninformed) theory is that it's an OS issue (since Canon offers drivers for ML too), and am on the verge of re-installing/downgrading my OS so that I can use this printer.

 

Of course, my theory could be completely wrong so I'd really appreciate any suggestions for things I could try.

 

Questions:

1. Is it possible to detect printers even when Apple doesn't officially support them?

2. Is it worth re-installing my OS for this to work?

 

Exchanging the printer would be a last resort for me as it was a present, so I'd like to try everything else first.

 

Thanks in advance


iMac, OS X Mountain Lion (10.8.2)
  • 1. Re: OS 10.8.2 not detecting Canon MF3010
    PAHU Level 6 Level 6 (14,510 points)

    In reply to the two questions you have asked.

     

    1. Yes. The printer, if connected to Mac via USB cable, should be visible in the Add printer window and in System Information, which is the application that opens via the More Info button you mention. And the ability to see it is not dependent on any driver installation.

     

    2. At this stage I would say no. I would say you have a hardware issue, such as the USB cable. So try another USB cable and a different USB port on the Mac. Note that you need to be connecting directly to the Mac. Not to a port on a keyboard or to a USB hub.

     

    One last thing. When using the System Information app, you need to be looking at the USB entry under Hardware. The printer should be visible under one of the USB busses. Until it is visible you will not be able to add the printer.

  • 2. Re: OS 10.8.2 not detecting Canon MF3010
    kiapkiap Level 1 Level 1 (0 points)

    Thanks for the information and suggestions, PAHU.

     

    I've tried connecting to the computer (directly) using different USB cables and different ports, but that didn't work either. And the printer isn't coming up under the USB entry.

     

    Since I posted the question, someone from Canon came to take a look, and he was able to detect the printer on his computer (on Windows XP tho'). He said the same thing as you said in 1. He thought it could be an Apple issue, but no suggestions beyond waiting for a software update.

     

    But I need to use the printer, so I'm trying hard to find the root cause of the problem and see if it's fixable..

     

    Hm, does the year of the mac matter? Shouldn't right? it's a mid-2010 desktop fyi.

  • 3. Re: OS 10.8.2 not detecting Canon MF3010
    PAHU Level 6 Level 6 (14,510 points)

    The test with the Windows computer confirms the MF3010 is okay.

     

    But it is a concern that different cables or different ports on the Mac has not helped. Until you can see the MF under one of the USB busses you won't get too far. One action that has helped some MF owners previously is to turn off the MF at the power point and unplug the USB cable. Leave the MF off for a few minutes and then reconnect the USB cable and then turn the power back on. Then refresh the System Information view and check the USB entry for the MF.

  • 4. Re: OS 10.8.2 not detecting Canon MF3010
    kiapkiap Level 1 Level 1 (0 points)

    Thanks again... Yes, the printer is totally okay - he was able to print a test page too.

     

    Have tried the power point/turn off + unplug/usb but System Information is still looking like this. Also changed the power point source just in case. And unplugged my other devices in case there's interference.

     

    I've just noticed that they are called "hubs" - is this considered plugging into a hub? The USB is going right into the back of my Mac, so I thought I was plugging in directly. How can I plug in directly if these are hubs?

    Screenshot_30_12_12_1_16_PM.png

  • 5. Re: OS 10.8.2 not detecting Canon MF3010
    PAHU Level 6 Level 6 (14,510 points)

    These are internal hubs and nothing like the 3rd party external hubs I was referring to. So you are connecting directly to the Mac.

     

    Does the MF3010 have an Ethernet port as well as USB port? If you are not sure, take a photo of the back of the MF where you connect the USB cable and post back here.

  • 6. Re: OS 10.8.2 not detecting Canon MF3010
    kiapkiap Level 1 Level 1 (0 points)

    Oic, thanks for explaining that.

     

    No Ethernet port I'm afraid, just this:

     

    photo.JPG

  • 7. Re: OS 10.8.2 not detecting Canon MF3010
    PAHU Level 6 Level 6 (14,510 points)

    Thanks for the photo.

     

    Just want to confirm that you are using this USB port on the back of the MF. I'm not sure that your model has any other USB ports, but with no cable shown in the picture I just wanted to ensure you are connecting to this USB port on the back and not some other port on the printer.

     

    Assuming that you are connecting to this port, and that the USB cables you have used are okay, then I don't know what action you should take next. I doubt that reinstalling the OS or downgrading to a previous version of OS X would resolve the issue, although I would not be surprised to be wrong about this.

     

    Do you have other products, like a camera, that you can connect to the Mac USB port to check?

  • 8. Re: OS 10.8.2 not detecting Canon MF3010
    kiapkiap Level 1 Level 1 (0 points)

    Yup, it's that USB port I'm using (took out the cable to take the photo - sorry for the confusion).

     

    and yes, I do have other devices I use (iPhone, external disk drive, camera) and I've tried connecting them with the different USB ports behind my Mac (just in case one port was kaput), but all the ports can detect the devices. The cable's definitely okay too - tried connecting it to a netbook and the connection was made instantly.

     

    totally agree about reinstalling/downgrading - someone on Amazon who bought the printer replied that they are using it on 10.8.2, so it shouldn't be a problem either. Guess I will have to give it a shot since there doesn't seem to be any other solution.

     

    Really appreciate you taking time to help me troubleshoot though, thanks

  • 9. Re: OS 10.8.2 not detecting Canon MF3010
    WSKit Level 1 Level 1 (0 points)

    Hi. Did you manage to get your Canon MF3010 working on the Mountain Lion? I had the same problem. When I bought my MF3010 in Sept 2012, I could not get it to work from my Mac. But it worked ok from my Windows PC. I went into the Canon website and read that OS 10.8.2 did not have any support for MF3010. The info also said that Apple would have an update for OS 10.8.2 by Nov2012 to accomodate MF3010. So far, in all my OS updates, I have yet to come across any support for MF3010.

     

    Plse visit this web page  http://support.apple.com/kb/HT3669?viewlocale=en_US&locale=en_US#canon

    You will find that MF3010 is not in the list of supported softwares by Apple.

     

    I am still waiting for the OS update for MF3010. Meanwhile, I am using my MF3010 from my Windows PC.

     

    Appreciate if you have any info that I may have missed. Thanks.

  • 10. Re: OS 10.8.2 not detecting Canon MF3010
    PAHU Level 6 Level 6 (14,510 points)

    WSKit wrote:

     

    Plse visit this web page  http://support.apple.com/kb/HT3669?viewlocale=en_US&locale=en_US#canon

    You will find that MF3010 is not in the list of supported softwares by Apple.

    This web page lists the drivers that the vendors supply to Apple so that they can be downloaded to the Mac via Software Update. It is by no means a  list of drivers that are only approved or supported on 10.8 and earlier.

     

    With regards to the UFR2 driver used by the Canon MF series, it is supported by Canon on 10.8 and version 2.43 lists the MF3010 as a supported model. This is shown in the Readme for the driver.

     

    Also, as I have mentioned above, the ability to see the MF connected to the Mac via USB is not dependent on the printer driver. The device should appear under one of the USB busses. The fact that it is not for the OP would normally suggest a faulty USB cable or some device residing between the Mac and the MF. But this is not the case so there must be something else causing this symptom.

     

    If you open System Information and select USB, do you see the MF listed?

  • 11. Re: OS 10.8.2 not detecting Canon MF3010
    kiapkiap Level 1 Level 1 (0 points)

    WSKit wrote:

     

    I am still waiting for the OS update for MF3010. Meanwhile, I am using my MF3010 from my Windows PC.

    Hi, I haven't spoken to Apple to ask if they have any weird USB issues with the MF3010 (or on refurbished Macs from mid-2010), but both the printer and cable work perfectly on a WindowsXP netbook. Also discovered I couldn't send print jobs from the Mac via the netbook. Some "filter failed" error comes up. 

     

    Just fyi, I tried re-installing my OS and it didn't help as expected. So if we have the same problem (USB), then I doubt an OS update will solve the problem either.

     

    Will update if I learn anything useful from Apple.

  • 12. Re: OS 10.8.2 not detecting Canon MF3010
    WSKit Level 1 Level 1 (0 points)

    Hi kiap kiap,

     

    I found the driver of MF3010 for Mac OS 10.8 (Mountain Lion) here - http://support-my.canon-asia.com/P/search?category=Laser+Printers&series=ImageCL ASS&model=imageCLASS+MF3010&menu=Download&filter=0

     

    After installing the driver, my MF3010 works perfectly on my Mac - both printing and scanning functions. Of course, for scanning you will need to install the MF Toolbox that comes with the hardware. I used the direct USB connection.

     

    Cheers and good luck.