1 Reply Latest reply: Dec 27, 2012 9:58 PM by BDAqua
abrewer_7 Level 1 Level 1 (0 points)

I can not access Itunes because it says that i need the latest version of a software. So i got the OSX update 10.8 and it says this  This package type requires Mac OS X 10.5.. I dont get it.. I am new to apple products. I dont understand what i need to do to update my software and be able to access ITUNES. Please help. i also have no idea what operating system i have all it says is Mac OS X


MacBook