8 Replies Latest reply: Dec 29, 2012 7:13 AM by Fuff24
Fuff24 Level 1 (0 points)

Hi all

I can't seem to download the "additional content" in garageband. Just did a fresh install of GB on my mid 2012 macbook pro, and I want to get all of the loops/synthesizer presets. When I click a grayed out loop, GB asks me to download the complete suite. This doesn't work however, as the link only opens the Mac App Store, which informs me there are no updates available. Am I missing a step? I tried reinstalling GB but that did not work either. I've attempted to installing http://support.apple.com/kb/DL1507 but that also failed to work. Can anyone help me with this issue?

  • consultanator Level 1 (0 points)

    Wish I had something useful to say, but I've got the exact same problem with a brand new iMac 21.5, 2012.  I have admin rights, and I tried both the "download now" and "download later" options with no success.  It just launches the app store and then stops.


    I downloaded the .dmg, but was informed that I should not use that on this system when I clicked on it; so I did not try to reinstall via that route.  (I don't know how to re-install via the app store, and doubt that fixes this.)

  • léonie Level 10 (85,290 points)

    Have you tried this:

    Re: GarageBand '11 won't download additional loops




    If that does not work, reinstall GarageBand, that has solved the problem for quite few posters.

    To reinstall from the AppStore,

    • quit GarageBand
    • then sign into the AppStore with your Apple ID
    • Look at the "Purchased" tab, if the iLife Applications are there. If there is an "Accept" button beside them, accept them to your AppleID. Quit the AppStore.
    • Move the GB application to the trash.
    • Launch the AppStore again. Sign in,
    • Open again the "Purchased" tab. The button besides GarageBAnd should now say "Install".
    • Press "Install".


    After installation launch GB again and select a loop to install. Press "install later".

    Then launch the AppStore again, and check if you can download the additional loops.




  • consultanator Level 1 (0 points)

    Thanks for the suggestions but after trying both ideas (the one at the link and the uninstall/reinstall method you suggested) unfortunately neither worked. 


    So if anyone else is reading this I'm still open to more ideas!  :-(

  • Fuff24 Level 1 (0 points)

    According to the finder, the Update list.txt is etnerally in use for some reason, so I am wary to delete it. Reinstalling from the app store didn't work either. I will try again soon though, on both methods

  • consultanator Level 1 (0 points)

    Thanks to LeonieDF, I finally got pushed in the right direction.  I followed Dagon's instructions at: HERE as best I could (I may have found a slight difference in directory names, the instructions are for GB 2011).  Deleting the additional files that they list is essential to making the re-install work.


    The process was: delete GB, delete the files and folders listed in Dagon's instructions.  Then from app store re-install GB.  This is a 200 MB download, followed by a massive 1.5 (?) GB download to get back to zero--at the end of this I thought it had failed b/c I was back to the basic incomplete GB.  But this time when I went into GB and clicked on a missing loop, I selected the option to "download later."  When I next went to the app store and checked updates, the missing material was finally there!  Another 1.2 GB download and finally it worked and GB was complete.  So all afternoon and 3 GB of my internet usage later I am back to where I *should* have been with my new machine!


    There has got to be a better way.  The one thing I know for sure is that I just keep deleting parts of GB until it was so broken that essentially the app store installer thought it needed to completely re-install GB from scratch.  I am sure there is exactl one essential file that is the key, but I don't know what it is.


    Good luck to everyone else with this problem, and thanks to everyone who helped me by posting here and pointing me in the right direction!  Cheers!

  • léonie Level 10 (85,290 points)

    Great- I am glad it works for you now - that is why I pointed to the thread with dagon's post in it. It is always hard to tell, if the complete uninstall will be necessary, i.e., since dagon's system is an older system, and for other poster the simple removal of one file forced the download to appear.

  • léonie Level 10 (85,290 points)

    There is one more file, that you could try to delete, before doing it the hard way like in dagon's post:


    GarageBand stores the previous state in the Preferences file: In some cases it helped to remove this file, to make GarageBand try the download again:


    First, quit GarageBand. Log off and on again.


    The preferences are in your your user Library folder. This is a hidden folder that normally does not appear in the Finder. The easiest way to open it is to go to the Finder and select "Go->Go to Folder..." from the menubar and type "~/Library" in the dialog box.


    Once you are in your Library folder, drag the following file to the trash:






    Relaunch GarageBand and try the download again.


    If this does not help, bite the bullet and reinstall completely.

  • Fuff24 Level 1 (0 points)

    This solution failed too, so I suppose I will have to use dagon's method and do a complete reinstall