Previous 1 2 Next 23 Replies Latest reply: Dec 30, 2012 7:11 PM by Ernie Stamper
cslaurie Level 1 (0 points)

I have created my photobook and every thing seems in order, it previews perfectly.  When I go to buy the book, I get the following error:

Unavailable images detected in book

One or more of the images in your book are not presently available at full resolution.  Please reconnect to these files by mounting the volume(s) containing the original images.

 

I know the the problem is not the resolution of the images.  The problems seems to be that Aperture cannot find the folder with the images.  This particular folder is not a part of the aperture library.  Is this the problem?  Is that what it means by "reconnecting" these files?


Aperture 3, Mac OS X (10.7.5)
  • Ernie Stamper Level 8 (37,545 points)

    Reconnect, yes!  You have a referenced Master/Original involved, and it is needed for full resolution.

     

    Ernie

  • cslaurie Level 1 (0 points)

    Thanks for the help.  How do I reconnect? And will this put the images back into the aperture library or only connect them?

     

      After I get the error message, it asks to "show referenced files".  It then brings up a list of all the images that it cannot find.  But it does not give me any reconnect options.

  • léonie Level 10 (90,574 points)

    Where is the folder with the original images, that Aperture cannot find? Is this folder on an external disk, and is this disk connected to your Mac and mounted?

     

    Sometimes Aperture loses the connection to the referenced original images and you have to reconnect them, see this section of the User Manual:

    Reconnecting Missing or Offline Referenced Images

    http://documentation.apple.com/en/aperture/usermanual/index.html#chapter=5%26sec tion=16%26hash=apple_ref:doc:uid:Aperture-UserManual-91292BSR-1037600

     

    Basically you have to do the following:

    • Select the images with the missing originals in the browser,
    • Use the command "File > Locate Referenced Files".
    • In the upper part of the panel that opens select one of the images.
    • In the lower part select the folder with missing original image and select the original.
    • Now the "Reconnect" buttons should become active. Press "Reconnect all".

     

    Aperture should now be able to access the missing originals.

     

    If this does not succeed post back with more information on the location where you are storing the originals - the kind of disk, filesystem, how it is connected.

     

    Regards

    Léonie

  • cslaurie Level 1 (0 points)

    I have tried this before and I just tried it again.  when I match the upper and lower panels then hit reconnect or reconnect all...nothing happens.  I would think that after it reconnects them it would remove it from the upper panel but it does not.

  • cslaurie Level 1 (0 points)

    All of these files are on my Mac harddrive with a typical path name of:

     

    Users/cslaurie/Pictures/2012/Disney Vacation/file name

  • léonie Level 10 (90,574 points)

    I would think that after it reconnects them it would remove it from the upper panel but it does not.

    If you see the reconnect button, then all should be well. The files in the upper panel will only vanish, if you check the "Show only Files Not Found" button. Have you tried that?

    And when you match the selection in the upper and lower panel, both selected files should show the same preview.

    reconnect.png

  • cslaurie Level 1 (0 points)

    Yes, both panels show the same preview and when Check the "show only files not found"  the entire list goes away.  But I still the very same error message.

  • léonie Level 10 (90,574 points)

    Then it may help to check, if your referenced image files are now properly connected. You could use a smart filter for that:

    • Select the "Photos" view.
    • Then click ⌘F (or the looking glas icn besides the Browser search field) to bring up the smart settings.
    • Click "Add Rule" and add a file status rule. "File status is missing" of "File status is offline".

     

    Does any of these rules show images you used in your book?

     

    offline.png

    If there are still images shown, do they have arrow badges with warning icons?

  • cslaurie Level 1 (0 points)

    No, none of the images I used in my book show up when running that missing filter. 

  • cslaurie Level 1 (0 points)

    I was able to finally click on the Reconnect All button and got a 100% complete message.  But when I clicked done and went back to my book, I got the same original error message.  It seems like I am doing all the right things but it just isn't connecting.

  • léonie Level 10 (90,574 points)

    But when I clicked done and went back to my book, I got the same original error message.  It seems like I am doing all the right things but it just isn't connecting.

    You may be connecting to the wrong images. What happens, when you toggle between original master and version? Select one of the images that do not work and press "M" to reveal the master. Is it the correct master? And what is the pixelsize of the images? Do the have enough pixels? Perhaps it is only one image, that has too low a resolution.

    Regards

    Léonie

  • cslaurie Level 1 (0 points)

    Aperture has decided to repair my library and after 5 hours it is 69% complete.  Maybe this will help.  If not I am going to look at your ideas in your last post.  If that does not work, I am seriously considering switching to Lightroom.

  • cslaurie Level 1 (0 points)

    Repairing the library made no difference

    Each image is 51XX x 34XX (17.9MB)

    I have no yellow triangles.

  • léonie Level 10 (90,574 points)
    Each image is 51XX x 34XX (17.9MB)

     

    The images are rather large. Are they raw images? This looks like Aperture is not able open the original master image files to render the book, even if they are properly connected. Check if Aperture can open your raw at all:

     

    Select the images in question and reprocess the raw. 

    From the "Photos" menu: Photos > Reprocess original

     

    Something must be preventing the access to your original files. Have you checked the permissions on that folder? Do you have read/write access?  Can it be, that you have turned on "File vault" for your Home Folder in the "Security & Privacy" settings, and your home folder is encrypted?

     

    @Ernie Stamper, do you have any suggestions? Frankly, I am puzzled and running out  of ideas.

Previous 1 2 Next