2 Replies Latest reply: Dec 28, 2012 4:25 PM by steve359
maria from hemel hempstead Level 1 (0 points)

Hi I am having trouble uploading itunes latest version as it says I need Mac OS x 10.6.8 but I only have 10.5.8 - What do I need to do?  Many thanks

iMac, Mac OS X (10.5.8)