4 Replies Latest reply: May 24, 2013 12:12 AM by ricksca
bcors2 Level 1 Level 1 (0 points)

I just received this computer and it randomly fails to reconnect to wi-fi after it resumes from sleep mode. Could this be cause by too many connections to my router? I'm currently running this mac, 2 PC's and 2 smartphones on a Linksys WRT54g router

iMac, OS X Mountain Lion (10.8.2)
  • BDAqua Level 10 Level 10 (121,200 points)

    Hi, this has worked for a few...


    Make a New Location, Using network locations in Mac OS X ...




    10.7 & 10.8…


    System Preferences>Network, top of window>Locations>Edit Locations, little plus icon, give it a name.



    10.5.x/10.6.x/10.7.x instructions...


    System Preferences>Network, click on the little gear at the bottom next to the + & - icons, (unlock lock first if locked), choose Set Service Order.


    The interface that connects to the Internet should be dragged to the top of the list.


    10.4 instructions...


    Is that Interface dragged to the top of Network>Show:>Network Port Configurations.

    If using Wifi/Airport...


    Instead of joining your Network from the list, click the WiFi icon at the top, and click join other network. Fill in everything as needed.


    For 10.5/10.6/10.7/10.8, System Preferences>Network, unlock the lock if need be, highlight the Interface you use to connect to Internet, click on the advanced button, click on the DNS tab, click on the little plus icon, then add these numbers...



    Click OK.

  • WZZZ Level 6 Level 6 (12,775 points)

    Sometimes this happens for me. When it does I give Airport a second chance to find the signal it must have missed on the first try on wake from sleep. From the Airport icon in the menubar, just select "Turn Airport Off" wait a second or two and then turn it back on again. Never fails for me.

  • BDAqua Level 10 Level 10 (121,200 points)

    Did you ever try the New Location? Easy to switch back if need be.

  • ricksca Level 1 Level 1 (0 points)

    I had this problem on both my Macbook Pro's. I tried all sorts of fixes and none of them worked. Sometimes it would take 5 minutes to reconnect to the Internet after being asleep. This went on for YEARS. Last month, I switched from ATT Broadband to Comcast. Problem GONE. That alone would have made the switch worth it. The extra 25 mbps I got is just icing. (Oh, and half the cost).