Previous 1 2 3 4 5 Next 68 Replies Latest reply: Nov 3, 2014 4:34 AM by DmitrySPB Go to original post
  • DmitrySPB Level 1 Level 1 (0 points)

    @mayokaze - how do you exactly do that?

     

     

    No answer from mayokaze, so I answer:

     

     

    To disable auto hibernate I wrote in terminal (root):

     

     

    pmset -a autopoweroff 0

    pmset -a standby 0

     

     

    Now my MBA sleeps well!

  • janschuster Level 1 Level 1 (0 points)

    It seems like it helped on my MBA 2012 too. No DarkPME for the past hour. Let's wait for this night and see...

     

    Still, that does not leave me satisfied, as this is not the way it should be fixed... Let's hope for another firmware-update to help.

     

    All the best,

    Jan

  • aphasia0 Level 1 Level 1 (0 points)

    Anyone has checked if the 10.8.3 update solve the problem?

  • sorenfriis Level 1 Level 1 (0 points)

    I ran a test on my MBA2012 just updated to 10.8.3.

     

     

    I started by resetting every pmset setting to default:

    standbydelay     4200
    standby          1
    halfdim          1
    hibernatefile    /var/vm/sleepimage
    darkwakes        0
    disksleep        10
    sleep            10
    autopoweroffdelay14400
    hibernatemode    3
    autopoweroff     1
    ttyskeepawake    1
    displaysleep     2
    acwake           0
    lidwake          1

     

    At 22.32 last night I closed the lid at 100% battery, and at 13.50 today I opened it again at 94% battery.

    According to Console.app:

     

    23.42 Switch to hibernate i.e. 4200 seconds after lid close.

    Until 07.38 there are no entries in the log, but after this, it starts waking up at an interval of between 2 and 18 minutes, not consistently.

     

    It doesn't make sense to me. Could we please get an explanation from Apple??!

  • DmitrySPB Level 1 Level 1 (0 points)

    I hope soon will see a new firmware for power controler as it was with last version

  • Yositimy Level 2 Level 2 (235 points)

    Just to add that a brand new rMBP with firmware updated and loader with 10.8.3 from factory will periodically wake for EC.darkPME (maintenance).

     

    The most annoying part (I leave power applied) is the external DP display and attached USB3 RAID will also wake up at the same time....  in fact I noticed the problem shortly after connecting up my new monitor and then wondering why it seems to wake up on its own.  Otherwise the rMBP can be quite warm in the morning.

     

    Any word from engineering on a fix?

  • JDW1 Level 1 Level 1 (0 points)

    For what it's worth, I just started having this problem as of last night, just after I installed 10.8.4 (I was using 10.8.3 before) on my early 2009 DuoCore iMac.

     

    Running the Terminal command suggested earlier in this thread yields the following:

     

    iMac kernel[0] <Debug>: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake

     

    And the Console says the following:

     

    6/11/13 12:19:38.000 AM kernel[0]: Wake reason: RTC (Alarm)

    6/11/13 12:19:38.000 AM kernel[0]: RTC: Maintenance 2013/6/10 15:19:37, sleep 2013/6/10 13:31:38

    6/11/13 12:19:38.000 AM kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake

    6/11/13 12:19:38.000 AM kernel[0]: AirPort_Brcm43xx::checkInterfacePowerState: Check _pwrOffThreadCall!

    6/11/13 12:19:38.000 AM kernel[0]: Previous Sleep Cause: 5

    6/11/13 12:19:39.000 AM kernel[0]: 3b9aca00  00500030  NVEthernet::setLinkStatus - not Active

    6/11/13 12:19:42.000 AM kernel[0]: Ethernet [nvenet]: Link up on en0, 1-Gigabit, Full-duplex, Symmetric flow-control, Debug [796d,0000,0c01,000d,c5e1,3800]

    6/11/13 12:19:42.000 AM kernel[0]: 3b9aca00  00500030  NVEthernet::setLinkStatus - Active

    6/11/13 12:19:47.000 AM kernel[0]: Graphics suppressed 9868 ms

    6/11/13 12:19:48.066 AM configd[18]: network changed: v4(en0-:192.168.0.11) DNS- Proxy- SMB

    6/11/13 12:19:48.262 AM configd[18]: network changed: v4(en0+:192.168.0.11) DNS+ Proxy+ SMB

     

    Interestingly, I put the iMac to Sleep at about 7PM that same evening, and the Console reported that it woke and slept and woke again (which is what you see above).  But when I tapped a key to wake the iMac this morning, it would not wake.  I then pressed the power button on the back left only briefly and it booted!  Apparently, the Mac shut itself down for some reason last night about midnight.  And no, my Energy Saver settings are not set to do that.

     

    I never experienced anything like this until 10.8.4.

  • osro82 Level 1 Level 1 (0 points)

    I'm having this very same problem in 10.9.1.

     

    Battery drains out in few hours while the computer should be sleeping.
    It continously keeps waking up from the sleep mode.

     

    Jan 10 19:27:56 kernel[0] <Debug>: Wake reason: EHC1

    Jan 10 19:27:56 kernel[0] <Debug>: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake

  • JTrudel Level 1 Level 1 (0 points)

    I'm also experiencing it in 10.9.1, just noticed it, today.  Mine is a MacBookPro8,3.

     

    The powerups are definitely following a schedule.  Take a look at these messages in the /var/log/system.log:

     

    Feb 10 12:01:59 MACHINE kernel[0]: RTC: Maintenance 2014/2/10 18:49:46, sleep 2014/2/10 17:02:00

    Feb 10 13:49:46 MACHINE kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake

     

    It's definitely following a cycle - it wakes up, does the maintenance, then goes to sleep, and tells you when it's gonna wake up next (in GMT, apparently). 

     

    I just upped the standbydelay to 86400 and I'm going to see if that tweaks it.

     

    Funny thing was that I noticed it when my home computer started logging into my work IRC today.  I almost thought someone was booting up my computer at home!

  • Yositimy Level 2 Level 2 (235 points)

    MIne seems to have picked up again, annoyingly spining up USB external drive and turning the external monitor on and off.  You would think Apple would have figured this out by now. 

     

    2/26/14 3:50:32.000 PM kernel[0]: Wake reason: EC.DarkPME (Maintenance)  every few minutes

  • John Clark Level 1 Level 1 (95 points)

    I know that this is an old thread, but I've only just discovered it.  Similar symptoms to all with my rMBP (July 2012 model, 16Gb/256Gb/2.3i7 15"), including EC.DarkPME (Maintenance) calls approximately every six minutes when power supply disconnected.

     

    One workaround that DOES work for me, and is unobtrusive, is to have a microSD card permanently mounted in the SD slot (in my case using a Nifty microdrive adapter which I can recommend for this purpose).  With the microSD card mounted, EC.DarkPME (Maintenance) calls stop and the machine doesn't wake unless I want it to.

     

    I'd obviously love a proper fix, but this is a decent and acceptable workaround.  Bad show on Apple for letting this go unfixed for so long, but there is much about the rMBP that is not perfect - e.g. battery life, random screen flickers - that this is lower down the priority list...

     

    john

  • Gerald Petiteville Level 1 Level 1 (30 points)

    Well, I’ve found what have been the cause for the DarkWare (PME): a direct MiniDisplayPort to DisplayPort câble from my Mac Pro (2013) to a DELL U2311H monitor. Using a MiniDisplayPort to DVI adapter from Apple did the trick!

    I filled a support case with Apple, waiting for their answer…

  • Yositimy Level 2 Level 2 (235 points)

    I found that when I inserted a LaCie Big 5 between the rMBP Thunderbolt port and the DP monitor it solved this insomnia and a few other nagging issues.

  • jraoult Level 1 Level 1 (0 points)

    I actually got to the same conclusion. I have a DELL U2713HM connected to my rMBP15 through a thunderbolt to display port cable and in this configuration my Mac wakes up about every 20 seconds. I noticed that if I "Lock the screen" the Mac will eventually sleep. That's a decent workaround but I have to remind to do that every time.

  • jraoult Level 1 Level 1 (0 points)

    By the way Gerald, have you contacted the support? If yes, what did they say?

     

    I reinstalled Mavericks and same problem, I tried with another rMBP15 and again same problem so I'm definitely positive that it is a software problem, probably driver. I would like to make sure Apple is aware so that they could fix it.