10 Replies Latest reply: Mar 10, 2014 2:48 PM by flashgordonlash1
Des Collins Level 3 Level 3 (755 points)

I have all my movies in iTunes tagged with their respective rating for UK.

 

On each Apple TV, I have parental controls setup, which allows content rated 'U'. Any other content (PG,  12, 15 and 18) should prompt for a pin.

 

I've just noticed that the PG rated films are NOT prompting for a pin, but 12, 15 and 18 are promoting just fine.

 

I've played about with other settings.

Putting the 'allow' to PG (so U and PG should NOT prompt), works as expected.

Putting the 'allow' to 12 (so U, PG and 12 should NOT prompt), works as expected.

Putting the 'allow' to 15 (so U, PG, 12 and 15 should not prompt), works as expected.

Putting the 'allow' to 18 (so all should work without a prompt), works as expected.

 

It just seems to be an issue when U is set to allow, where it allows U and PG. This happens on all 3 of my AppleTV's - 2 2nd gen, 1 3rd gen. All are runing latest up to date OS version.

 

I'm absolutely positive this worked correctly on earlier OS versions for me - not sure when it broke.

This happens for iTunes purchased films as well as DVD rips... So I don't believe the issue is with the content / media files themselves. It also happens for streaming  purchased films from the 'Movies' 'app' on the Apple TV.

 

Can anyone else confirm they have the same issue? Or otherwise. If you don't see to issue, any suggestions as to what may be the cause?

 

Cheers

Des

  • FlashGordonLash Level 1 Level 1 (10 points)

    Des,

     

    I am in the UK and I think I have the same problem.  It has only happened since the last Apple TV software update.

     

    It doesn't matter what I set the restriction to, U and PG films are not restricted, and 12, 15 and 18 are always restricted.  I have tested it is not my films or my Apple TVs (I have 3, all version 3) by rerating one as a US PG-13 and changing the Parental Controls to US, and then it all works as expected.  I notice the last update included a fix for Australian Parental Controls, so maybe that has broken them for the UK?

     

    I have not been able to find a fix or workaround, apart from rerating everything, but that would take days and shouldn't be necessary.

     

    I will report this to Apple as a bug, if I can find out how.

     

    Ian

  • Des Collins Level 3 Level 3 (755 points)

    Thanks Ian,

    Always good to know its not just me.

    Yes, could well ave been the last update that broke it. I'll also report it.. Hopefully it'll get sorted soon.

    Cheers

    Des

  • Stevie-Gogs Level 1 Level 1 (0 points)

    I am having similar issues. I have an older daughter who I want to let see 15's but still want to restrict 18's. Parental controls work fine up to rating 12 but if I try to increase restriction to 15 or 18 it still asks for a password for anything above 12.

     

    Same issue on two Apple TV 2 running 5.1.1. However have a new Apple TV 3 which is running on 5.0.2 and it all works fine on this for all ratings. The Apple TV 2's both worked fine previously so I am convinced it is to do with last update.

     

    I have reported to Apple so heres hoping it gets fixed.

     

    Stephen

  • FlashGordonLash Level 1 Level 1 (10 points)

    Stephen,

     

    I've discovered that one of my 3 Apple Tv 3's is still running 5.1, and the parental controls work fine on there.  So, 5.1.1 broke it, but 5.1 is fine.

     

    Ian

  • 450Chap Level 1 Level 1 (0 points)

    I'm also having the same problem - I have two ATV3's running 5.1.1 - one is my son's and I want to restrict him to be able to watch up to (and including) a 12 rating without the PIN prompt and the other is my daughter's and I want to let her watch up to (and including) a 15 without a PIN prompt.

     

    Son's setup seems to work OK but my daugher has to enter a PIN to watch a 15, which she has to get me to do and is very annoying.

     

    Sounds like we all have the same problem - how do I report to Apple for investigation and resolution?

  • Stevie-Gogs Level 1 Level 1 (0 points)

    Tried latest 5.2 update but no change. Found a workaround. I changed the parental controls region on my problem ATV  to USA and set restriction to and"R".Now only "18" rated movies require a password.Up to inc 15s play without password. Not ideal but at least its doing what I want now

  • 450Chap Level 1 Level 1 (0 points)

    Strange - that workaround doesn't work for me (now also on 5.2) - set the Country to US and the 'Restrict To' to R and 18 films still play without a PIN.

  • FlashGordonLash Level 1 Level 1 (10 points)

    Go here to report the bug to Apple:- http://www.apple.com/feedback/

  • m0thr4 Level 1 Level 1 (100 points)

    Exactly the same problem here - 12, 15 & 18 movies are PIN-protected no matter what you set.

     

    Also, I find the choice of English in the menu rather bizarre - why is it "restricted to"?  If you're blocking rating 15 and above, what you're restricted to is films of certificate U, PG & 12.  The menu item should be called "restriction begins".

     

    I'm reporting it as a bug, as suggested below.

  • flashgordonlash1 Level 1 Level 1 (0 points)

    Just updated to 6.1 and now it is even worse!  Some 15 movies show without protection, others require the PIN to be entered.  Same with 12A films.  This is unacceptable.

     

    I need to work on Stevie-Gogs workaround mentioned above, to see if I can get that working.