9 Replies Latest reply: Jan 13, 2013 9:59 AM by Howard Brazee
Howard Brazee Level 1 Level 1 (10 points)

Whenever I have some software upgrade, I cannot empty my trash can until I reboot my iMac.    My Mac says the program that was updated is using a file.


After I reboot, I can empty my trash.


What causes this?

  • Linc Davis Level 10 Level 10 (169,570 points)

    You're trying to delete a mounted disk image file. Unmount the disk image first, then empty the Trash.

  • Howard Brazee Level 1 Level 1 (10 points)

    Not that I can find.   The upgrade I had this time was using Bodega which may have mounted something without showing me.

  • Linc Davis Level 10 Level 10 (169,570 points)

    What is in the Trash when you can't empty it?

  • Howard Brazee Level 1 Level 1 (10 points)

    Nothing was in my trash, so I went to Bodega and it updated Librarian Pro.    I did some other stuff then tried to empty the trash folder.   It couldn't delete a file named "Librarian Pro (2.2.4).app".    I then started Librarian Pro and checked to see that it was 2.2.5.    Hmmm, the older version of Librarian Pro is what is in the trash.


    I believe I've had the same problem when I updated Opera from telling Opera to upgrade.

  • Linc Davis Level 10 Level 10 (169,570 points)

    The next time you have the problem, proceed as follows.


    Launch the Terminal application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.


    Triple-click anywhere in the line below to select it:


    lsof | grep Trash


    Drag or copy and paste the selected line — do not type it — into the Terminal window.


    Post any lines of output that appear below what you entered — the text, please, not a screenshot.

  • Howard Brazee Level 1 Level 1 (10 points)

    I just had a variation of this problem.     I installed the applicatino DeDRM 5.5.5.app, and then deleted the program DeDRM 5.3.1.   Renaming the application was a pain, as I had to change my configuration to allow me to trust the application, run it, then change my configuration back.


    But it may have helped solve the problem in this thread.


    I tried to empty the trash, but it won't empty DeDRM 5.3.1.app.


    I pulled out your instructions, started Terminal, then searched for DeDRM in the spotlight (which is how I run most applications that I remember the name of (including Terminal)).   It didn't show DeDRM 5.3.1 (which makes sense).   Here's my output:

    lsof | grep Trash

    UserEvent   137 HBrazee   49r     DIR                1,3       102 8023996 /Users/HBrazee/.Trash

    Finder      157 HBrazee   10r     DIR                1,3       102 8023996 /Users/HBrazee/.Trash

    Mail      24561 HBrazee  txt      REG                1,3      1610 7074261 /Applications/Mail.app/Contents/Resources/TrashMailboxMediumTemplate.png

    Mail      24561 HBrazee  txt      REG                1,3      4671 7074262 /Applications/Mail.app/Contents/Resources/TrashMailboxMediumTemplate@2x.png

    ~ >

  • Linc Davis Level 10 Level 10 (169,570 points)

    When I asked what was in the Trash when you couldn't empty it, you said nothing was. Did the Trash icon in the Dock indicate that it was empty? Does it indicate that now?

  • Howard Brazee Level 1 Level 1 (10 points)

    Right now the icon shows it is not empty.   It has "DeDRM 5.3.1.app" in it.


    It also has some other files that I created after I did my post.   Let me delete them...   Hmm, this time the trash emptied all the way, including that file that didn't delete earlier - and I didn't do a reboot in between.    Odd.  

  • Howard Brazee Level 1 Level 1 (10 points)

    I just tried to empty my trash.   It shows as full after telling me it couldn't delete Librarian Pro.   Odd, finder shows it was modified today at 10:55 AM (when I emptied the trash) and has zero bytes.    The application was updated in the last couple of days, and I doubt if I emptied my trash since then.


    I just emptied the trash again and it worked.