2 Replies Latest reply: Jan 2, 2013 11:45 AM by minihilly
minihilly Level 1 Level 1 (0 points)

Hi.

 

It's been a while since I've updated my iPod, and now that I've tried to update it (from iOS 4.2), whenever I click the 'Check for new updates' [for my iPod] button, iTunes states that the latest version is already installed, which obviously is NOT the case.

 

I am using the latest version of iTunes, and have already tried re-installing it.

 

 

After attemping to update, the next logical step was to restore, despite losing some of my data this way, for I currently have no-choice but to update via a different system to my usual managing computer of my device(s). However, an unexplained error occured, and my iPod is stuck in recovery mode (displaying that 'connect to iTunes' image it shows at this point).

 

 

Now, I've tried repeatedly to restore th iPod via iTunes, but it just won't work - as it is 'extracting software' (as indicated at the top of iTunes' window), it stops, giving a rather vague error: 'The iPod "iPod" cannot be restored at this time because the iPod software update server could not be contacted or is temporarily unavailable'.

 

I have no idea why this occcurs repeatedly, as it is persistent to do so.

 

I'd also like to confirm that my system is correctly connected to the internet at a speed that should be ample to install any required updates (furthermore, this error occurs after no-more-than 1 minute after attempting to restore the device)

 

 

 

Thanks in advance

~mini.


iPod touch, Windows 7