6 Replies Latest reply: Jan 5, 2013 5:28 AM by jbs12345
jbs12345 Level 1 (0 points)

A few thumbnails in my iPhoto library appear blank with a dotted white line outline. I have tried all the items in Photo Library First Aid; repair permissions, rebuild thumbnails, repair database, rebuild database and this has not helped. When I click on the thumbnail outline I no photo appears just a blank black area where the photo should be. What should I do next? What has gone wrong?

Mac mini (Mid 2007), Mac OS X (10.7.3), none
  • Terence Devlin Level 10 (137,945 points)

    What version of iPhoto? What version of the OS?

  • janesomers Level 1 (0 points)

    I have a similar issue. I have a new iMac 21.5" with iPhoto '11. I moved over 5,000 photos from my old computer (iPhoto '09) by dragging the iPhoto library onto an external hard drive, then dropping it into my new Pictures folder. I then also loaded photos directly from my camera into iPhoto '11.


    iPhoto has crashed at least 4 times in the past day, and as I scroll through the photo thumbnails, they disappear as I scroll. If I try to double click on anything newer than about March 2012 (when, coincidentally, I got a new lens), I can see the thumbnails below, but get the triangle with the exclamation. The photos I loaded from my camera are gone.


    Also, anything I try to do in iPhoto on my new, lightning-fast computer responds with a beach ball.


    Should I start over? Is there a better way to bring the photos over?


  • Terence Devlin Level 10 (137,945 points)

    As a Test:



    Hold down the option (or alt) key and launch iPhoto. From the resulting menu select 'Create Library'



    Import a few pics into this new, blank library. Is the Problem repeated there?

  • janesomers Level 1 (0 points)

    So far, so good. Now I'm trying to import the photos from my camera.

    If this works, should I be able to drop in my old iPhoto library from my external drive?


    Also - thanks for the quick reply. Happy New Year!

  • Terence Devlin Level 10 (137,945 points)

    This was a test:


    As a Test:



    It tells us that the app is sound and the problem specific to that Library. Assuming i worked normally on the old machine I would try copy it over again.

  • jbs12345 Level 1 (0 points)

    Version '11 9.4.1 (701.67)


    I did a second library rebuild and this seems to have solved the problem, thank you.


    BUT, why did it happen in the first place

    AND how can I stop it happenning again ?