Previous 1 2 Next 18 Replies Latest reply: Apr 8, 2015 6:27 AM by BobHarris
rosalindwills Level 1 Level 1

Hello. I'm having a really weird issue with my laptop (Macbook Pro, 10.7.4). In the last few days it's abruptly developed an issue where the clock in the upper right-hand corner will not update unless I click on it. In other words, it will display 10:00 steadily for forty-five minutes, but when I click the menu bar to get the Date/Time dropdown, it suddenly updates to 10:45, which it proceeds to continue to display until I click it again.

 

I've checked the Date/Time Preferences and they all seem to be right. "Set Date and Time Automatically" and "Set Time Zone Automatically" are checked, and both seem to register correctly in the preference dialog. The analog clock in that dialog also ticks along correctly but when it ticks over to a new minute, the menu bar clock does not change.

 

Out of curiosity, I flicked some of the options under "Clock" in the date/time preferences on and off...telling it to display the time with seconds doesn't change anything; the seconds remain as stagnant as everything else. Toggling it between a 12-hour and 24-hour display does cause it to update to the current time, but not to resume updating automatically.

 

All in all very weird, and is *really* throwing my groove off (you don't realize how much you come to depend on the computer clock until it isn't there). Google isn't coming up with any obvious answers...has anyone run into something like this before?

 

Much thanks!


MacBook Pro, Mac OS X (10.7.4)
Solved by Richard was taken on Jan 2, 2013 8:00 AM Solved

Well just discovered that iStat Menus had an update, this has solved the issue for me. Clock now works as normal again.

  • chaitanya.ac Level 1 Level 1

    check this

     

     

    It doesn't look like you're reaching an ntp server. To verify whether your time is being synchronized, open a terminal window and type:

     

    ntpq

     

    ntpq> host localhost
    ntpq> peers

     

    This should show a list of servers that are synchronizing your clock and some other details. Check to be sure you are actually synchronizing.

     

  • BobHarris Level 6 Level 6

    If it is not the NTP server, you could try an alternate menubar clock, as an experiment.

     

    Day-O

    <http://macupdate.com/app/mac/43284/day-o>

     

    I actually like it better than the default Mac OS X menubar clock.  So if it works for you AND you like it, your problem is solved.

     

    If the problem continues, then there is an underlying problem, either with the time source, or with the menubar support infrastructure.

     

    If an alternate clock works, it means there is something specific to the default menubar clock software.

  • rosalindwills Level 1 Level 1

    Here's what I got when querying the NTP:

     

    ntpq> host localhost

    current host set to localhost

    ntpq> peers

         remote           refid      st t when poll reach   delay   offset  jitter

    ==============================================================================

    *time.apple.com  17.168.198.148   2 u   18  512    1   38.118   -1.749   1.170

    ntpq>

     

    So I guess that's working?

     

    Further updates since I posted the last message...I tried an app called MagiCal, which among other things added a new menubar clock. THat seemed to work fine and ticked along quite nicely, except the night after I installed it the computer did this weird half-crash thing and I don't know if it's related (to either the app or the clock problem) but I haven't had the guts to try it again yet.

     

    The default clock software seems to work sporadically; a couple times it's been fine for a while, or has clicked forward and caught up with itself suddenly and then fallen behind again. Weirdly, however, the computer still seems to know what time it is -- an incoming message in Thunderbird, for instance, will be correctly marked 3:30pm, even though the menu bar is still saying 2:30.

     

    So assuming that it is something specific to the default menubar clock software...is there any way to fix/reboot/decorrupt that program? Or am I just stuck with it unless I can find a working alternative?

  • Rajeev Deut Level 1 Level 1

    I have the same problem on a new Mac Mini. For me the problem happens both with the standard Mac OS X clock as well as a 3rd party, "iStat Menus". I'm wondering if it's something to do with the whole menu bar not being graphically updated as other icons in mine remain static unless clicked on whence they update. A bug in OS X more than the app within the menu bar itself. I'm running the latest 10.8.2 BTW, not Lion.

  • Topher Kessler Level 6 Level 6

    This is a UI problem instead of an issue with the system's time. Try removing the SystemUIServer preferences file, which is in the username/Library/Preferences/ folder and is called "com.apple.systemuiserver.plist."

     

    If this does not work, then try uninstalling, quitting, or removing any third-party menu items (ie, status monitors, AV software, or the like), to see if that helps the situation, as these can interfere and cause these problems.

  • Richard was taken Level 1 Level 1

    I'm also experiencing this issue. I run iStat Menus which places a bunch of system metrics in the menubar so could be that's the culprit. Didn't notice anything wrong with the clock before this morning though and I have had the iStat software for a while now.

     

    I DID configure a VPN through the network settings pane which now also shows in the menubar. Could that have triggered this?

  • Richard was taken Level 1 Level 1

    Well just discovered that iStat Menus had an update, this has solved the issue for me. Clock now works as normal again.

  • rosalindwills Level 1 Level 1

    Success! I was wondering if iStat might be the culprit but it didn't occur to me to check for an update. Went up to the latest version and the problem appears to have gone away.

     

    Thanks so much!

  • bflad Level 1 Level 1

    Same problem and same solution. Update to iStat Menus fixed it for me. Thanks for sharing!

  • Bockbertil Level 1 Level 1

    Had the same issue for quite a few days, found this thread and it solved my problem too, I never suspected iStat although when I think about it it's painfully obvoius.

     

    Thanks for sharing! :-)

  • GiantMike Level 1 Level 1

    I too had the iStat Menus update, but I had to go one step further with this article ==> https://discussions.apple.com/docs/DOC-3603

     

    Clearing the SMC and PRAM brought it back for me (iMac 27")

  • slaterk Level 1 Level 1

    +1 ... iStat update cleared my clock problem

  • Ignolopi Level 1 Level 1

    I never would have thought iStat Menu the culprit!! Thanks.

  • Jason Kichen Level 1 Level 1

    +1 to updating iStat menus fixing this problem!

Previous 1 2 Next