5 Replies Latest reply: Jan 5, 2013 10:28 AM by JoeDWoods
JoeDWoods Level 1 Level 1 (0 points)



I tried to upgrade the RAM on my mother's MB061LL/B but after the upgrade, despite the Macbook identifying the new 4GB installed memory the machine is extremely unstable and applications crash continuously. Something about a launchd error... Then eventually it will give the "power down your machine" lockscren thing.


I ran memtest in single user mode seperately on each individual 2GB stick as well as having both sticks installed together, and it found no errors after hours of scaning. When I put the original 1GB memory back again, the problems seem to disapear...


Any thoughts from anyone? We're running snow leopard, all autoupdates applied, memory is correct type etc... Well I hope it is (http://www.pcworld.co.uk/gbuk/integral-pc2-5300-ddr2-laptop-memory-2gb-sodimm-ra m-09993435-pdt.html)


I was thinking about doing a timemachine backup, re-installing snow leopard with the 4GB installed then restoring off backup if necessary...


But maybe there is an easier way?

  • BGreg Level 6 Level 6 (17,495 points)

    I was thinking about doing a timemachine backup, re-installing snow leopard with the 4GB installed then restoring off backup if necessary...


    That seems to be alot of work. Why not return the memory and buy a brand that will work? Understand that it passes memtest, which is a pretty good test, however, it obviously doesn't work running applications. Various mac models have shown sensitivity to memory over the years. Sometimes, even though memory meets the printed specs, it simply doesn't work.


    Samsung 2GB memory # M470T5669AZ0-CE6 is a 2GB module that OWC sells, and which you can probably find in the UK (OWC ships overseas too). OWC has a great reputation in providing memory and other products to mac owners. I've bought Samsung memory from them for several systems, which has worked without issues. So, I'm sure that Samsung 2GB module would do the trick.

  • Mike Sombrio Level 6 Level 6 (13,750 points)

    BGreg is right. Return the memory and buy from either the OWC link he provided or from Crucial UK http://www.crucial.com/uk/

  • frederic1943 Level 6 Level 6 (9,980 points)

    If you bought your RAM at a place that also sells PC RAM you may have gotten mislabelled RAM. PCs can handle different RAM speeds so they’ll often label higher speed RAM as a lower speed rather than make two different speeds of RAM. But Macs are much more picky. They require a RAM stick to be exactly 667mhz not 675mhz or 800mhz. The way to tell is to put one of your old RAM sticks in and it will force the new RAM to run at the correct speed.

    This is from one review of PNY RAM:
    "These modules are actually 800Mhz. PNY no longer makes or sells 667Mhz modules. Not all computers that require 667Mhz are compatible with 2 800Mhz modules. They refuse to down clock properly. This is especially true with a number of Core 2 Duo MacBooks. Spoke to PNY support, they flat out told me that yes, they sell 800Mhz modules in 667Mhz packaging. If you RMA a module that is 667Mhz (or supposed to be 667Mhz) they will replace it with an 800Mhz module as they no longer have any 667Mhz SODIMMs, not even for RMA replacement!"

  • JoeDWoods Level 1 Level 1 (0 points)

    Thanks guys. It seems like the consensus is that the new memory is at fault.


    I've ordered up something better from Crucial and we'll see if the MacBook prefers that.


    I was convinced the problem was a corrupt file somewhere... But I guess not if the machine is stable under its original RAM.


    I'll report back ASAP :)

  • JoeDWoods Level 1 Level 1 (0 points)

    Well, I was a little sceptical that this would work, but RAM from Crucial did the trick!


    I had no idea of this issue. I thought the product I bought from PC World would work as it matched the specs of the Macbook.


    It's a pity there are no tools within OS X or Memtest that can tell us exactly what the problem is with the memory we install...


    Thanks anyway guys! I learnt something new