8 Replies Latest reply: Jan 10, 2013 7:58 AM by TStam
Richard Hallas Level 1 (0 points)

OK, I've been putting off updating to the latest version of Aperture (3.4.3) because I had a sort of premonition about something bad happening to my library. But I finally got around to doing the upgrade, having felt this version had been around long enough to be stable. Big mistake. It worked OK initially, but suddenly today won't open my library, no matter what I do.


When I launch Aperture, it opens a little window with a spinning marker in it and the message "Opening Aperture Library". This is normal prior to the main window opening, but usually I see it for no more than a second or so. Now, it's all I see; the main window never appears.


Oddly, Apertur's menu structure seems to work OK while this 'loading' window is open. I can, for example, open the Activity window. However, it contains no useful information to say what's going on; the entries are just blank in this window. Also, I can quit Aperture normally (whereupon it says 'updating previews' as usual).


I've tried all three of the database-reparing options that Aperture offers if you hold down Option-Command when starting: repair permissions, repair database, rebuild database. In all three cases, it goes through the repair process and then just reverts to showing the little 'opening library' window and nothing has improved.


The upgrade to version 3.4.3 apparently went OK the other day, and I've opened and quit the software a few times since I upgraded it, and I thought everything was fine. The one thing that wasn't quite right (and I wonder if this has somethnig to do with my problem now) was Photo Stream. It didn't seem to be working properly. If I clicked the Photo Stream entry in the list at the left of the window, what I saw was just the 'welcome' message with buttons below it to sign in or turn off the service ("No, thanks" button). I didn't see any actual Photo Stream content. In this window, however, it *did* say that I was signed in with my usual Apple ID, so it wasn't very clear to me whether it was OK or not.


There's a photo I took on my iPhone which I was expecting Aperture 3.4.3 to download from Photo Stream, but it never did. I.e. just one shot that failed to download; all the previous ones had been downloaded by my previous version of Aperture. I couldn't see why the missing picture was failing to download, so I tried turning Photo Stream off and on again from within Aperture. I'm really not sure whether this worked or not; there didn't seem to be any meaningful feedback from the software.


Anyway, after having tried to launch Aperture today (and failed), I checked System Preferences and found that Photo Stream was turned off. So I turned it on again. Unfortunately it makes no difference: Aperture still won't load its library at all now.


I have tried all of following:


1. Rebooting my Mac

2. Verifying the disk contaning my Aperture library (it was fine)

3. All three of Aperture's database-repair options

4. Turning Photo Stream on in System Preferences


...and nothing makes any difference. Aperture simply will not open my library but just sits there, twiddling its spinner.


NB My library still appears to be OK, in that I can access its contents from other software successfully using the media browser.


What I haven't yet attempted is to create a blank new library and import my existing library into it. Failing any better ideas I'll try that next, but it's going to be a big operation that will take a lot of time and disk space, so I'd like to see if there are any better things to try first.


I must say I'm very disappointed that Aperture can apparently break so easily. I haven't lost any actual pictures because I'm paranoid and keep a separate copy of all my shots just in the Finder, external to any management software. But I've lost access to lots of photo books I've created over the years and various other resources, not to mention all the editing work I've done on thousands of shots within Aperture (which I haven't retained separately).


This is supposed to be professional level software. How can it seriously (a) break this easily and (b) not be able to retrieve itself via its database repair options?I'm very disappointed.

Mac Pro, OS X Mountain Lion (10.8.2), 8-core 2.8GHz (2008), nVidia 8800GT
  • léonie Level 10 (90,434 points)

    When I launch Aperture, it opens a little window with a spinning marker in it and the message "Opening Aperture Library". This is normal prior to the main window opening, but usually I see it for no more than a second or so. Now, it's all I see; the main window never appears.

    Richard, you have already covered a lot of ground with your tests. But we need to narrow the problem down further:

    Typical reasons for the main application window not to appear and Aperture hanging:

    • You may have imported a currupted image file or video - did you import something before the problem started?
    • Your library may be corrupted: To check this, create a new Aperture library, but do not import your current library - just check if Aperture launches at all and import a few images, if possible. Does it work? If yes, we will know for sure, that library needs fixing.
    • If Aperture does not even launch on a new library, try launching Aperture from a different account. If it works from a different user account, we will know, that the Aperture installation and the system are o.k., but settings in your regular account are causing problems.



  • Richard Hallas Level 1 (0 points)

    Thanks for that very helpful reply. I've followed your instructions and done some further digging too.


    To answer your three points, first of all:


    1. No, I haven't imported any images since upgrading my Aperture library for version 4.3.4; I did move photos between projects a couple of times, but mostly I just checked that everything appeared OK after the upgrade and tried to work out why PhotoStream didn't seem to be working properly.


    2. I've attempted to create a new Aperture library. This didn't work! A library gets created on disk, but attempting to open it produces the same endless spinner as the main library.


    3. I switched to a spare user account (a blank one called 'test', just as the system created it) and tried to launch Aperture and create a new library there. Same result: library is created but won't load in.


    This is very strange, because I'm not aware of having changed anything substantial on my system recently. No new software that installed anything as a login item, system service or background process etc. that I'm aware of. (I'm actually quite wary of such software, and don't have much of it on my system.) The only substantial thing that I know has changed since I last successfully launched Aperture is the year, to 2013! And I hardly think that's the cause...!


    I'm wondering if Aperture itself has become corrupted somehow, and whether I should trash it and reinstall it. But that's rather a pain because I've got the DVD version, not the one from the Mac App Store. Besides, I'm not sure what remnants it leaves on the system (sandbox files etc.).


    I've verified my startup disk, on which Aperture resides, and repaired permissions, and no error was reported (nor did many permissions need to be fixed).


    Now, the only other possible explanation I can come up with is that startup is being prevented by a misbehaving PhotoStream process, as I've just discovered that I'm having endless crashes from PhotoStreamAgent, as reported in Console. I'm getting the same series of messages popping up every few seconds:


    01/01/2013 21:58:51.649 xpcd[4676]: PhotoStreamAgent[5540]: registration request failed: (0x11, 0x0) The file “com.apple.iLifeAssetManagement.agent.plist” couldn’t be saved in the folder “Preferences” because a file with the same name already exists.

    01/01/2013 21:58:52.431 com.apple.launchd.peruser.501[473]: (com.apple.photostream-agent[5540]) Job appears to have crashed: Illegal instruction: 4

    01/01/2013 21:58:52.431 com.apple.launchd.peruser.501[473]: (com.apple.photostream-agent) Throttling respawn: Will start in 10 seconds

    01/01/2013 21:58:52.615 ReportCrash[5531]: Saved crash report for PhotoStreamAgent[5540] version 2.7 (40.34) to /Users/rghallas/Library/Logs/DiagnosticReports/PhotoStreamAgent_2013-01-01-2158 52_Richard-Hallass-Mac-Pro.crash

    01/01/2013 21:58:52.620 ReportCrash[5531]: Removing excessive log: file://localhost/Users/rghallas/Library/Logs/DiagnosticReports/PhotoStreamAgent _2013-01-01-215516_Richard-Hallass-Mac-Pro.crash


    This is just repeating every 10 seconds, as suggested by the 'Will start in 10 seconds' message. Starts; crashes; loop.


    Now, I've searched for a file called "com.apple.iLifeAssetManagement.agent.plist" and have found three instances: one each in the following places:



    /Users/rghallas/Library/Containers/com.apple.Aperture/Data/Library/Preferences/c om.apple.iLifeAssetManagement.agent.plist


    PhotoStream Agent:

    /Users/rghallas/Library/Containers/com.apple.photostream-agent/Data/Library/Pref erences/com.apple.iLifeAssetManagement.agent.plist



    /Users/rghallas/Library/Containers/com.apple.iPhoto/Data/Library/Preferences/com .apple.iLifeAssetManagement.agent.plist


    In all three cases, the file appears to be an alias that points to itself (i.e. original path is the same as the alias's path in each case). That seems weird but I hope it's right, given that it applies to all three (and the files alongside these plists in the folders in which they reside).


    Anyway, the logs unfortunately don't make it clear exactly *which* Preferences folder is being referred to, and hence which com.apple.iLifeAssetManagement.agent.plist file is causing a problem. I imagine it's the one associated with PhotoStream Agent, since it's the Agent that's producing the ongoing crash reports. But either way I don't know what to do about it. I suppose I could try trashing this particular plist file, but I'm reluctant to do so as I don't want to break anything further.


    NB Aperture itself doesn't appear to output any log messages to say what's happening while it's failing to load its library.

  • Richard Hallas Level 1 (0 points)

    A follow-on to the last message.


    The PhotoStream Agent problem may be a red herring, in that it seems to exist independently of the Aperture problem.


    If I use System Preferences to turn off PhotoStream, the PhotoStreamAgent crashes stop (unsurprisingly enough). If I turn PhotoStream back on again, the looping crashes start up again.


    However, attempting to launch Aperture is unsuccessful regardless of whether PhotoStream is on or off.


    This is all most aggravating. It wouldn't be so bad if I'd been doing any tinkering with my system that might have caused these things to break, but I haven't. They just suddenly stopped working of their own accord and deprived me of access to my photo library. Brilliant.


    I may try reinstalling the system from recovery partition to see if that helps. But these things take time, and I'm busy... Any further ideas, before I take more drastic steps, would be most welcome.

  • léonie Level 10 (90,434 points)

    In all three cases, the file appears to be an alias that points to itself (i.e. original path is the same as the alias's path in each case). That seems weird but I hope it's right, given that it applies to all three (and the files alongside these plists in the folders in which they reside).

    The folder /Users/rghallas/Library/Containers/com.apple.Aperture you have found in your library is the sandbox of Aperture - it contains data to be shared with other applications in a save way.

    I checked with my own user library - most of the aliases "/Users/rghallas/Library/Containers/com.apple.Aperture/Data/Library/Preferences/c om.apple.iLifeAssetManagement.agent.plist" are broken links; they do not point at anything; if I try to open the referenced file, I get the error message "... theoriginal item cannot be found". The aliases that are not broken point directly into the classical "Preferences" folder in the user library, in your case this would be "/Users/rghallas/Library/". 


    It looks like Aperture were trying to replace the dead aliases wby new aliases, if it creates a new Preferences file, but cannot write it.


    Are you running Aperture logged in as an administrator or as a simple user?

    Have you already checked the permissions and ownership in your user library?

  • Richard Hallas Level 1 (0 points)

    Yes, I run as an administrator. And yes, I've checked the permissions of the library. All OK.


    Actually, whilst there's clearly a problem here in terms of this plist file, it relates to PhotoStream and the constant crashing that that's now doing. I'm not sure it's actually relevant to Aperture, because Aperture fails to open the library regardless of whether PhotoStream is turned on or off. I now suspect that these are two unrelated problems that just happened to show up at around the same time.

  • TStam Level 1 (75 points)

    Same is happening to me. 3.43 with Mountain Lion. Have tried every posted fix here and in other posts. Deleting plists, photostream, loading with iPhoto first, rebuilding, creating a new library to test, etc. Nothing works. The only fix is to reinstall Aperture. Then all works fine for a few days. Then it happens again. It's not the library because if I reinstall aperture without repairing the same library that was not opening it loads fine..........for a few days. Also, the same library, which is now compatible, loads just fine in iPhoto.


    I'm on my 5th reinstall now. Last was a few days ago. I reinstalled Aperture again and as some have suggested created a new library and imported the old one into the new. So far, so good, but I fear it will happen again.


    I don't get it. I am getting frustrated enough to dump the program as much as I love(d) it.

  • Richard Hallas Level 1 (0 points)

    Nice to know I'm not alone.


    I haven't yet tried reinstalling Aperture (and am glad to hear that doing so may help, if only temporarily). However, the other night I did reboot to the recovery partition and used the Reinstall OS X option there, in the hopes that refreshing the OS installation would help.


    It didn't. Aperture behaves just the same as before, and what's more, the OS reinstallation didn't fix the problem of the PhotoStreamAgent repeatedly crashing either. I'd left PhotoStream turned off, but I've turned it on with Console loaded just now, and starting it up causes the crashing loop again, as described above.


    I'm very underwhelmed with the reliability of OS X since Snow Leopard, frankly. OS 10.6.8 was the last one that worked well on my 2008 Mac Pro. I dearly wish Apple would release the rumoured 10.6.9 update with iCloud integrated, as the loss of calendar synching etc. (now that MobileMe is dead) is probably the only thing that's dissuading me from reverting back to Snow Leopard. Mountain Lion seems bug-ridden; even my screen saver only starts once or twice per system boot, and thereafter dies.

  • TStam Level 1 (75 points)

    I have the same Mac Pro. Some have reported that deleting the plist works, others that opening first with iPhoto works. Nothing has worked for me, except reinstall. That works every time.............for a few days. If you do this and you install from an old CD you must make sure to install the update from the App Store first or your library will be incompatible. I'm hopeful that importing my old library into a new one works, but doubt it. Time will tell.


    I have no issue with Photostream.


    There are many posts on this. Just google "Opening Aperture Library" and you will see.


    This "just doesn't work". Apple needs to fix it.