Skip navigation

OS 10.8.2 not detecting Canon MP810

817 Views 3 Replies Latest reply: Jan 3, 2013 4:14 PM by PAHU RSS
Hangtown Fry Calculating status...
Currently Being Moderated
Jan 1, 2013 5:16 PM

I have been gradually setting up my iMac 27 bought a couple of months ago and have found that it does not recognize the Canon MP810 printer/scanner I have been using the past few years.  "Add Printer" does not detect it.  The USB tree under System Information does not list it.  The MP 810 software is listed as available for download on the Apple Support page.

 

I've tried changing the USB cables and using different ports.  The printer itself works fine when connected to my old iMac (G4) running OS 10.4.11.  I have done a complete power-down, disconnect, and reconnect.  I have even tried using the installation software that came with the printer.  This hangs at a 71% install until I have to use force/quit in order to shut down.

 

I do not wish to replace the printer as I have been very satisfied with how it has worked.  Any idea what the problem here is?

 

Thanks.

 

Message was edited by: Hangtown Fry

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Jan 1, 2013 10:17 PM (in response to Hangtown Fry)

    Hangtown Fry wrote:

     

    The USB tree under System Information does not list it.

    Until it does, no amount of printer driver installation, removal or reinstallation is going to help. The detection of the device on a USB bus is not printer driver dependent - it is something built in to the Mac.

     

    With all the steps you have taken already, I wonder if there is something about the new iMac's and USB power? This is the second new iMac in this forum that is not detecting a Canon printer (a different model altogether and much newer than your model) on the USB port. I don't have access to a new iMac to test this theory. If you know someone that does have a small printer that they can bring over for testing, it will help with isolating the cause.

  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Jan 3, 2013 4:14 PM (in response to Hangtown Fry)

    Good to see that you got it working. Not surprised to read that it was the USB cable after all. Cannot tell you how many times the cable has been the cause of connection problems. Even cables that were working with a previous OS or from another computer...

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.