2 Replies Latest reply: Jan 1, 2013 9:26 PM by Pagnucci
Pagnucci Level 1 (0 points)

I have had this ongoing problem. I cannot get images to automatically load in mail. Instead I always have to click the load images button. I click on a message, click load images, the images load. I click on another message, then back to the message with the images and have to reload them.


In preferneces I have turned the View>Load remote HTML images on and off and on again, and rebotted multiple times. It makes no difference. The images do not load.


I checked Little Snitch, but all ports are open.


My firewall is set to let everything connect to mail. Even just turning off the firewall does not solve the problem.


I tried removing com.apple.mail.plist but that did not work either.


This problem occurs in Mail on a MacBook Pro and on a MacBook Air both using the newest version of OS Mountain Lion. The problem happened in OS Lion as well.


The senders are in my contacts, so that doesn't help either.


This is not an issue with the serve sending the images. The images load if I click load images. They just will not automatically laod.


I've read tons of posts but no one seems to know how to solve the problem.


Does anyone have any other ideas?

MacBook Pro, OS X Mountain Lion (10.8.2)
  • Pagnucci Level 1 (0 points)

    After some more searching, I found an older post that says you should use terminal to enable inline image posting. Doing that has made some of the messages post for me. Not all, but at least some of them.


    Here is the terminal command to use:


    defaults write com.apple.mail DisableInlineAttachmentViewing -bool false



    Just run terminal, copy and paste that line, then press return. That's it.


    Not perfect, but a start of a solution.


    It seems to me that the messages that don't work now are the ones I've clicked load images on before. So new messages now load images, but not the older ones I had already tried to do.


    Still, this does seem to help.




  • Pagnucci Level 1 (0 points)

    I am not sure how to link these discussions, so below I am pasting the post that helped me. And here is the link:






    Jul 25, 2011 3:17 AM



    This is not a problem specific to Lion, but most recent OS X versions. Regularly I receive email formatted as HTML, which includes JPEG images embedded within them. These images are technically attachments, and as such, Mail.app displays them as a placeholder. Other mail apps will display these images inline, regardless of them being an attachment, remote image or otherwise.


    How can I make these images load automatically?

    MacBook, Unibody, Mac OS X (10.7), 750GB, 7200RPM WD HDD, 4GB RAM



    This solved my question by louse101  on Jul 26, 2011 3:47 AM



    No-one replied, but I found a solution on another board. Run Terminal (do a Spotlight search if you don't know where to find this), and type:


    defaults write com.apple.mail DisableInlineAttachmentViewing -bool false


    This will force Mail not to disable inline attachment viewing. Obviously, to reverse this, simple replace 'false' at the end with 'true'.

    See the answer in context