1 Reply Latest reply: Jan 1, 2013 9:42 PM by John Galt
Maddog871 Level 1 Level 1 (0 points)

I am on a Mac OS X and it is currently updated to a 10.5.8 and won't update when I click on system update. I can't buy Snow Leopard from Apple and I want Mountain Lion so I can buy iMovie '11. But you have to have at least 10.6.8 to get Mountain Lion! Help!


iMac, Mac OS X (10.5.8), not updating