1 2 Previous Next 23 Replies Latest reply: May 5, 2014 5:52 PM by Rubayee Go to original post
  • 15. Re: Can't Boot Into safe mode mountain lion
    ericfromsan jose Level 1 Level 1 (0 points)

    I too have the same issue, MBP 13 A1278 with latest ML update. I have moved the original 700GB disk to the dvd bay and placed a 240GB SSD in its place. The 700GB disk is empty, ML and all data are on the SSD drive. I cannot boot in Safe Mode, when I do, it stays stuck in the progress bar at about 15%.

  • 16. Re: Can't Boot Into safe mode mountain lion
    ericfromsan jose Level 1 Level 1 (0 points)

    Might be related to this discussion.

  • 17. Re: Can't Boot Into safe mode mountain lion
    Rob Mitchell1 Level 1 Level 1 (0 points)

    Not sure if this adds to the discussion...

     

    I'm still on 10.7, and the progress bar freezes at about 25% when I attempt to boot into safe mode on my Mac Pro. I tried starting up in safe mode from a 10.6 volume and it boots quickly. I've tried repairing permissions, etc. on 10.7, but didn't help. I'm wondering if I should reinstall the OS or try installing Snow Leopard, to see if either helps. Based on some comments, I worry it will just be a time-waster, and I don't really have a ton of spare time.

     

    Any thoughts?

  • 18. Re: Can't Boot Into safe mode mountain lion
    Topher Kessler Level 6 Level 6 (9,340 points)

    One cause for this is a damaged HFS+ attributes file, which can cause Apple's fsck_hfs routine in Safe Mode to hang. The only way around this is to either use DiskWarrior or another such tool to attempt a repair, or to completely format and repartition the drive to ensure the filesystem structure is rebuilt, and then restore a backup to it.

     

    I've found this can be the case even when Disk Utility on the boot drive does not pick up any problems; however, if it does happen then Disk Utility on an external drive or on the OS X Recovery HD partition may show a similar hang when run.

  • 19. Re: Can't Boot Into safe mode mountain lion
    Rob Mitchell1 Level 1 Level 1 (0 points)

    Thanks for your response, Topher. That leads me to more questions...

     

    Is there a way to determine with confidence if the problem is indeed the HFS+ attributes file?

     

    I haven't used DiskWarrior in a long while, and it appears their only upgrade from my version 3 software is to ship a physical disk to me for $49+shippping (or pay $99+shippping, and have immediate access to a download too -- not sure why they have that policy). Plus my internal optical drive died (though I do have a USB external)... Is there another tool you recommend?

     

    As for the restore option, would cloning the drive using SuperDuper somehow fix the problem, or does it clone the bad HFS+ attributes file? If SuperDuper clones the problem, what method of backup and restore would not clone the HFS+ attribute file?

     

    Thanks!

  • 20. Re: Can't Boot Into safe mode mountain lion
    Topher Kessler Level 6 Level 6 (9,340 points)

    Run the followign command at the Terminal to boot the system in Safe-Single User mode (or replace the "s" with a "v" in the command to do the same in Verbose mode--they should be equivalent for this purpose):

     

    sudo nvram boot-args="-s -x"

     

    Provide your password and then restart the system and it should load in a text-based environment. A number of things will scroll up the screen with the most recent events happening at the bottom. One of these should be an indication of "fsck_hfs" running and checking various files. If it stops at the step of checking the attributes file and will not proceed even after an extended period of time, then you are experiencing this problem (you will have to hard-reset to exit if this is the case, and then reset the PRAM to clear these variables so it doesnt always load in this mode).

     

    File-level cloning likely would help the situation. Just be sure to fully format the old drive before cloning back.

  • 21. Re: Can't Boot Into safe mode mountain lion
    Rob Mitchell1 Level 1 Level 1 (0 points)

    Thanks for the advice!

  • 22. Re: Can't Boot Into safe mode mountain lion
    Rob Mitchell1 Level 1 Level 1 (0 points)

    Topher, thanks to your spot-on advice, my computer will boot again in safe mode!

  • 23. Re: Can't Boot Into safe mode mountain lion
    Rubayee Level 1 Level 1 (0 points)

    Hi there friends

    I don't have apple help in my city

    I'm using MBP as desktop removed battery due to batter sensors issue.

    It is late 2011.

    It started with no startup tone chime than I set nvram so startup tone came but the persisting issue is grey bar at the startup blow apple logo that takes 20 min almost and after completion MBP turns off and requires manual turn on and upon re turning on again that grey bat appears same fasion.

    Some one told me to  go to safe mode and apply some changes but I can't go to safe mode with shift key startup login Id password bar appears and constant shift key press interrupts and again grey bat appears.

    I don't know how to disable startup password and how to disable vault.

    Please help me in

    I don't have firm ware password

    How to get into safe mode

    How to get rid of grey bar on startup

    My discs are working well I checked in recovery.

    Please help me even I don't have disc

    And if you could help me in how to open a USB net modem.with the MBP having same issues as with mine

    Thanks

1 2 Previous Next