3 Replies Latest reply: Jan 2, 2013 10:45 AM by Dutchboy777
JeninFrance Level 1 (0 points)



I have not used iMovie much since buying my Mac in 2009. But now I have a camera (Canon EOS 7D) that takes HD movies, and decided to edit some footage.  iMovie is the worst product I have tried on this Mac. The previous movie I created to this one was done about a year ago using a template. This time I did not want to use any of the vast choice of 4 ugly not very customizable templates so tried creating from scratch. It crashed / beach balled (combinations of both) at least 15-20 times in the time it took me to edit together 44 minutes of footage into a 5 minute movie. Such actions as clicking to move a clip from one section of the movie to another, adding a photo via iPhoto (love the way you CANNOT add photos from anywhere else Apple - that is a lovely touch Apple -- since I use Lightroom since I learned some time ago that iPhoto is crummy if you have more photos than will fit on your hard drive, as you have to repoint the software to "find" your new photos one by one by one (with hundreds of thousands of photos I decided to ditch your software instead) so I had to go through the trouble of importing exported Lightroom .jpg files into iPhoto just for this movie). Why oh why did I think that iMovie might be a useful tool on my Mac ??? I so regret the past 24 hours ...


After 14 hours of hair pulling, swearing and struggling, rebooting, and force-quitting beach balls -- finally I was ready to export the project, which played cleanly in the iMovie viewer.


So, now comes the final slap in the face from Apple -- Now,  no matter what format I choose to try to export this movie, I get the above error after about 1 second.


I am trying to export to a folder on my local hard drive. I have tried various folders, including the desktop to no avail. I have tried changing various export settings and methods, choosing iDVD, Quicktime and what I really want - the normal movie and always get this same hideous, undescriptive error after only about a second. I tried various sizes of movies, and screen formats. Absolutely no change in the amount of time to get this error.


I have a MacBook Pro running Mac OS X 10.6.8 and 4GB of memory. I am running no other apps while I try this and have rebooted dozens of times, repaired permissions and run various "clean up" utilities. I have 79GB free disk space on my start up disk.


When I imported the original movie files to iMovie, due to performance concerns I told it to copy the files to the disk and to reduce the video format size (my camera records HD but I did not need HD).  I saw someone say maybe the original files are on a remote disk -- but when remote disks are not connected I still get all the movies to play, so they must be locally stored. Also, when I try to use the iMovie option to Consolidate media it does not seem to do anything and returns instantly (but I can "undo" that and it also seems to do nothing ... ie takes no time at all). Yet the Consolidate Media prompt seems to show 6GB of clips are somewhere, which if copying what it claims are 6GB of files should take awhile to do it -- and it does not.


I am trying to export to a local disk, not a remote disk. The original import was from a remote attached USB drive, and I asked it to copy the files into the library at the start (in the reduced size format). That operation took awhile so it seemed to be really doing it.


I did not use an iMovie template to build the movie, I built it from clips using various of the "transitions" and added some music from iTunes (2 mp3 files) and from the default effects folders of iMovie.


I cannot easily "remake" this movie in a new project, because the clips are only small sections of various parts of the many import files and some were done as "inserts" (to have 2 video clips running simultaneously with one fading into view) etc.. There are no "caution" signs on any of the clips or music or any indication of errors when I play it in preview mode, or even full screen from iMovie. It starts up in iMovie if I click on the ".project" file from the Finder.


I have read a number of entries from advice givers regarding this error. Seems everything from "you left your car running too long" to "the refridgerator door is open" could cause this error and there is no actual way to trouble shoot what that could be except by trial and error, which I could easily spend another week doing and still never figure it out. I tried duplicating the project using the menu option, and I just get the same error.


Is there some reason Apple released this piece of *?£$!ç%*& software into the world, causing me to waste so many hours of my creative time and energy, only to find I can do nothing but view the results inside of iMovie ???


I want to really scream at someone at Apple right now for the most idiotic stupid unhelpful error message ever, and the worst piece of software ever. Worst because it makes you think you can produce something very cool, and even lets you see it in the iMovie preview viewer -- only to pull the rug out from under you at the end when you can't do anything but show it to friends who come to your house and look at your Mac.


Not really a question I guess - more like a RANT and wondering what other software out there is recommended for someone who is not a pro but wants to make nice movies that WORK and will EXPORT. I expect no one knows how to solve this because all the people I see reporting this error seem to think various hundreds of things "resolved it", so in other words it is a generic error that has no way to solve it except through hours of trial and error -- Apple should be shot for releasing this and never fixing it. I see the same error code is helpfully still there in iMovie 11 as well.


I also have no desire to upgrade to Mountain Lion, having read multiple people saying their Macs of the generation I have got really really slow after loading it, so suggest something compatible please. I am not going to waste another 12 hours trying to decipher which of the dozens of clips, edits, wipes or mp3 files could cause "error -50".


Also, I have no time machine plugged in right now, not sure what that would have to do with anything anyhow, since I am trying to export it to a local disk, not a remote one.


So - what NON APPLE product that is REASONABLE in price does someone recommend to replace this stinking pile of poo known as iMovie ???


Message was edited by: JeninFrance

iMovie '09, Mac OS X (10.6.8)
  • JeninFrance Level 1 (0 points)

    PS - have found other posts indicating that clips smaller than 2s or sometimes 5s, or "short files" can cause this. Modern style editing often uses short takes ! Good grief I cannot believe Apple. Well I deleted a half a dozen short sections and can export, but now of course the video is a ruined piiece of junk and I need to re-do the whole thing, the sound etc. which is basically taking as much time as the original. And each time I re-do it I risk again this lovely error -50 and again trying to figure out what thing bugs it via trial and error instead of a REASONABLE ERROR MESSAGE POINTING TO THE CLIP IT CAN'T PROCESS. What a mess. I HATE this iMovie application - full of BUGS BUGS BUGS which Apple will not fix obviously, since I had this product for a few years and see just hundreds of hits on Google about this error with disappointed users. Such junk I cannot believe I paid money for it and Apple does not support it with fixes !!!


    If anyone knows of a GOOD reasonably priced video editing program NOT from APPLE I am still looking for suggestions. I want to do more video in future, but obviously NOT with iMovie !!!

  • JeninFrance Level 1 (0 points)

    PS - I would not consider this "Resolved" at all some  other users have when they find some workaround that finally lets them export a movie, but still does not give clear errors about WHAT caused the software to fail to start with. This is a clear BUG in the software and Apple won't fix it, so until they do I consider it "Unresolved".

  • Dutchboy777 Level 1 (35 points)

    Have you tried deleting the com.apple.iMovie.plist file yet?  That solved a similar problem for me.  If you have not done this type of thing before, close iMovie, go to Library/Preferences and look for the file.  After it is deleted, restart iMovie.  It will be created again.  Let us know if this helps.