6 Replies Latest reply: Jan 6, 2013 10:19 AM by BDAqua
sl55amguy Level 1 Level 1 (0 points)



I have a Mac mini with a 30" Cinema display.  This setup worked fine with OS X Lion Server installed.  I upgraded the Mac mini to OS X Mountain Lion.  Now I am experiencing intermittent blackout/resolution issues on my display.  Usually this problem occurs when I park my cursor in the upper-left corner hot-spot I have defined to put the display to sleep or when I select the Login Window to lock the screen.  What happens is sometimes when the display is asleep and I tap the keyboard the display won't immediately wake up and the power button will start flashing.  If I wait for several minutes usually the display will then come alive after tapping the keyboard.  However, at this point it looks like the resolution of the display was changed to some other value and then back to the original setting.  I see on the monitor programs I had running, e.g. iTunes moved to a different location and a dialog message stating something about my resolution being incorrect (I don't recall exactly).  I rearrange everything back to normal and all is ok.  I don't have a lot of patience for waiting for the display to wake up so I discovered that if I unplug the display from the back of the Mac mini and plug it back in the monitor wakes up and all is ok.


Currently I have installed OS X Mountain Lion 10.8.2.


Any thoughts on this?  My thought is something is a little off in 10.8.2 versus Lion Server with respect to the 30" Cinema Display.



Mac mini, OS X Mountain Lion (10.8.2), Cinema 30" Display
  • BDAqua Level 10 Level 10 (121,165 points)

    Hi, have you installed the latest EFI update?

  • sl55amguy Level 1 Level 1 (0 points)



    Thanks for the suggestion.  I attempted to update and the updater said the computer did not need the update.

  • BDAqua Level 10 Level 10 (121,165 points)

    I wonder if it's a variation of this, of which I've seen many different symptoms...



    Move the mouse or trackpad cursor over the center area of the login window so you can see the user icons. Click on the icon of the user that you would like to login as, type in the user's password, and press Return.

    If the login window is configured to show only the name and password fields, type in the user's name and password into the fields, and press Return (even if you cannot see the rest of the login window).

    Additional Information

    This issue will not occur if the display is not sleeping when the account is logged out. Use the steps below to confirm that the account is not configured to log out automatically while the display is sleeping:

        1.    Open System Preferences > Security & Privacy > General.  Click the padlock to unlock the preference pane and enter your admin password. Click the Advanced button at the bottom, then see if the option "Log out after N minutes of inactivity" (where N is the number of minutes) is enabled.

        2.    Open System Preferences > Energy Saver and configure Display Sleep to occur after the account is logged out, by dragging the slider to a number of minutes that is greater than N was set to in the previous step.

    Important: If automatic log out is not needed, disable "Log out after Nminutes of inactivity" in System Preferences > Security & Privacy > General. This will also prevent the issue.



  • sl55amguy Level 1 Level 1 (0 points)



    Thanks for the info.  The "Log out after N ..." was disabled so nothing to do.  I set the Energy Saver sleep status on my monitor to never to see what happens; I always put my monitor to sleep so "never sleep" is not a problem for the monitor's life.


    If you have any other thoughts please let me know.



  • sl55amguy Level 1 Level 1 (0 points)

    Well, setting the Energy Saver sleep status to "never" didin't work, either.

  • BDAqua Level 10 Level 10 (121,165 points)

    Sorry, I'm stumped & haven't seen another report like this.


    To find out if it's system wide or user specific, try this...


    Open System Preferences>Users & Groups, unlock the lock, click on the little plus icon, make a new admin account, log out & into the new account.


    Does it work OK in the new account?