Previous 1 2 3 Next 40 Replies Latest reply: Mar 25, 2014 4:58 AM by dandeliondigital Go to original post
  • Ric91 Level 1 Level 1 (0 points)

    Hi there, just found the folder and deleted. There is no change at all, even with new Java versions.


    It is for sure a display problem. All elements in the Java window are there and working, but one cannot see them. Very strange...

  • Mferchak Level 1 Level 1 (0 points)

    I have the exact same problem.  Mac Mini running 10.7.5 Server with Filemaker Server 11.  I also am using Remote Desktop to access the server (no display).   I never had any trouble with Java until just a few days ago.  Now all of my Java windows are blank.  I have tried removing Java and the Oracle folder numerous times and re-installing, but nothing fixes the problem.

  • nemo_mdq Level 1 Level 1 (0 points)


    To me the same error occurs on a Mac Mini running 10.7.5 Server with Filemaker Server 7 and Java 7 Update 17.

    Has anyone found any solution to this problem?.


  • Paralel Level 1 Level 1 (0 points)



    Same problem here on a Mac Mini server running 10.7.5 with Filemaker Server 12 and Java 7 Update 17.


    I can see the FMS Console AND the Java Control Panel with Remote Desktop 3.6.1 only if an external monitor is connected (HDMI). As soon as I unplug the monitor, the consoles are blank and unusable.


    Any solution on this issue?


    Many thanks!

  • StaruRider Level 1 Level 1 (0 points)

    Yes it seems to be a graphic/display issue.


    If you minimize then maximize the window the elements will appear. For additional Java windows that do not have minimize available just drag the window off screen out of view and back.

  • Ric91 Level 1 Level 1 (0 points)

    This works at first sight. You have to mini- and maximize again after each mouse click. But: it works.

  • Terry Fundak Level 2 Level 2 (150 points)

    I am glad I finally found my tribe - FileMaker on MacMini Server with Java problems.....


    I have had this problem off and on for some time..... It seems to re-arise about every other java update.


    Has anyone figured out if it is indeed a problem of the MacMini not having a graphic cable of some type connected.... Is that what is up?


    It is true the the window do indeed work. I tested this by "logging in" with the blank window and it does work..... but it is really hard to know where to "Click"..... Not a very useful GUI....


    Thanx for the post. I will subscribe and hope someone will post a terminal solution.....i.e. something like rm /LIbrary/Cache/this or that...... I'm sure there is a terminal fix....... perhaps setting the screen size.....nope....


    I'm still looking for a solution ....anyone had success?

  • gannon Level 1 Level 1 (0 points)

    The problem is a constant with all headless Mac minis.


    If you plug in a screen, the java applications will all run nicely, while without screen, windows are empty.


    By minimizing a java application window, I can manage some times to see the content of the windows, but tab controls, some options and windows with not minimize possibility will not work.


    Means that it is not possble to run any java applications on our Mac mini servers (yes, a server is 99% of the time without a screen).


    Also, connecting a DisplayPort to DVI adapter will not solution the problem.


    Let's pray and hope that our solution vendors will sooon give up Java... as Java has been my bigger pain all these years...

    Let's also pray and hope that Apple will come consider the professionnals again... as Apple has disappointed us so much these last 2 years.

  • bugymac Level 1 Level 1 (0 points)

    Hi to all User that work with a Mac mini or Mac mini Server with a HDMI-Port (2010/2011/2012)

    If you have no Monitor connected to the HDMI-Port, You have Graphic Problems with all Java Apps.

    This Problem is only on Lion and Mountain Lion. With Snow Leopard it works perfekt.


    I host over 17 Servers and have a lot of experiments behind the last 200 Days about this.



    You buy a Monitor and connect him to the HDMI-Port and everythings works fin, or you go back

    to the Snow Leopard when the Mac Mini is from 2010.


    Last Check with Mountain Lion Today with 10.8.4

    The same Problems ;-(


    I hope that Apple realise this


    Best regards

  • bricci_mn Level 1 Level 1 (0 points)

    You're a genius!!!


    Thank you for (at least temporarily) solving this awful issue!

  • Mferchak Level 1 Level 1 (0 points)

    This worked perfectly for me.



    It also solved my problem of having a black screen when connecting via Remote Desktop.

  • Peter Wieriks Level 1 Level 1 (0 points)

    I too was having this problem up to the point of complete despair (including re-installing all versions of Java known to man). My final workaround used to be that I connected an external monitor to my headless mini every time I wanted to adjust something in FMS.


    But I have found the solution, and it's so obvious and simple that it made me laugh out loud when it just worked.

    Here it is: you don't run the Java applet on the server, but on your desktop machine.


    On the server, the standard URL for accessing the FMS 11 Start Page is:




    As we know, when you click on Start Admin Console it will download a Java applet on your server - which you cannot use though VNC, no matter how much you swear or try resize the window.


    Now, on *any* remote client all you have to do is change the 'localhost' bit, to an address that points to your server, e.g:





    You don't even need VNC! It's plain web access.


    *Now* when you click on Start Admin Console the Java applet will be downloaded to that local machine.

    Run it. It just works!

    (you may need to install Java Runtime Environment on your client machien first)


    It's really that simple. And probably just exactly how FileMaker has intended it to work. It's a server solution that you can access over the internet, no matter where you are. It's not a bug, it's a feature, stupid!

  • gannon Level 1 Level 1 (0 points)

    Hello Peter,


    Your answer is out of scope...


    The problem in this thread is about a java issue with headless systems, not a dns issue as in your case.

    The problem you have with your FileMaker server is probably that the localhost DNS name redirects to an IPv6 address, which is not handled correctly in some cases.


    In command line, type


    ping localhost


    This will probably show


    PING localhost ( 56 data bytes ...


    where, which is the loopback IPv4 address of your host.


    If it returns something like ::1 then this is the loopback IPv6 address, and that's the issue.

    0000:0000:0000:0000:0000:0000:0000:0001 = ::1


    If it returns any other address, your system has been hacked :-)


    Now, the java issue of this thread is not yet solved.

  • Peter Wieriks Level 1 Level 1 (0 points)

    Hi Gannon,


    Not true. I do not know where you get it from that I am having DNS issues. I don't. It's all working brilliantly, thank you. Please don't complicate a perfectly simple case!


    The reason that the original poster and myself and many others were fighting with Java not working over VNC, was because we need to administer a FM server remotely. That was the goal.

    We were mistakingly thinking that this required us to solve Java issues and VNC and monitor issues (up to soldering our own VGA dongles!) in order to be able to see the output of the Java applets. Turns out that the solution simply is: forget Java over VNC, and run the applet on a client not on the server, with a simple web interface without VNC. We were simply not appreciating the brilliance of the FileMaker's developers' solution (do you?).


    So as far as I'm concerned, I do not longer care about Java working or not working over VNC, as long as I can administer my FM server - and I can now. Problem solved!

  • gannon Level 1 Level 1 (0 points)

    Hello Peter,


    Sorry for been so hard on you in my previous post.

    You are correct, but here is more about my position regarding this issue.


    We provide FileMaker Server fp7 and fmp12 hosting solutions, and we need to manage our servers, remotely.

    We also have a bunch of servers hosted in our clients offices.


    The java bug with headless systems is still there, and remains.

    Nor Apple nor Oracle are willing to solve it.


    Now, FileMaker Server administration tool is a remote administration tool.

    This means that you don't need to be on the server itself.

    You can manage the FileMaker server from a remote host.


    So, yes, you are correct : remotely, your system doesn't have the headless issue as it has a screen, the fms administration tool being executed locally on your system.


    The problem we have is that we need secured connections to our servers.

    Enabling the fms admin tool remotely to our servers or our clients severs is not a solution that we can live with, as we have to secure the channel fms admin tool uses.

    This would mean to manage so many different VPN connections to different systems or routers, while our remote desktop tool let's us in a secured session to control all our Mac and Windows servers, wherever the server is located, without opening any ports.


    So in our case, the fms remote administration is not a solution we can rely on.

    To solve this issue on our mac servers, we have implemented a secured php application (web app) that can manage FileMaker databases (even better than FileMaker does but oriented final user). But this is not a full implementation of the sever's capabilities (logs, programs)...


    So, to your question : "Do I appreciate the brilliance of the Java remote admin solution developped by FileMaker ?" : My answer is NO, really not. Managing FileMaker Server has been a major issue for us since the move to Java. You know the Java issues, security updates that break fms admin tool...

    These issues have been there on Windows also...


    Your solution is a quick and successfull solution to manage just a few servers.

    You where not out of scope, sorry again.