4 Replies Latest reply: Jan 7, 2013 12:51 PM by dnaylor125
dnaylor125 Level 1 Level 1 (0 points)

I have ARD installed on a 10.8 mac mini server in my server closet.  the easiest way (ive found) to manage this is via VNC.  ie, i VNC from my laptop to the server running ARD.

 

I dont have ARD installed on my machine as we only have the one license, and the way i understood the licensing i believe is i can either a) install it on multiple computers if im the only one using it, or b) install it on one computer with multiple people using it.  we are in the (B) category.  have it installed on 1 server, but 3 or 4 people access it via VNC to push updates and such out.

 

the problem we have, is if someone is connected and has ARD open (or closes their connection and leaves ARD open), VNC wont connect with an error that the management application is open.

 

Connecting from 10.8.2 macbook pros, using Chicken of the VNC for our VNC client.

 

Is there a better way to go about this, or is there a way to bypass this check?  or to reset it remotely with ssh?


OS X Mountain Lion (10.8.2)
  • Templeton Peck Level 9 Level 9 (59,770 points)

    YOu don't need ARD installed on the server.  The client is built into the OS.  Install the ARD admin app on your laptop.

  • dnaylor125 Level 1 Level 1 (0 points)

    Well, with licensing requirements, unless i bought more copies of ARD (which isnt an option at this time),

     

    i do need it installed on the server.

     

    As per the apple license, commercial use, i can install it on as many computers as i want, if im the only one using it.  or install it on one computer and multiple people can use it.

     

    We have one license currently, and thats all we have, so we have it installed on the server so multiple people (the IT team) can access it and use it.

  • varjak paw Level 10 Level 10 (169,830 points)

    Remote Desktop application -> Preferences -> Security. Select the box that says "Allow control of this computer when this application is running".

     

    Regards.

  • dnaylor125 Level 1 Level 1 (0 points)

    I would like to say i checked that, but sadly i didnt, and thats exactly what i needed, thank you!

     

    as a side note, after enabling that feature i had to restart ARD before it would allow me to reconnect with it running.