5 Replies Latest reply: Jan 25, 2013 5:24 PM by Symfonic_phan
Symfonic_phan Level 1 Level 1 (0 points)

I have done a foolish thing - I was having issues with permissions with OS 10.7.5, so I decided to make them all read/write for all documents on my hard drive (using the get info dialogue) - Big mistake - now I cannot use any software or documents and the disk utility software cannot help... e.g. - I ty to activate iTunes and I get "The folder iTunes is on a locked disk or you do nt have write permissions for this folder" -  In effect, I have lost my computer.... HELP?

  • 1. Re: Catastrophic permission issues ....
    Symfonic_phan Level 1 Level 1 (0 points)

    Okay - a bit of self help...  This is what I have done in my struggle to correct - the reason I reset the permissions in the first place is, rather than having to modify the permissions of each file individually, this command simultaneously changes the permissions of all the items in the selected folder—to match the settings listed the Sharing & Permissions section of the folder’s Get Info window. Assuming the folder has the desired permissions settings, this command can quickly remedy your problem. For starters, the command doesn’t actually change the ownership of files, just their read and write permissions. This means that, if you were not the owner of the file before using the command, you still won’t own it after afterwards—even if you are the owner of the enclosing folder. The miracle is that having done it for the hard drive, that it didn't shut down my systems folder.

     

     

    1. Disk utility, which then kicks up a huge list of errors, which we are urged by Apple to ignore because there's nothing we can do about it so don't worry (yeah)...
    2. So in despair, I reloaded the OSX using the ctr-r command - it successfully rebooted but failed to change any of the settings.
    3. I tried fixing folders individually - don't - it ignores you - however, when I went in to iPhoto - the package recognises the problem and offeres a fix for the folder in question - and succeeds (for that particualr library - I have 4 and they were all fixed by the script that iPhoto is using - so there is a fix out there, it's just I can't find it (and it isn't in the disk utility)
    4. In despair, I went to root and entered sudo chmod -RN ~ in Terminal and rebooted ctr-r again and used the disk utility in the reboot - it did it's job and this time with no error returns!  Sadly, it made no difference - but I reloaded the operating system again - zilch - back to square one.
    5. I think I have done enough self-help damage...

     

    At least now I know there is a fix out there (a script imbedded in iPhoto) - the question is, what next?  Do I go out and buy 10.8?  Apparently the issue has been with us since 10.4 - so why would 10.8 be any different?  Pease someone - I want my Apple back :-(

  • 2. Re: Catastrophic permission issues ....
    Symfonic_phan Level 1 Level 1 (0 points)

    Do you ever get the impression you're writing... talking... appealing to yourself?  There's a funny echo in here...  Think I'll go away and pull some faces in the mirror for a while....

  • 3. Re: Catastrophic permission issues ....
    Symfonic_phan Level 1 Level 1 (0 points)

    Okay - faces over... problem fixed.  I replaced everything with Time Machine.  For some stupid reason, I thought time machine only backed up documents - but it doesn't.  One quick ctr-r backup and I've got my Mac back and I'm a happy bunny.  Still, the mirror bit is quite theraputic - pity I don't have any evidence that I am a changed man but there you go - start with a changed computer...

  • 4. Re: Catastrophic permission issues ....
    ~Bee Level 7 Level 7 (30,770 points)

    Symphonic --

     

    I'm just now seeing this -- I'm SO sorry no one came along to help you, but we're all so grateful that you came back to let us know what worked for you.  I'm sure your posts will help others in your unfortunate situation.  Well done, Sym!

  • 5. Re: Catastrophic permission issues ....
    Symfonic_phan Level 1 Level 1 (0 points)

    Thanks for the thought Bee - We get there in the end and who knows, learn a lot on the way.  But a little judicious intervention to nudge people in the right direction once in a while is crucial for those like myself who don't have the content knowledge to converge on a solution.  I spent too long diverging and digging the hole even deeper.  Granted, you can't create a dependence but there has to be a middle line - not sure if there are any Apple professionals who gatekeep this forum - but I guess this is a plea from the blissfully ignorant: you don't have to be culpable to help people along their way.  We all have the answers inside us somewhere but spend a lifetime looking for the right questions - at least where our Macs are concerned- you know the questions...