0 Replies Latest reply: Jan 4, 2013 10:15 PM by Twistan
Twistan Level 1 Level 1 (5 points)

Hello,

our Lion Server (10.7.5) is running fine, but since we restored it from a back-up Profile Manager no longer accepts the Code Signing certificate despite the fact that it is shown as valid in Server App's Manage Certificates.

 

I tried everything from deleting the device manager postgrep db, and restoring it as described in

https://discussions.apple.com/thread/3791994?start=0&tstart=0

 

Backup and delete db:

sudo pg_dump -U _postgres -c device_management > $HOME/device_management.sql

/usr/share/devicemgr/backend/wipeDB.sh

 

Restore the db :

 

sudo serveradmin stop devicemgr

sudo serveradmin start postgres

sudo psql -U _postgres -d device_management -f $HOME/device_management.sql

sudo serveradmin start devicemgr

 

I tried to recreate the Code Sign certificate as described in:

http://support.apple.com/kb/HT5358

 

The certificate is successfully created but it is just NOT accepted. (It does not show in the "Sign Configuration Profiles" dialog)

 

I would be very, very grateful for a hint.

(When running the server from the external clone, from which we copied the server back, the problem is not present)

 

Regards,
Twistan

 

Screen Shot 2013-01-05 at 3.35.29 PM.png


Mac mini (Mid 2010), Mac OS X (10.7.5)