12 Replies Latest reply: Apr 15, 2015 7:37 AM by Kathyj311
pjkinann Level 1 Level 1 (0 points)

My iphone 4 always used to notify me of text messages with a sound.  I didn't change anything, but one day I noticed it was not notifying me.  I checked all the settings and nothing is changed: still have the notification for text set, still have the sound set.  I rebooted.  I changed the sound thinking maybe one of them didn't work. 

 

Oddly, my husbands iphone 5 is doing the same thing!!!  We are wondering if it is a problem with ATT, because obviously we both have different iphones.

 

Has anyone had this problem?  Only way I can see if I have a text is open my phone and look at the texts, and they will appear on the front screen; however, I will never be notified that I received one with the sound.

 

Does it have anything to do with iCloud? Is iCloud somehow not picking up the sounds for text or something?

 

Anyway, it's very annoying and frustrating because we use our text more than the phone calls or email.  And now we don't know when we've received a text, unless we want to look at our phones every 10 minutes LOL

  • uselessSABOTAGE Level 4 Level 4 (3,680 points)

    Do you have "Do not Disturb" set to run on a schedule?  There apparently is a bug with it since the new year that will no longer be happen after 7th/8th of jan.  I read an article and it is likely to do with programming language using "YYYY" instead of "yyyy" for year.

     

    Long story short using "YYYY" the first days before the first monday in the new year appear to the program to belong to the previous year.

     

    So what I was getting at was try turning off Do not Disturb (settings-do not disturb-set to off).

     

    Also check the mute switch on the side of the phone, above the volume keys.  The switch should be toward the front of the device.

  • pjkinann Level 1 Level 1 (0 points)

    Wow! you're awesome! Thanks so much! The "Do Not Disturb" setting solved it.  I turned off both our "Do Not Disturb" settings, then rebooted both the phones, held my breath and tested!  Got notified!!! Yeah!!!

     

    I had, of course, already checked switch on side, and all settings, and everything known to iphone LOL EXCEPT the "Do  Not Disturb."  I looked at it a couple times and thought, hmmmm . . . but the schedule isn't set for all day, and all day I don't get texts.  So just didn't bother to try that.

     

    So thank you VERY much for responding, because that IS the problem.  A shame that Apple didn't get it together because that's a REALLY nice feature.  I'll have to go back to shutting off the phone at night, and that's not good either in case someone had an emergency.  But otherwise, everything on the phone keeps me awake all night, emails coming in, little ring-a-dings here and there LOL.  I could shut all THAT off, but it's easier to just shut off the phone.

     

    Thank you again very much!

     

    P.S.  Apple thinks they're going to have it fixed after the 7th or 8th??  I'll try again then to turn back on the "Do Not Disturb".

  • uselessSABOTAGE Level 4 Level 4 (3,680 points)

    From what I understand, the issue was with how the date was programmed.  Certain ways to "code" the year in programming language mean different things.  So from an article I read (http://arstechnica.com/apple/2013/01/ask-ars-why-will-apples-do-not-disturb-bug- fix-itself-next-week/) says that using "YYYY" instead of 'yyyy" for the date in the language has caused this snafu.  The program sees the "off" date as being in 2012 and so it doesn't bother to do anything.

     

    Again this is what I read, not anything I actually know.

     

    I am glad that this fixed your issue.  However, I believe you could still use the feature, simply manually turn it on/off and you should be good. You could use the reminders app to remind you in the morning to turn it off... Again, the issue should be resolved.

     

    Last but not least, you're welcome and Happy New Year!

  • pjkinann Level 1 Level 1 (0 points)

    Good idea. And thx. Happy New Year to u as well.

  • titus1971 Level 1 Level 1 (0 points)

    I am having a similiar problem with my iphone 5 regarding text audible notifications. The majority of the time I have my email and text notifications set to vibrate only and ringer is audible. However when I get to work i set the text notification to audible so i can differentiate it from my emails. about 75% of the time I have to do a power off/on to be able to hear the texts. Just changing it from vibrate only to a tone will not work. No other settings sem to affect it and I'm not using the Do not disturb feature. It's been very consistent in this behavior.

  • Twillick Level 1 Level 1 (0 points)

    I have the same problem titus1971 has. I found that turning it off, then on again (power cycling it) reset the Do Not Disturb and it worked for me. However, this is a bad bug and needs to be fixed.

     

    EDIT:

     

    Why I think this is a "bad bug": because the phone is no longer providing important information AS A PHONE. I don't get too upset when an app misbehavies, but when a phone stops provinding text notifications, and you start missing important texts, then I would grade this as a "must fix soon".

     

    Message was edited by: Twillick

  • ChrisJ4203 Level 8 Level 8 (41,230 points)

    What user troubleshooting have you tried to fix this "bad bug"?

  • Twillick Level 1 Level 1 (0 points)

    Did you not read what I wrote? As a far as I am concerned, if the behaviour is to suddenly stop notifying, and change in power state consistently corrects the issue, that's enough user troubleshooting done. TIme for Apple Tech Support to jump in.

  • ChrisJ4203 Level 8 Level 8 (41,230 points)

    Well, you are not addressing Apple here, we are users like you. If you want Apple Tech support to jump in, then you need to contact them. Typing something here does not do that. If you should call Apple Care, they are going to ask you if you have performed all of the user troubleshooting, I was just trying to help you out, but it appears you do not want my assistance.

  • Rocksteady17 Level 1 Level 1 (0 points)

    To you  poster: pjkinann

     

    Thank you SO much for your post regarding the Ringtones that stopped notifying.(ringing)!!

    Yup! I was screwing around with the Do Not Disturb last night. Also flipped the right switch on the outside of the iphone UP and it's working GREAT.

    Whew...wasted a day and I shoulda checked here first.

    You're such a NICE person! ~

  • pjkinann Level 1 Level 1 (0 points)

    You are certainly welcome!

  • Kathyj311 Level 1 Level 1 (0 points)

    Thank you so much-it was making me crazy and I didn't even know what that "moon icon" was there for.  I know I didn't set Do Not Disturb, it must've automatically done it when I updated my phone.