2 Replies Latest reply: Jan 5, 2013 8:39 AM by steve359
jonamac54 Level 1 Level 1 (0 points)

I have an IMAC  running 10.5.8

2.4 Intel core 2 duo

How much is it going to screw things up to upgrade to snow leopard....

 

I can't even plug my Iphone into this computer because the computer won't "run" a compatible version of Itunes. That is the only reason i need to upgrade... And I don't think quicken 2007 will run on Snow Leopard


iMac, Mac OS X (10.5.8)