3 Replies Latest reply: Jan 5, 2013 9:08 AM by lemmans
annaoscar Level 1 (0 points)

My son has an iPod touch (probably 3rd or 4th generation) and wanted to download some new apps. However a window pops up saying Update required, this app requires iOS 4.3.

How do I get iOS 4.3 please?


iPod touch
  • Niel Level 10 (298,591 points)

    Connect it to iTunes on a computer and check for updates.

     

    (73728)

  • roaminggnome Level 10 (95,042 points)

    If he has a second gen ipod touch then he cannot upidate past 4.2.1

     

    Identifying iPod models

  • lemmans Level 1 (5 points)

    Hi... I am sorry to tell you this, but that is happening to anyone with a 2G iPod Touch because Apple is telling developpers to work with new tools that only generate iOS 4.3 or + compatible apps.

    This means that if you want to intall an app and this app is made with the new tools, you wont be able to. Why? To make you buy a new product.

     

    What I wonder is: shouln't Apple be giving the opportunity to download older versions of the apps instead of making your device go out of use? Is that so hard? I honestly don't think so.