1 Reply Latest reply: Jan 11, 2013 10:40 PM by Raelyk
Raelyk Level 1 Level 1 (0 points)

Even with "allow calls from favorites" on, my husband's phone calls are blocked and won't go through unless he calls more than twice in 3 minutes. I've had my iPhone 5 since it launched and it's been a problem since day 1, any help?  This is just during the scheduled hours and has nothing to do with the 1/1/13 issue.  Any thoughts?

iPhone 5
  • Raelyk Level 1 Level 1 (0 points)

    Found this fix on another thread for anyone reading this



    I'm having the same issue but found a workaround:

    I assume that your favourite contact is associated with a facebook contact, right? What you have to do is

    1) disable "do not disturb" mode

    2) delete the contact from your favorite list

    3) edit the contact: delete the association with the facebook contact

    4) re-add the contact phone number to the favorite list

    5) optional: edit the contact, re-associate the contact to the related facebook contact

    6) enable the "do not disturb" mode.


    For me this worked, once a contact phone number is added to the favorite list while the contact is NOT linked to the related facebook contact will allow this contact to call you while in do not disturb mode.

    If the contact phone number is added while it is linked to a facebook contact any calls from the number will be blocked.