2 Replies Latest reply: Jan 6, 2013 1:39 AM by Klaus1
twhite512 Level 1 Level 1 (0 points)

I have the MacBook Pro 2009. I just bought a printer & it won't install because "this HP software is'nt compatible w/ your version of Mac OS X". I need at least Mac OS X v10.6-v10.7. I have the OS X v10.5.8. No updates are showing. Where/what do Install? I keep going in circles with the options I 'think' are going to help.


MacBook Pro, Mac OS X (10.5.8)