1 Reply Latest reply: Jan 6, 2013 7:36 AM by Niel
sherif29 Level 1 Level 1 (0 points)

my macbook 10.4.11 osx will not update to mountain liion states that i need to be on 10.6.00 prior to moving forward


Mac OS X (10.4.11)