14 Replies Latest reply: Aug 21, 2013 11:39 AM by Csound1
realMacMark Level 1 Level 1 (95 points)

iCloud's function "Documents & Data" is not available for my main user in all applications. When i use for example TextEdit i can do File -> Move To … and then select either iCloud or Recent Places or Favorites or Devices. But on my main account "Move To …" does not show the iCloud option.

 

Every other program for this user cannot use iCloud documents too. What might be wrong with my user?

 

Of course "Documents & Data" for iCloud in System Preferences is enabled.

 

Also when doing "Open …" with TextEdit and then clicking iCloud, the view below remains local file system and does not show my TextEdit iCloud documents like on other Macs. It cannot access iCloud obviously.


OS X Mountain Lion
  • 1. Re: Move to … iCloud not available
    Winston Churchill Level 10 Level 10 (81,980 points)

    What do you mean by your main user.

  • 2. Re: Move to … iCloud not available
    realMacMark Level 1 Level 1 (95 points)

    It is just the user i usually use. Other users are for testing.

  • 3. Re: Move to … iCloud not available
    realMacMark Level 1 Level 1 (95 points)

    When i use the Open … dialog in any iCloud enabled application, i see those entries in my log files:

     

    06.01.13 17:42:49,457 librariand[409]: unable to get mobile documents URL

    06.01.13 17:42:49,457 librariand[409]: error in _handle_client_request: LibrarianErrorDomain/10/Unable to configure the collection.

     

    Also: "Mobile Documents" does not exist in ~/Library.

  • 4. Re: Move to … iCloud not available
    Winston Churchill Level 10 Level 10 (81,980 points)

    Are they on the same computer or start up disk, are they all using ML, lion doesn't have document syncing through the applications. I assume you have documents and data checked in system preferences.

  • 5. Re: Move to … iCloud not available
    realMacMark Level 1 Level 1 (95 points)

    The users are on the same computer, same disk, same startup disk, on Mountain Lion, documents and data are checked in sys prefs.

     

    When an iCloud-enabled application like TextEdit or Pages try to access iCloud in Open-dialog it beeps an gives the errors in log files like shown in other post.

     

    When i use a fresh OS X user and set him up with my iCloud account, everything is working. So it must be something wrong with my OS X user.

  • 6. Re: Move to … iCloud not available
    Winston Churchill Level 10 Level 10 (81,980 points)

    Yes sorry, I must have posted while you were posting and missed it.

     

    You might try the following, every step may not apply:

     

    1. Sign out of your account


    (If you are unable to do this because System Preferences has frozen, Force Quit System Preferences and try again)


    2. When prompted, opt to delete, contacts, calendars etc from your Mac.


    (You are only deleting this data from your Mac, not from iCloud, the data will be reinstated when you log back in. If you need to check that the data is in iCloud before deleting it go to iCloud.com and check each section for data)


    3. Having logged out, check that the iCloud accounts along with their data have disappeared from the Mail, Address Book and iCal Applications.


    (If necessary, delete the iCloud accounts from each of these application separately from each Applications Preferences)


    4. At this point it may be worth trying to log into iCloud from the System Preferences iCloud settings again, if this works, all well and good, if it doesn't continue to step 5.


    5. Open your User Library folder in the Finder. (When in the Finder, go to the Go menu, hold down the option key (alt) and choose Library when it appears in the Go menu)


    6. Navigate to Library > Application Support > iCloud and drag the iCloud folder to your desktop. (This action only copies the folder and will provide you with a back up)


    7. Select the iCloud folder again in Library > Application Support and drag it to the trash, enter your administrators password when prompted.


    8. Restart your computer.


    9. You should now be able to enter your ID and Password in system Preferences > iCloud and log into your account. Check the services you wish to use and once you are satisfied it's working as it should, trash the iCloud folder you copied to your desktop earlier.

  • 7. Re: Move to … iCloud not available
    realMacMark Level 1 Level 1 (95 points)

    The iCloud folder in Application Support was then created by the system, i logged into iCloud again, but the problem is still there. TextEdit for example cannot show me iCloud files when i click on "iCloud" in the Open … dialog.

     

    The error log shows:

     

    06.01.13 19:29:01,135 com.apple.security.pboxd[479]: CGSGetWindowTags: Invalid window 0x96

    06.01.13 19:29:01,136 com.apple.security.pboxd[479]: kCGErrorFailure: CGSSetHideOnDeact: error getting window tags

    06.01.13 19:29:01,138 librariand[378]: unable to get mobile documents URL

    06.01.13 19:29:01,139 librariand[378]: error in _handle_client_request: LibrarianErrorDomain/10/Unable to configure the collection.

    06.01.13 19:29:01,387 WindowServer[133]: _CGXSetWindowHasMainAppearance: Operation on a window 0x97 requiring rights kCGSWindowRightOwner by caller TextEdit

    06.01.13 19:29:01,504 com.apple.security.pboxd[479]: CGSCopyWindowColorSpace: Invalid window 0x96

    06.01.13 19:29:02,997 WindowServer[133]: _CGXSetWindowHasMainAppearance: Operation on a window 0x97 requiring rights kCGSWindowRightOwner by caller TextEdit

  • 8. Re: Move to … iCloud not available
    Winston Churchill Level 10 Level 10 (81,980 points)

    I'm not sure in that case, if that didn't help.

  • 9. Re: Move to … iCloud not available
    realMacMark Level 1 Level 1 (95 points)

    I fixed it by creating a new user and moving my data from the old to the newly created user. I used this http://support.apple.com/kb/HT1428?viewlocale=en_US&locale=en_US to do it.

     

    Resetting permissions and ACLs in home folder via Command-R boot and then resetpassword-utility did not work well, so i used the link above which is a nice trick to get the pemissions in ~ right.

     

    I omitted to copy in ~/Library/Application Support/ everything iCloud-related like iCloud, Librarian, SyncServices, Ubiquity. Also i did not copy ~/Library/Mobile Documents.

     

    Finally i renamed home and recreated the original account with the link above to get my original Unix user name back.

     

    Now iCloud is working on this account again. This account had already some other troubles like you can see in my earlier discussions. Something must have gone wrong during some upgrades - just my guess.

  • 10. Re: Move to … iCloud not available
    Bodhi Level 1 Level 1 (55 points)

    How has no one mentioned how ridulous it is that you have to do this to get a signature back?  Sorry, got to be another way.

  • 11. Re: Move to … iCloud not available
    pigg Level 1 Level 1 (0 points)

    I have a similar problem. When I create a signature or saved mailbox in Mail (on 10.8.4), it isn't there once I close and reopen Mail. This thread helped me track down the problem to iCloud's Documents & Data. If I turn Documents & Data off, the changes are saved to ~/Library/Mail/V2/MailData/. When the feature is turned on, changes to these two (signature and saved mailbox) don't save there and don't persist.

     

    I ran Repair Disk Permissions early in my troubleshooting process, but that didn't help. For what it's worth the MacBook Pro Retina 15" is new and the user account doesn't have administrative privileges.

     

    I'd prefer to not have to create a new user account and move all my data. If anyone has any suggestions, I'm all ears.

  • 12. Re: Move to … iCloud not available
    Csound1 Level 8 Level 8 (35,330 points)

    Promote your existing account to an Administrator. You'll need an Admin account to do that.

  • 13. Re: Move to … iCloud not available
    pigg Level 1 Level 1 (0 points)

    Thanks for your help Csound1. I have a separate admin account. It's against company policy (and not a good practice) to have admin rights on the account you use every day.

     

    Are you suggesting I temporarily promote my account? If so, that's possible though what steps should I take with admin rights?

  • 14. Re: Move to … iCloud not available
    Csound1 Level 8 Level 8 (35,330 points)

    I was simply addressing this:

     

    I'd prefer to not have to create a new user account and move all my data. If anyone has any suggestions, I'm all ears.

    Rather than making a new account and moving data it would be simpler to promote the one you have, I am not addressing any of the other posters questions, and frankly you would be better served by starting your own post, and stating your question. There are too many in this thread already.