7 Replies Latest reply: Jan 8, 2013 1:17 PM by Grant Bennet-Alder
Gerungof Level 1 Level 1 (0 points)

I tried to install Windows 7 on the second hard drive of my new Mac Pro, but I think I deleted the 200MB-sized EFI-partition, because when I try to restart it says "no system disk. Press any key to restart", but it doesn't do anything when I press Option-key or Cmd+R. I can't get any system working. Thanks for helping me in advance!


Mac Pro, OS X Mountain Lion (10.8.2)
  • mende1 Level 10 Level 10 (91,320 points)

    Welcome to the Apple Support Communities

     

    Your Mac can work without the EFI volume, but I doubt that you deleted it. The EFI volume is only used to store firmware updates and install them on its next boot.

     

    Try pressing X key to start into Mac OS X. If it doesn't work, reset the PRAM, so the startup disk will be restored to factory settings

  • Grant Bennet-Alder Level 9 Level 9 (52,870 points)

    Press any key to restart

    When you get that obtuse prompt, it is not coming from Mac OS X.

    Those sorts of useless messages come only from Windows.

     

    As mende says, you need to get control of your Mac BEFORE it commits to booting Windows and gets stuck there.

     

    In addition to his suggestions, you could hold the Alt/Option key at Startup. This invokes the All-in-ROM Startup Manager, which will look at all Volumes and draw an icon for each potentially-bootable Volume.

  • The hatter Level 9 Level 9 (60,790 points)

    never install Windows on t he same drive as Mac

    pull all t he oter drives

    let Windows totally format and take over its own hard drive.

     

    Works like a charm.

  • Gerungof Level 1 Level 1 (0 points)

    Thanks for your quick responses!

    Unfortunately It didn't work out at all. When the screen telling me to press any key to reboot comes up, I am not able to do anything, no matter what key I press. Nothing happens. Event the combinations CMD+R for the restore-partition, CMD+X for the Mac OS-partition and CMD+Option+P+R for resetting the NVRAM/PRAM don't appear to do anything. I am still stuck in this Windows-thing.... I think this happens because something during the installation process went wrong and the Windows-installer told my Mac to boot from the Windows-drive. But I still don't know how to get out of there.

  • mende1 Level 10 Level 10 (91,320 points)

    You have to press them after the startup sound, not when the black screen has appeared. You can't do anything when this screen shows up

  • Gerungof Level 1 Level 1 (0 points)

    I do press the hotkeys, when starting the computer, before the Windows-thing appears. I even tried to remove the HDDs and the DVD-drives, but this didn't help me to reset the NVRAM either. I am going to call the apple support tomorrow.

  • Grant Bennet-Alder Level 9 Level 9 (52,870 points)

    You must have the keyboard connected Directly to a USB port on the chassis, not on a Display or Hub.

     

    The Hubs are initialized too late for "snag keys" to be seen at Startup.