Previous 1 2 Next 16 Replies Latest reply: Jan 7, 2013 11:38 PM by vickyjones
vickyjones Level 1 (0 points)

I purchased a new iMac running Snow Leopard. I have been attempting to back it up via Time Machine to an external hard drive (Western Digital My Book Essential) for several days now.  I'm not a technical person, so please bear with me as I try to describe my issue.


I have 104GB of stuff on my computer. The WD hard drive holds 999GB.  I reinitialized the external drive before beginning, and I verified it through Disk Utility. I have repaired permissions using Disk Utility and Onyx. The only thing I've excluded from the backup is the backup drive itself.


I have tried three times to back up with TM.  Each time, TM tells me it will need between 27 hours and 3,000 days to do the job. I let it work overnight, and, when I check on it the next day, the progress bar tells me that  the task will be completed in 5 seconds.




It will sit on "5 seconds" for hours, although the number of files changes:



If I restart the computer and try to begin a manual backup, TM tells me that there has never been a backup, but, clearly, something is being recorded onto the hard drive, because space is getting used up.


What am I doing wrong?


I've been looking through threads for this issue, and I can't find it, although I have seen experts requesting for a sample from the log.  Here is part of the log on the latest backup that I cancelled. I don't understand log language, so please forgive me if I included irrelevant stuff:


1/6/13 11:03:55.214 PM[766]: Starting manual backup

1/6/13 11:03:56.292 PM[766]: Backing up to: /Volumes/MyBook/Backups.backupdb

1/6/13 11:03:57.331 PM[766]: Forcing deep traversal on source: "Big Sister" (mount: '/' fsUUID: B5CB7EC3-145D-3164-A7E3-2BD90A6DEB1C eventDBUUID: 71D4E79C-74C5-49D3-9AE2-C7E5FE3EF38C)

1/6/13 11:03:57.423 PM[766]: Warning: Bytes to copy estimate was negative (-1783297686)

1/6/13 11:03:57.424 PM[766]: Found 573831 files (104.9 MB) needing backup

1/6/13 11:03:57.443 PM[766]: 104.9 MB required (including padding), 870.26 GB available

1/6/13 11:06:44.437 PM System Preferences[728]: Could not connect the action backUpOnBatteryPowerPressed: to target of class TMOptionsSheetController

1/6/13 11:08:28.550 PM[766]: Copied 209 files (299.8 MB) from volume Big Sister.

1/6/13 11:08:28.563 PM[766]: Backup canceled.


Thank you to anyone who can help me do this correctly. I've been using TM for years on two other computers and have never had this perplexing problem.

iMac (21.5-inch, Late 2012), OS X Mountain Lion (10.8.2)
  • John Galt Level 8 (44,680 points)

    The screenshots and log excerpt are very helpful. The obvious problem is that Time Machine is reporting a nonsense value for the number of bytes to copy estimate, but the reason for this is a mystery.


    Please confirm that you are using Snow Leopard. Your profile indicates


    iMac (21.5-inch, Late 2012), OS X Mountain Lion (10.8.2)


    ... this is the Mountain Lion support area, your topic mentioned 10.8, and you said you purchased a "new iMac" which would certainly not be running Snow Leopard. Diagnosing what's wrong requires clarification.

  • vickyjones Level 1 (0 points)

    Yes, it's Mountain Lion, if Mountain Lion is 10.8.2.


    My inability to cite the specific cat that I am working with on this machine attests to my technical ineptitude.

  • John Galt Level 8 (44,680 points)

    Thanks for confirming that you're running Mountain Lion, that will help.


    1. Did you install any Western Digital software that may have been included with the MyBook?
    2. How did you initially erase the MyBook - did you use Disk Utility or something else?
    3. Are you using any virtualization software e.g. Parallels, VMWare...?
    4. Are you using any non-Apple "Anti-Virus" utilities - anything at all?
  • Linc Davis Level 10 (184,800 points)

    You did excellent groundwork on the problem.


    Open the Time Machine pane in System Preferences. Click the padlock icon in the lower left corner, if necessary, to unlock it. Scroll to the bottom of the list of backup drives and click Add or Remove Backup Disk. Remove the problem disk, then add it back. Quit System Preferences. Test.

  • vickyjones Level 1 (0 points)

    Thank you, John and Linc for helping me through this.


    @John Galt: I reinitialized the external drive using software from WD. WD also provides software for performing backups, which I have not used; however, as you can see from this screenshot, the WD software has already profiled my iMac. 




    I don't think this is a WD problem.  I've used this external drive in the past to back up two other computers (simultaneously). I reintialized the drive to make room for backups from my new iMac ("Big Sister").  The 131.8 GB of so-called "Additional Files" is clearly data put there by TM.  If it had been put there by the WD software, the data would have shown up in the individual folders/volumes/whatever-they're-called.


    As far as I know, I am not running any virtualization software or non-Apple anti-virus utilities.


    @Linc Davis: I tried your suggestion, to no avail. I even restarted the computer.


    Tra la la:






    Some other things I have been trying:


    • I went through the System Profiler and looked for everything that might still be hanging out inside my computer that was identified as Classic or PPC, and trashed them.
    • I disabled all of the applications I had selected for automatic login, thinking that maybe there is something running in the background that might be reproducing itself.
    • I took my computer through Onyx again.
    • I restarted it in "safe mode."


    I'm wondering two things:


    (1) Whether this has anything to do with Spotlight.  I keep seeing this in the log:      

    1/7/13 2:04:01.575 AM[199]: Waiting for index to be ready (100)


    (2) Whether I should just forget trying to get TM to work, reinitialize the WD drive, and use the WD software. Although TM seems to be loading data onto the drive, it's not accessible to me because it is always presented as "in progress"...



    and I can't find anything when I enter Time Machine.


    Do you think there might be something in that last 115.3 MB that is messing things up?  If so, how do I find it?




    I'm sorry about all these screen shots.  I don't know how else to describe this.


    I will restart my computer, run Time Machine for a few hours, and then post the log again.


    Thanks to everyone so far.


    Tra la la.



  • vickyjones Level 1 (0 points)

    I take it back about the 115.3 MB. It's all over the place.



  • Linc Davis Level 10 (184,800 points)

    I restarted it in "safe mode."


    Did you try to back up while in safe mode?

  • Topher Kessler Level 6 (9,865 points)

    I know you verified your external drive with Disk Utility, but did you do the same for your internal boot drive? Try doing this to see if the source file system is intact or needs repair. It's possible a fault in this drive's formatting could be the reason for improper file size and file counts being read by the backup process.

  • John Galt Level 8 (44,680 points)

    The screenshots are very helpful.


    Apple states that formatting the drive with Disk Utility is a requirement for Time Machine. I recommend you do not use Western Digital SmartWare regardless of prior experience with it.


    The 131.8 GB of so-called "Additional Files" is clearly data put there by TM.


    I agree but that is not likely to matter.


    I suggest you do the following:


    • Turn off Time Machine for now.
    • Boot your Mac using OS X Recovery. At the OS X Utilities screen, select Disk Utility. At the Disk Utility screen, select your source volume ("Big Sister") and click Repair. Let it repair the volume.
    • Still using Disk Utility, erase the backup volume. Select your backup volume ("MyBook" - be sure it is not your source volume), select the Erase tab, and next to Format select Mac OS Extended (Journaled).
    • When it is finished quit Disk Utility, quit OS X Recovery, and restart your Mac.
    • After it restarts, force Spotlight to erase and re-index your source. There is an Apple KB article that explains the procedure but it does not specifically indicate its applicability to Mountain Lion, so to be certain the Spotlight index is correctly erased and rebuilt, do the following instead:


    You must first be logged in as an Administrator.


    In Terminal, type the following:


    sudo mdutil -E /


    and press Return. At the Password: prompt, type your Administrator password followed by the Return key. The password characters will not be echoed, not even with ••• characters.


    This will erase and rebuild the Spotlight index, which may take several hours.


    You will know it has finished when clicking the Spotlight menu icon no longer shows a progress bar. When it does, re-enable Time Machine and select the backup volume.


    I believe the cause of this problem is a corrupt Spotlight index, which may have been the result of using WD SmartWare, Onyx, or other unknown. Reformatting your backup volume and repairing your source volume are simply additional steps to ensure there is no obvious file system corruption that may have contributed to this.


    Do not use Onyx to do anything. It may be harmless, but it cannot possibly help with anything.


    Also, be sure to address questions 3 and 4 above. Anti-virus junk can interfere with Time Machine, and virtualization software can cause very slow backups.

  • Topher Kessler Level 6 (9,865 points)

    In addition to removing the spotlight index on the boot drive, yoiu can also try doing so for your Time Machine drive. While you can do this using the command John Galt mentioned, you can also do it by dragging both of your drives to the Time Machine "Privacy" list (in the Time Machine system preferences) and then remove them from this list.

  • vickyjones Level 1 (0 points)

    Thank you, everyone, for releasing me from Time Machine ****.


    In case anyone has a problem similar to this, here is what ended up producing a successful Time Machine backup:


    1. I was unable to erase the WD external drive using Disk Utility. In OSX Recovery mode, my computer couldn't see the drive. In regular mode, Disk Utility told me that it could not erase the disk because it was "in use". 
    2. I shut down my computer, disconnected the WD external drive, and connected it to my old computer, with which the drive had no pre-existing relationship (because I had earlier removed all of the backup data associated with that computer). I was able to erase the disc with that computer using Disk Utility.
    3. Using John Galt's directions, I erased and rebuilt the Spotlight index. It took about a half hour.
    4. I connected the WD drive -- it still required the WD password to mount, and perhaps one of you knows why -- but I was able to select it as my Time Machine disc and execute a back up. It took about an hour.
  • vickyjones Level 1 (0 points)

    Thank you for holding my feet to the fire regarding #3 and #4. 


    3.  I haven't had any third-party anti-virus software since OS9. I went through my computer to make sure there weren't any old preferences hanging around. I don't have any software that helps me clean out old preference files, so I hope I got everything. Maybe you can recommend something?


    4.  I don't think I know what virtualization software is. I have X11 on my computer, although I have never used it. Is X11 virtualization software?  I could remove it, if it would improve my life as a backer-upper.

  • vickyjones Level 1 (0 points)

    Linc, one of the reasons I was able to get as far as I did on my own was because of all of the good advice you've given people in other posts. I feel like you must be an Apple community guardian angel. Thank you.

  • John Galt Level 8 (44,680 points)

    Splendid. Thanks for the follow up. This could have been vexing to resolve if you had not described your observations in such detail.


    Preferences files are generally very small, inert, and can be ignored. There are exceptions, most of which are Microsoft-related. Others may be created by clever third party hacks that destablize your Mac and interfere with its file system, which is the reason for asking about AV software. I have not used any since Macs needed floppy disks, and even then there was only one that was useful.


    I would avoid using any clever utility to identify and erase old Preferences files, or anything else for that matter. Use the Finder and sort Preferences files by Date Modified. If they have not been modified in years, then they are candidates for removal. If you are overly concerned they might be necessary, then drag them to a temporary folder and leave them there until you are satisfied they are no longer required. If you guessed incorrectly and a previously functioning program is demanding registration information (for example), just drag the Preferences file back to its original location.


    Virtualization software includes various means of running Windows on a Mac. This results in thousands of small items and memory swap files that constantly change, causing Time Machine to run slowly. X11 is not that.

Previous 1 2 Next