7 Replies Latest reply: May 1, 2015 6:57 AM by Cemoi
Chenbmac Level 1 Level 1 (0 points)

Hello everyone,

 

I recently bought a late 2012 top of the line Mac Mini running MAC OSX Mountain Lion 10.8.2.

 

When connected to a SAMSUNG Monitor/TV (Model: T27A550) via the HDMI port, I'm only able to get the sound through the Monitor speakers, if it's through the analog Audio IN connection of the monitor, using a 3.5mm traditional audio cable connected to the Mac Mini's LINE OUT.

 

If I'm not mistaken HDMI also supports sound output through the monitor's speakers. Right?

 

I went to the system preferences to change the sound output device. There were the Headphones and the Monitor model as the only 2 options. When trying to select the HDMI option it automatically reassigns the Headphones options.

 

I also tried to configure the audio output to go through the HDMI output via the AUDIO MIDI SETUP. Once again I was unsuccessful.

 

Does anyone have any idea as to how to solve this issue? Is it a hardware or software issue? Does anyone know if APPLE is working on a software update to solve this problem?

 

Thanks a lot!


Mac mini (Late 2012), OS X Mountain Lion (10.8.2), SAMSUNG SyncMaster A27TA550
  • philhoggins Level 1 Level 1 (10 points)

    I have the exact same setup as you.  Firstly how are you connected, I have a thunderbolt to HDMI cable converter to make the connection, are you going HDMI to HDMI?, does your HDMI cable support audio ?, second you will have no volume control via the keyboard using HDMI for sound which is a real pain.  I use Soundflower to get over this and have a very happy audio setup (google how to set it up)

     

    Phil

  • qazxsw52 Level 1 Level 1 (50 points)

    FWITW:  Using HDMI to HDMI I have sound control in iTunes via a wireless keyboard: the apple key and the up down arrows.

    HTH

     

    What I dont have is sound control via the Apple remote within iTunes

  • philhoggins Level 1 Level 1 (10 points)

    can't help there...my remote works fine...never had an issue

  • Laorens Level 1 Level 1 (20 points)

    Hello

     

    You simply cannot modify the volume while using an HDMI connection because this is the end periphreal (the monitor) which manage sound level.

     

    You can check on the settings / Sound panel / Output.

    All available outputs are shown.

    As you see below my monitor is connected in HDMI.

     

    The lowest arrow shows the volume control is greyed out. And a short phrase says the control volume is [...] on the selected peripheral.

    Capture.JPG

     

    Last thing: if you press the volume up or volume down key on your keyboard, you shoud see a iforbidden grey sign.

    I hope this helps.

     

    By the way: did you try to insert then take out a headphone jack into the output?

     

    Best wishes

  • philhoggins Level 1 Level 1 (10 points)

    Soundflower over rides this.. I have full control of audio via keyboard and remote.  google soundflower and mini mac.

     

    Phil

  • Chenbmac Level 1 Level 1 (0 points)

    Hello everyone!

     

    First of all, thanks for all your help!

     

    After I posted this HMDI sound output issue, I've searched all over the internet for answer and I eventually I found an easy fix by accident.

     

     

    To have sound passing through my HDMI connection directly from my Mac Mini to my Monitor (using only the HDMI cable), in this case a SAMSUNG T27A550, I did the following:

     

    1 - Before your turn on your Mac or Monitor, make sure no analog Audio cable (3.5mm) is connected to your Mac Mini's output, neither to your Monitor analog Audio Input port.

     

    2 - Turn on both the Mac Mini and your Monitor.

     

    3 - In your MAC go to System Preferences/Sound/ --- In both the SOUND EFFECT and OUTPUT tabs designate your HDMI device as the OUTPUT source. In my case, my Monitor's model was the only choice available besides the INTERNAL SPEAKER (Built In Audio).

     

    4 - In your Monitor's remote control select SOURCE and scroll to the HDMI port (which will be highlighted) and press TOOLS (also on the remote control).

     

    5- Select EDIT NAME.

     

    6- Choose PC and hit Enter in the remote control.

     

    Play any audio and turn up the volume of your Monitor using its remote control. You should be able to listen to audio via your Monitor's speakers by this step.

     

    Bear in mind you won't have the usual Mac keyboard volume control. These will be disabled. You will have to control the volume using your Monitor volume control.

     

     

    If you want to have the Mac Mini's keyboard volume control, to the following:

     

    1 - Connect an analog audio cable to both your Mac Mini's output and your Monitor Audio Input.

     

    2 - Turn on both the Mac Mini and your Monitor.

     

    3 - In your MAC go to System Preferences/Sound/ --- In both the SOUND EFFECT and OUTPUT tabs designate your INTERNAL SPEAKER (Built In Audio). OBS: If you try to choose your HDMI option, the software won't allow it for some reason.

     

    4 - In your Monitor's remote control select SOURCE and scroll to the HDMI port (which will be highlighted) and press TOOLS (also on the remote control).

     

    5- Select EDIT NAME.

     

    6 - Choose DVI PC and hit Enter in the remote control.

     

    You should be able to listen to sound by this step from your Monitor's speakers. To control the volume, you can use both your Mac keyboard volume control and your Monitor Volume knob in the control remote.

     

     

    It is an easy fix, but it was quite tricky to figure it out.

     

    Anyway, I hope it helps anyone with the same issue.

     

     

    Cheers!!!

  • Cemoi Level 1 Level 1 (0 points)

    Hi,

    Merci beaucoup Chenbmac, your post help me solved the same issue on the Late-2012 Mac Mini I've just purchased.

     

    Now I don't need to turn off and on the Mac Mini: simply removing the jack from the Mini's headphones port sends the audio to my TV through HDMI. Connecting it back stops HDMI audio. No need to go through System Preferences.

     

    Strangely the Thunderbolt/Mini Displayport doesn't have the same (faulty?) behaviour: even when the jack is connected to the audio out port, I have audio in my monitor's speakers, which is connected through Displayport to the Mini.