5 Replies Latest reply: Jan 7, 2013 12:02 PM by Linc Davis
mwagena Level 1 Level 1



I'm getting a kernel panic every boot, this started after i upgraded my ram with corsair cmsa8gx3m2a1066c7.

The macbook is a March 2009 model, MacBookPro6,2


What should I do?


Thanks in advance.





Below a dump of the panic


Mon Jan  7 18:11:37 2013

panic(cpu 2 caller 0xffffff8011643d8e): "a freed zone element has been modified in zone: maps"@/SourceCache/xnu/xnu-2050.18.24/osfmk/kern/zalloc.c:219

Backtrace (CPU 2), Frame : Return Address

0xffffff80f9b6b950 : 0xffffff801161d626

0xffffff80f9b6b9c0 : 0xffffff8011643d8e

0xffffff80f9b6ba00 : 0xffffff80116435d2

0xffffff80f9b6bae0 : 0xffffff80116663f7

0xffffff80f9b6bb20 : 0xffffff8011667398

0xffffff80f9b6bc70 : 0xffffff801166887c

0xffffff80f9b6bd20 : 0xffffff801195b8fe

0xffffff80f9b6bf50 : 0xffffff80119e182a

0xffffff80f9b6bfb0 : 0xffffff80116ced33



BSD process name corresponding to current thread: launchd



Mac OS version:

Not yet set



Kernel version:

Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64

Kernel UUID: 69A5853F-375A-3EF4-9247-478FD0247333

Kernel slide:     0x0000000011400000

Kernel text base: 0xffffff8011600000

System model name: MacBookPro6,2 (Mac-F22586C8)



System uptime in nanoseconds: 1839492699

last loaded kext at 1774744721: com.apple.driver.AppleUSBTCButtons          235.4 (addr 0xffffff7f932ee000, size 20480)

loaded kexts:

com.apple.driver.AppleUSBTCButtons          235.4

com.apple.driver.AppleUSBCardReader          3.1.0

com.apple.driver.AppleUSBTCKeyEventDriver          235.4

com.apple.driver.AppleUSBTCKeyboard          235.4

com.apple.driver.AppleIRController          320.15

com.apple.iokit.SCSITaskUserClient          3.5.1

com.apple.driver.AppleFileSystemDriver          3.0.1

com.apple.AppleFSCompression.AppleFSCompressionTypeDataless          1.0.0d1

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib          1.0.0d1

com.apple.BootCache          34

com.apple.driver.XsanFilter          404

com.apple.iokit.IOAHCIBlockStorage          2.2.2

com.apple.driver.AppleFWOHCI          4.9.6

com.apple.driver.AppleUSBHub          5.2.5

com.apple.driver.AppleAHCIPort          2.4.1

com.apple.driver.AirPort.Brcm4331          602.15.22

com.apple.iokit.AppleBCM5701Ethernet          3.2.5b3

com.apple.driver.AppleUSBUHCI          5.2.5

com.apple.driver.AppleUSBEHCI          5.4.0

com.apple.driver.AppleEFINVRAM          1.6.1

com.apple.driver.AppleSmartBatteryManager          161.0.0

com.apple.driver.AppleACPIButtons          1.6

com.apple.driver.AppleRTC          1.5

com.apple.driver.AppleHPET          1.7

com.apple.driver.AppleSMBIOS          1.9

com.apple.driver.AppleACPIEC          1.6

com.apple.driver.AppleAPIC          1.6

com.apple.driver.AppleIntelCPUPowerManagementClient          196.0.0

com.apple.nke.applicationfirewall          4.0.39

com.apple.security.quarantine          2

com.apple.driver.AppleIntelCPUPowerManagement          196.0.0

com.apple.iokit.IOSCSIBlockCommandsDevice          3.5.1

com.apple.iokit.IOUSBMassStorageClass          3.5.0

com.apple.driver.AppleUSBMultitouch          235.7

com.apple.iokit.IOUSBHIDDriver          5.2.5

com.apple.driver.AppleUSBMergeNub          5.2.5

com.apple.driver.AppleUSBComposite          5.2.5

com.apple.iokit.IOSCSIMultimediaCommandsDevice          3.5.1

com.apple.iokit.IOBDStorageFamily          1.7

com.apple.iokit.IODVDStorageFamily          1.7.1

com.apple.iokit.IOCDStorageFamily          1.7.1

com.apple.iokit.IOAHCISerialATAPI          2.5.0

com.apple.iokit.IOSCSIArchitectureModelFamily          3.5.1

com.apple.iokit.IOFireWireFamily          4.5.5

com.apple.iokit.IOAHCIFamily          2.2.1

com.apple.iokit.IO80211Family          500.15

com.apple.iokit.IOEthernetAVBController          1.0.2b1

com.apple.iokit.IONetworkingFamily          3.0

com.apple.iokit.IOUSBUserClient          5.2.5

com.apple.iokit.IOUSBFamily          5.4.0

com.apple.driver.AppleEFIRuntime          1.6.1

com.apple.iokit.IOHIDFamily          1.8.0

com.apple.iokit.IOSMBusFamily          1.1

com.apple.security.sandbox          220

com.apple.kext.AppleMatch          1.0.0d1

com.apple.security.TMSafetyNet          7

com.apple.driver.DiskImages          344

com.apple.iokit.IOStorageFamily          1.8

com.apple.driver.AppleKeyStore          28.21

com.apple.driver.AppleACPIPlatform          1.6

com.apple.iokit.IOPCIFamily          2.7.2

com.apple.iokit.IOACPIFamily          1.4

com.apple.kec.corecrypto          1.0

MacBook Pro, OS X Mountain Lion (10.8.2)
Reply by Linc Davis on Jan 7, 2013 12:02 PM Helpful

If you have no panics with the original RAM, it's almost certain that the third-party RAM is at fault. I suggest you make a "Genius" appointment at an Apple Store to have the machine tested. There's nothing more I can tell you. Good luck.

All replies

  • Linc Davis Level 10 Level 10

    If you've recently upgraded the memory, reinstall the original memory and see whether there's any improvement. Be careful not to touch the gold contacts on the memory modules when handling them. If necessary, clean them with a mild solvent such as rubbing alcohol.


    The Apple Hardware Test, though generally unreliable, will sometimes detect memory faults. A negative test can't be depended on.

  • mwagena Level 1 Level 1

    I'm using the original memory as we speak, the weird thing is that its functioning normally.

    Have tried serveral different memory modules, all of the corsair brand, but all with the same error.


    I also tried one of the old rams and one of the new one but also without any success...

  • Linc Davis Level 10 Level 10

    If the new RAM doesn't work, you'll have to return it.

  • mwagena Level 1 Level 1

    I understand, but the strange thing is, the previous modules I used also had these problems.

    Is it possible something else is going on with my Macbook?


    So a recap:

    currently using the default modules. (4gb total)


    Previously used:

    Corsair Ram: CM3X8GSDKIT1066

    Corsair Ram for Mac: CMSA8GX3M2A1066C7

    Both with the same Kernel Panic

  • Linc Davis Level 10 Level 10

    If you have no panics with the original RAM, it's almost certain that the third-party RAM is at fault. I suggest you make a "Genius" appointment at an Apple Store to have the machine tested. There's nothing more I can tell you. Good luck.